aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb')
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb22
1 files changed, 10 insertions, 12 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
index 068b3d54f7..7ff9c2e1af 100644
--- a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
+++ b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
@@ -1,25 +1,29 @@
-require klibc.inc
SUMMARY = "The klcc crosscompiler for klibc"
-SRC_URI += "file://use-env-for-perl.patch"
-
+require klibc.inc
DEPENDS = "klibc"
FILESPATH =. "${FILE_DIRNAME}/klibc-${PV}:"
+SRC_URI += "file://use-env-for-perl.patch"
+
inherit cross
+# disable task already run in klibc recipe
+do_configure[noexec] = "1"
do_compile() {
oe_runmake 'INSTALLDIR=${STAGING_DIR_TARGET}${target_libdir}/klibc' klcc
}
-
+# The linux-libc-headers and klibc custom headers are not machine-specific
+# but are installed into machine sysroot.
+# Klcc wrapper is hardcoding some of these paths thus, to keep the recipe
+# arch-specific, we force the rebuild of klcc-cross for each machine.
+do_compile[vardeps] += "MACHINE"
do_install() {
install -d ${D}${bindir}
install -m 0755 klcc/klcc ${D}${bindir}/${TARGET_PREFIX}klcc
}
-# disable task already run in klibc recipe
-do_configure[noexec] = "1"
# disable unneeded tasks
do_package[noexec] = "1"
@@ -28,9 +32,3 @@ do_package_write_ipk[noexec] = "1"
do_package_write_rpm[noexec] = "1"
do_package_write_deb[noexec] = "1"
do_package_write_tar[noexec] = "1"
-
-# The linux-libc-headers and klibc custom headers are not machine-specific
-# but are installed into machine sysroot.
-# Klcc wrapper is hardcoding som eof these paths thus, to keep te recipe
-# arch-specific, we force the rebuild of klcc-cross for each machine.
-do_compile[vardeps] += "MACHINE"