aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb')
-rw-r--r--meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
new file mode 100644
index 0000000000..5e680c4640
--- /dev/null
+++ b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
@@ -0,0 +1,20 @@
+# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
+HOMEPAGE = "https://github.com/graeme-hill/crossguid"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
+DEPENDS += "util-linux"
+
+SRCREV = "ca1bf4b810e2d188d04cb6286f957008ee1b7681"
+SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https;branch=master \
+ file://0001-include-missing-cstdint.patch"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+do_install:append() {
+ sed -i -e 's|${STAGING_DIR_HOST}||g' ${D}${datadir}/crossguid/cmake/crossguid-config.cmake
+}