aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/cannelloni
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/cannelloni')
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch43
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch37
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch32
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb (renamed from meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb)11
4 files changed, 41 insertions, 82 deletions
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch
deleted file mode 100644
index b78f0b3291..0000000000
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From c74f04dbab4d586287347b1d5517f36e2f0c3d8e Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 19 Dec 2019 15:52:34 -0800
-Subject: [PATCH] Use GNUInstallDirs instead of hard-coding paths
-
-Bump minimum cmake version to be >= 3.1
-
-Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 51b354f..958e0eb 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,4 +1,4 @@
--cmake_minimum_required(VERSION 2.6)
-+cmake_minimum_required(VERSION 3.1)
- project(cannelloni)
-
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
-@@ -60,6 +60,8 @@ set_target_properties ( cannelloni-common
- SOVERSION 0
- )
-
-+include(GNUInstallDirs)
-+
- if(SCTP_SUPPORT)
- add_library(sctpthread STATIC sctpthread.cpp)
- target_link_libraries(sctpthread addsources sctp)
-@@ -68,5 +70,5 @@ endif(SCTP_SUPPORT)
- set_target_properties(addsources PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
- target_link_libraries(cannelloni addsources cannelloni-common pthread)
-
--install(TARGETS cannelloni DESTINATION bin)
--install(TARGETS cannelloni-common DESTINATION lib)
-+install(TARGETS cannelloni DESTINATION ${CMAKE_INSTALL_BINDIR})
-+install(TARGETS cannelloni-common DESTINATION ${CMAKE_INSTALL_LIBDIR})
---
-2.24.1
-
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch
new file mode 100644
index 0000000000..71f447c94b
--- /dev/null
+++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch
@@ -0,0 +1,37 @@
+From 7aed36765ae44b41ede7e139da0a11b3696f2e06 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 13 Nov 2023 00:07:23 -0800
+Subject: [PATCH] include bits/stdc++.h only when using libstdc++
+
+We have other c++ runtime implementations e.g. llvm's libc++ which does
+not provide this header bits/stdc++.h, therefore make sure that this
+header is only included when using libstdc++
+
+Fixes
+| /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux/cannelloni/1.1.0/git/tcpthread.cpp:27:10: fatal error: 'bits/stdc++.h' file not found
+| 27 | #include <bits/stdc++.h>
+| | ^~~~~~~~~~~~~~~
+
+Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/56]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tcpthread.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tcpthread.cpp b/tcpthread.cpp
+index a1b3047..bb5a7b2 100644
+--- a/tcpthread.cpp
++++ b/tcpthread.cpp
+@@ -24,7 +24,9 @@
+ #include <cstdint>
+ #include <cstdio>
+
++#ifdef __GLIBCXX__
+ #include <bits/stdc++.h>
++#endif
+
+ #include <linux/can.h>
+ #include <string.h>
+--
+2.42.1
+
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
deleted file mode 100644
index 55f28dd672..0000000000
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 1788762863cd1f657697575f6e73a22e661ccb43 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 23 Dec 2019 10:32:54 -0800
-Subject: [PATCH 2/2] include missing <stdexcept> for runtime_error
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes
-error: ‘runtime_error’ is not a member of ‘std’
-
-Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- parser.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/parser.cpp b/parser.cpp
-index 4afb9e0..5bcdbde 100644
---- a/parser.cpp
-+++ b/parser.cpp
-@@ -2,6 +2,7 @@
-
- #include <arpa/inet.h>
- #include <string.h>
-+#include <stdexcept>
-
- void parseFrames(uint16_t len, const uint8_t* buffer, std::function<canfd_frame*()> frameAllocator,
- std::function<void(canfd_frame*, bool)> frameReceiver)
---
-2.24.1
-
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb
index d4a62bd92d..dfa7437ba8 100644
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb
+++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb
@@ -1,14 +1,11 @@
SUMMARY = "a SocketCAN over Ethernet tunnel"
HOMEPAGE = "https://github.com/mguentner/cannelloni"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
-SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https \
- file://0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch \
- file://0002-include-missing-stdexcept-for-runtime_error.patch \
+SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https;branch=master \
+ file://0001-include-bits-stdc-.h-only-when-using-libstdc.patch \
"
-SRCREV = "82aa49b417b96fe46bb3f017ae1bfea928f20f9a"
-
-PV = "20160414+${SRCPV}"
+SRCREV = "3d4fb8c8b07f6d7c62b2bdad7e5a94de61c9a29b"
LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"