aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/dibbler/dibbler_git.bb')
-rw-r--r--meta-networking/recipes-connectivity/dibbler/dibbler_git.bb26
1 files changed, 18 insertions, 8 deletions
diff --git a/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb b/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb
index 8890e14318..cc36fbd4f0 100644
--- a/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb
+++ b/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb
@@ -2,14 +2,17 @@ SUMMARY = "Dibbler DHCPv6 client"
DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6."
HOMEPAGE = "http://klub.com.pl/dhcpv6"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
-SRCREV = "c4b0ed52e751da7823dd9a36e91f93a6310e5525"
+SRCREV = "a7c6cf58a88a510cb00841351e75030ce78d36bf"
-SRC_URI = "git://github.com/tomaszmrugalski/dibbler \
+SRC_URI = "git://github.com/tomaszmrugalski/dibbler;branch=master;protocol=https \
file://dibbler_fix_getSize_crash.patch \
- "
+ file://0001-port-linux-Re-order-header-includes.patch \
+ file://0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch \
+ file://0002-make-Do-not-enforce-c99.patch \
+ "
PV = "1.0.1+1.0.2RC1+git${SRCREV}"
S = "${WORKDIR}/git"
@@ -29,9 +32,16 @@ inherit autotools
DEPENDS += "flex-native"
+CPPFLAGS += "-D_GNU_SOURCE -Dregister=''"
+LDFLAGS += "-pthread"
+
PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server"
-FILES_${PN}-client = "${sbindir}/${PN}-client"
-FILES_${PN}-relay = "${sbindir}/${PN}-relay"
-FILES_${PN}-requestor = "${sbindir}/${PN}-requestor"
-FILES_${PN}-server = "${sbindir}/${PN}-server"
+FILES:${PN}-client = "${sbindir}/${PN}-client"
+FILES:${PN}-relay = "${sbindir}/${PN}-relay"
+FILES:${PN}-requestor = "${sbindir}/${PN}-requestor"
+FILES:${PN}-server = "${sbindir}/${PN}-server"
+
+# http://errors.yoctoproject.org/Errors/Details/766880/
+# git/Port-linux/interface.c:118:18: error: assignment to '__caddr_t' {aka 'char *'} from incompatible pointer type 'struct ethtool_value *' [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"