aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-devtools/python')
-rw-r--r--meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb31
-rw-r--r--meta-networking/recipes-devtools/python/python3-scapy/run-ptest4
-rw-r--r--meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb44
3 files changed, 48 insertions, 31 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb b/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb
deleted file mode 100644
index f46ddbf449..0000000000
--- a/meta-networking/recipes-devtools/python/python3-ldap_3.2.0.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-# Copyright (C) 2012 Wind River Systems, Inc.
-#
-SUMMARY = "Provides a wrapper in Python to LDAP"
-DESCRIPTION = "This module provides access to the LDAP \
-(Lightweight Directory Access Protocol) through Python operations \
-instead of C API. The module mainly acts as a wrapper for the \
-OpenLDAP 2.x libraries. Errors will appear as exceptions."
-
-LICENSE = "PSF"
-HOMEPAGE = "http://www.python-ldap.org/"
-DEPENDS = "python3 openldap cyrus-sasl"
-
-PYPI_PACKAGE = "python-ldap"
-inherit pypi setuptools3
-
-LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
-SRC_URI[md5sum] = "fe22522208dc9b06d16eb70f8553eaab"
-SRC_URI[sha256sum] = "7d1c4b15375a533564aad3d3deade789221e450052b21ebb9720fb822eccdb8e"
-
-do_configure_prepend() {
- sed -i -e 's:^library_dirs =.*::' ${S}/setup.cfg
- sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' ${S}/setup.cfg
-}
-
-RDEPENDS_${PN} = " \
- ${PYTHON_PN}-pprint \
- ${PYTHON_PN}-threading \
- ${PYTHON_PN}-pyasn1 \
- ${PYTHON_PN}-pyasn1-modules \
-"
diff --git a/meta-networking/recipes-devtools/python/python3-scapy/run-ptest b/meta-networking/recipes-devtools/python/python3-scapy/run-ptest
new file mode 100644
index 0000000000..417e21053c
--- /dev/null
+++ b/meta-networking/recipes-devtools/python/python3-scapy/run-ptest
@@ -0,0 +1,4 @@
+#!/bin/sh
+python3 UTscapy.py -t regression.uts -f text -l -C \
+ -o @PTEST_PATH@/scapy_ptest_$(date +%Y%m%d-%H%M%S).log \
+ 2>&1 | sed -e 's/^passed None/PASS:/' -e 's/^failed None/FAIL:/'
diff --git a/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb
new file mode 100644
index 0000000000..d57cb977e4
--- /dev/null
+++ b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Network scanning and manipulation tool"
+DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. \
+It is able to forge or decode packets of a wide number of protocols, send \
+them on the wire, capture them, match requests and replies, and much more. \
+It can easily handle most classical tasks like scanning, tracerouting, probing, \
+unit tests, attacks or network discovery (it can replace hping, 85% of nmap, \
+arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very \
+well at a lot of other specific tasks that most other tools can't handle, like \
+sending invalid frames, injecting your own 802.11 frames, combining technics \
+(VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
+SECTION = "security"
+LICENSE = "GPL-2.0-only"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+# If you want ptest support, use the git repo
+# UTscapy does not exist in the pypi pkg
+#
+SRCREV = "0474c37bf1d147c969173d52ab3ac76d2404d981"
+SRC_URI = "git://github.com/secdev/scapy.git;branch=master;protocol=https \
+ file://run-ptest"
+
+S = "${WORKDIR}/git"
+
+UPSTREAM_CHECK_COMMITS = "1"
+
+inherit setuptools3 ptest
+
+do_install:append() {
+ mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
+}
+
+do_install_ptest() {
+ install -m 0644 ${S}/scapy/tools/UTscapy.py ${D}${PTEST_PATH}
+ install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
+ sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
+}
+
+RDEPENDS:${PN} = "tcpdump python3-compression python3-cryptography python3-netclient \
+ python3-netserver python3-pydoc python3-pkgutil python3-shell \
+ python3-threading python3-numbers python3-fcntl python3-logging \
+ python3-difflib"
+RDEPENDS:${PN}-ptest += "python3-json python3-mock python3-multiprocessing \
+ iproute2 tshark"