aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/radvd/radvd.inc2
-rw-r--r--meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.0.bb2
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb2
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb2
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb2
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta-networking/recipes-daemons/radvd/radvd.inc b/meta-networking/recipes-daemons/radvd/radvd.inc
index d8b3893392..ededf9ad25 100644
--- a/meta-networking/recipes-daemons/radvd/radvd.inc
+++ b/meta-networking/recipes-daemons/radvd/radvd.inc
@@ -18,7 +18,7 @@ SRC_URI = "http://v6web.litech.org/radvd/dist/radvd-${PV}.tar.gz \
file://radvd.init \
file://volatiles.03_radvd"
-inherit autotools update-rc.d useradd
+inherit autotools update-rc.d useradd pkgconfig
do_install_append () {
install -m 0755 -d ${D}${sysconfdir}/init.d \
diff --git a/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.0.bb b/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.0.bb
index 49ef0732c6..0cc1398408 100644
--- a/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.0.bb
+++ b/meta-networking/recipes-filter/conntrack-tools/conntrack-tools_1.4.0.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
SRC_URI[tar.md5sum] = "ee737c774e01349f75e935228a2d851b"
SRC_URI[tar.sha256sum] = "036b032a5c4d180aad686df21399d74506b9b3d3000794eb13ac313482e24896"
-inherit autotools-brokensep update-rc.d
+inherit autotools-brokensep update-rc.d pkgconfig
INITSCRIPT_NAME = "conntrackd"
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
index 29e54c4824..f733a7832f 100644
--- a/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
@@ -13,7 +13,7 @@ SRC_URI[sha256sum] = "75592483d40dc4f76cc3b41af40caa4be80478946a699d46846d5d03e4
DEPENDS = "openssl xz zlib bzip2 libcap"
-inherit autotools
+inherit autotools pkgconfig
PACKAGECONFIG ??= " \
${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
index 5fc0de3151..d8e1ddbba2 100644
--- a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -14,7 +14,7 @@ SRCREV = "a1d9615adde6d1a568813c24a128273ed755af04"
S = "${WORKDIR}/git"
-inherit autotools python-dir
+inherit autotools python-dir pkgconfig
CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools"
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 5a301e3098..d6ca30fb65 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -16,7 +16,7 @@ DEPENDS += "augeas libnl libxslt libxml2 gnulib"
S = "${WORKDIR}/git"
-inherit gettext autotools-brokensep
+inherit gettext autotools-brokensep pkgconfig
EXTRA_OECONF_append_class-target = " --with-driver=redhat"
do_configure_prepend() {
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb b/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb
index f8116e3d07..821d965eac 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.1.1.bb
@@ -31,7 +31,7 @@ PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4,"
PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,"
-inherit autotools systemd
+inherit autotools systemd pkgconfig
RRECOMMENDS_${PN} = "kernel-module-ipsec"