aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_1.12.5.bb (renamed from meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb)16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.5.bb
index 99ff5d0628..32d0ab92c9 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.5.bb
@@ -6,15 +6,12 @@ LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
DEPENDS = "perl-native pcre expat glib-2.0 sbc"
-SRC_URI = " \
- http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \
- file://Do-not-set-CC_FOR_BUILD-flags.patch \
-"
+SRC_URI = "https://2.na.dl.wireshark.org/src/wireshark-${PV}.tar.bz2"
PE = "1"
-SRC_URI[md5sum] = "acfa156fd35cb66c867b1ace992e4b5b"
-SRC_URI[sha256sum] = "de804e98e252e4b795d28d6ac2d48d7f5aacd9b046ee44d44266983795ebc312"
+SRC_URI[md5sum] = "9ee199dde4f36a3d71f7b81dd6764e93"
+SRC_URI[sha256sum] = "d0f177b2ef49e4deae4ff7d3299bdd295ba558a3934ce8ae489b2f13927cbd82"
inherit autotools pkgconfig
@@ -23,11 +20,12 @@ ARM_INSTRUCTION_SET = "arm"
# Works with either gtk+ or gtk3.
WHICH_GTK = "gtk3"
-PACKAGECONFIG ??= "libcap gnutls libnl"
+PACKAGECONFIG ?= "libpcap gnutls libnl libcap"
PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
-PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_DIR_HOST}, --with-libcap=no, libcap"
+PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
+PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
@@ -46,7 +44,7 @@ PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns"
PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
-EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --with-pcap=no --enable-pcap-ng-default"
+EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --enable-rawshark"
do_configure_prepend() {
# force to use fallback