aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb')
-rw-r--r--meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb29
1 files changed, 15 insertions, 14 deletions
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb b/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb
index b55bd51619..6fad255c89 100644
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb
+++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb
@@ -1,7 +1,7 @@
SUMMARY = "lm_sensors configuration files"
DESCRIPTION = "Hardware health monitoring configuration files"
HOMEPAGE = "http://www.lm-sensors.org/"
-LICENSE = "MIT-X"
+LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -12,30 +12,31 @@ SRC_URI = "file://fancontrol \
file://sensors.conf \
file://sensord \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
PACKAGECONFIG ??= "sensord"
PACKAGECONFIG[sensord] = ",,"
-RDEPENDS_${PN}-dev = ""
+RDEPENDS:${PN}-dev = ""
do_install() {
# Install fancontrol configuration file
install -d ${D}${sysconfdir}/sysconfig
- install -m 0644 ${WORKDIR}/fancontrol ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/sensord ${D}${sysconfdir}/sysconfig
+ install -m 0644 ${UNPACKDIR}/fancontrol ${D}${sysconfdir}
+ install -m 0644 ${UNPACKDIR}/sensord ${D}${sysconfdir}/sysconfig
# Install libsensors configuration file
install -d ${D}${sysconfdir}/sensors.d
- install -m 0644 ${WORKDIR}/sensors.conf ${D}${sysconfdir}/sensors.d
+ install -m 0644 ${UNPACKDIR}/sensors.conf ${D}${sysconfdir}/sensors.d
if ${@bb.utils.contains('PACKAGECONFIG', 'sensord', 'true', 'false', d)}; then
# Install sensord configuration file
- install -m 0644 ${WORKDIR}/sensord.conf ${D}${sysconfdir}
+ install -m 0644 ${UNPACKDIR}/sensord.conf ${D}${sysconfdir}
# Install sensord.cgi script and create world-writable
# web-accessible sensord directory
install -d ${D}/www/pages/cgi-bin
- install -m 0755 ${WORKDIR}/sensord.cgi ${D}/www/pages/cgi-bin
+ install -m 0755 ${UNPACKDIR}/sensord.cgi ${D}/www/pages/cgi-bin
install -d -m a=rwxs ${D}/www/pages/sensord
fi
}
@@ -51,18 +52,18 @@ PACKAGES =+ "${PN}-fancontrol"
# sensord web cgi support
PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'sensord', '${PN}-cgi', '', d)}"
-RRECOMMENDS_${PN}-cgi = "lighttpd lighttpd-module-cgi"
-RDEPENDS_${PN}-cgi = "${PN}-sensord rrdtool"
-FILES_${PN}-cgi = "/www/*"
+RRECOMMENDS:${PN}-cgi = "lighttpd lighttpd-module-cgi"
+RDEPENDS:${PN}-cgi = "${PN}-sensord rrdtool"
+FILES:${PN}-cgi = "/www/*"
# libsensors configuration file
-FILES_${PN}-libsensors = "${sysconfdir}/sensors.d/sensors.conf"
+FILES:${PN}-libsensors = "${sysconfdir}/sensors.d/sensors.conf"
# sensord logging daemon configuration files
-FILES_${PN}-sensord = "\
+FILES:${PN}-sensord = "\
${sysconfdir}/sensord.conf \
${sysconfdir}/sysconfig/sensord \
"
# fancontrol script configuration file
-FILES_${PN}-fancontrol = "${sysconfdir}/fancontrol"
+FILES:${PN}-fancontrol = "${sysconfdir}/fancontrol"