aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto/libkcapi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-crypto/libkcapi')
-rw-r--r--meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb28
-rw-r--r--meta-oe/recipes-crypto/libkcapi/libkcapi_1.5.0.bb32
2 files changed, 32 insertions, 28 deletions
diff --git a/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb b/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb
deleted file mode 100644
index b478e4c580..0000000000
--- a/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
-HOMEPAGE = "http://www.chronox.de/libkcapi.html"
-LICENSE = "BSD | GPL-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54"
-
-DEPENDS = "libtool"
-
-S = "${WORKDIR}/git"
-SRCREV = "8397f0f7c45264a3b9aff5a1f9119df25eeb4c60"
-SRC_URI = "git://github.com/smuellerDD/libkcapi.git"
-
-inherit autotools
-
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
-PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
-
-do_install_append() {
- # bindir contains testapp and apps. However it is always created, even
- # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
- rmdir --ignore-fail-on-non-empty ${D}${bindir}
-
- # Remove the generated binary checksum files
- rm -f ${D}${bindir}/.*.hmac
- rm -f ${D}${libdir}/.*.hmac
-}
-
-CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"
diff --git a/meta-oe/recipes-crypto/libkcapi/libkcapi_1.5.0.bb b/meta-oe/recipes-crypto/libkcapi/libkcapi_1.5.0.bb
new file mode 100644
index 0000000000..a34614dd9d
--- /dev/null
+++ b/meta-oe/recipes-crypto/libkcapi/libkcapi_1.5.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
+HOMEPAGE = "https://www.chronox.de/libkcapi/index.html"
+LICENSE = "BSD-3-Clause | GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3d8a091d797491204567185a6efce70f"
+
+S = "${WORKDIR}/git"
+SRCREV = "fc937358e71253a6efaa3ba74885364976b040ea"
+SRC_URI = "git://github.com/smuellerDD/libkcapi.git;branch=master;protocol=https \
+ "
+
+inherit autotools
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
+PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
+PACKAGECONFIG[hasher_only] = "--enable-kcapi-hasher --disable-lib-kdf --disable-lib-sym --disable-lib-aead --disable-lib-rng,,,"
+
+do_install:append() {
+ # bindir contains testapp and apps. However it is always created, even
+ # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
+ rmdir --ignore-fail-on-non-empty ${D}${bindir}
+
+ # Remove the generated binary checksum files
+ rm -f ${D}${bindir}/.*.hmac
+ rm -f ${D}${libdir}/.*.hmac
+}
+
+CPPFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare"
+CPPFLAGS:remove:libc-musl:toolchain-clang = "-Wno-error=sign-conversion"
+CPPFLAGS:append:libc-musl = " -Wno-error=sign-conversion"
+
+BBCLASSEXTEND = "native"