aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
index 0c07b128bb..9ae25bb650 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
@@ -3,11 +3,13 @@ HOMEPAGE = "http://c9.io"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
-PR = "r2"
+PR = "r4"
# Nodejs-native for node-waf, nodejs4-native for the headers
DEPENDS = "libxml2 nodejs-native nodejs4-native"
+inherit systemd
+
SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \
@@ -33,6 +35,7 @@ SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglify-js \
file://index.js \
file://cloud9-avahi.service \
+ file://cloud9.service \
file://0001-ide-use-node-as-interpreter-for-sketches-instead-of-.patch \
"
@@ -97,6 +100,9 @@ do_install () {
install -m 0755 -d ${D}${sysconfdir}/avahi/services/
install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system
}
FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug \
@@ -104,3 +110,8 @@ FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o
"
RDEPENDS_${PN} = "nodejs4 nodejs gzip"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "cloud9.service"