aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/smemstat/smemstat_0.02.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/smemstat/smemstat_0.02.13.bb')
-rw-r--r--meta-oe/recipes-devtools/smemstat/smemstat_0.02.13.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/smemstat/smemstat_0.02.13.bb b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.13.bb
new file mode 100644
index 0000000000..bf5c52fe50
--- /dev/null
+++ b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.13.bb
@@ -0,0 +1,22 @@
+SUMMARY = "smemstat reports the physical memory usage taking into consideration shared memory"
+HOMEPAGE = "https://github.com/ColinIanKing/smemstat"
+LICENSE = "GPL-2.0-or-later"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "ncurses"
+
+SRC_URI = "git://github.com/ColinIanKing/smemstat.git;protocol=https;branch=master"
+SRCREV = "1edc560602aa116b96408110b8b9d66a4edef60e"
+
+S = "${WORKDIR}/git"
+
+inherit bash-completion
+
+do_compile () {
+ oe_runmake smemstat
+}
+
+do_install () {
+ oe_runmake DESTDIR=${D} install
+}