aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb')
-rw-r--r--meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb31
1 files changed, 24 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
index 1638c41c88..e9508b6d4b 100644
--- a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
+++ b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
@@ -2,29 +2,33 @@ SUMMARY = "pam-ssh-agent-auth"
DESCRIPTION = "A PAM module which permits authentication via ssh-agent."
HOMEPAGE = "http://sourceforge.net/projects/pamsshagentauth/"
SECTION = "libs"
-LICENSE = "openssl & BSD"
+LICENSE = "OpenSSL & BSD-2-Clause & BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.OpenSSL;md5=8ab01146141ded59b75f8ba7811ed05a \
file://OPENSSH_LICENSE;md5=7ae09218173be1643c998a4b71027f9b \
"
-SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2"
+SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2 \
+ file://0001-Adapt-to-OpenSSL-1.1.1.patch \
+ file://0002-Check-against-the-correct-OPENSSL_VERSION_NUMBER.patch \
+ file://0001-configure-Include-stdio.h-for-printf.patch \
+ "
SRC_URI[md5sum] = "8dbe90ab3625e545036333e6f51ccf1d"
SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763"
DEPENDS += "libpam openssl"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "pam"
# This gets us ssh-agent, which we are almost certain to want.
#
-RDEPENDS_${PN} += "openssh-misc"
+RDEPENDS:${PN} += "openssh-misc"
# Kind of unfortunate to have underscores in the name.
#
S = "${WORKDIR}/pam_ssh_agent_auth-${PV}"
-inherit autotools-brokensep
+inherit autotools-brokensep perlnative
# Avoid autoreconf. Override the --libexec oe_runconf specifies so that
# the module is put with the other pam modules. Because it cannot, in general,
@@ -47,5 +51,18 @@ do_compile () {
# This stuff is not any place looked at by default.
#
-FILES_${PN} += "${base_libdir}/security/pam*"
-FILES_${PN}-dbg += "${base_libdir}/security/.debug"
+FILES:${PN} += "${base_libdir}/security/pam*"
+FILES:${PN}-dbg += "${base_libdir}/security/.debug"
+
+# This one is reproducible only on 32bit MACHINEs
+# http://errors.yoctoproject.org/Errors/Details/766965/
+# ssh-rsa.c:59:24: error: passing argument 1 of 'EVP_DigestInit' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-rsa.c:60:26: error: passing argument 1 of 'EVP_DigestUpdate' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-rsa.c:61:25: error: passing argument 1 of 'EVP_DigestFinal' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-ecdsa.c:76:18: error: passing argument 1 of 'DSA_SIG_get0' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-ecdsa.c:76:23: error: passing argument 2 of 'DSA_SIG_get0' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-ecdsa.c:76:27: error: passing argument 3 of 'DSA_SIG_get0' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-ecdsa.c:148:18: error: passing argument 1 of 'DSA_SIG_get0' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-ecdsa.c:148:23: error: passing argument 2 of 'DSA_SIG_get0' from incompatible pointer type [-Wincompatible-pointer-types]
+# ssh-ecdsa.c:148:27: error: passing argument 3 of 'DSA_SIG_get0' from incompatible pointer type [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"