aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r--meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch20
-rw-r--r--meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb32
-rw-r--r--meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb33
3 files changed, 85 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch b/meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch
new file mode 100644
index 0000000000..67b85470d3
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch
@@ -0,0 +1,20 @@
+Index: gobject-introspection-0.9.10/tools/g-ir-annotation-tool.in
+===================================================================
+--- gobject-introspection-0.9.10.orig/tools/g-ir-annotation-tool.in
++++ gobject-introspection-0.9.10/tools/g-ir-annotation-tool.in
+@@ -1,4 +1,4 @@
+-#!@PYTHON@
++#!/usr/bin/env python
+ # -*- Mode: Python -*-
+ # GObject-Introspection - a framework for introspecting GObject libraries
+ # Copyright (C) 2008 Johan Dahlin
+Index: gobject-introspection-0.9.10/tools/g-ir-scanner.in
+===================================================================
+--- gobject-introspection-0.9.10.orig/tools/g-ir-scanner.in
++++ gobject-introspection-0.9.10/tools/g-ir-scanner.in
+@@ -1,4 +1,4 @@
+-#!@PYTHON@
++#!/usr/bin/env python
+ # -*- Mode: Python -*-
+ # GObject-Introspection - a framework for introspecting GObject libraries
+ # Copyright (C) 2008 Johan Dahlin
diff --git a/meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb b/meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb
new file mode 100644
index 0000000000..f1a46a10b2
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb
@@ -0,0 +1,32 @@
+# NOTE: WIP! This recipe does not cross-compile atm., only -native
+SECTION = "libs"
+DEPENDS = "glib-2.0 libffi bison-native"
+BBCLASSEXTEND = "native"
+PR = "r1"
+
+LICENSE = "GPLv2+ & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=90d577535a3898e1ae5dbf0ae3509a8c \
+ file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7"
+
+SRC_URI[md5sum] = "e5cd63d6bcc5c105e898e7c33cf42175"
+SRC_URI[sha256sum] = "4bf244db75df04499dea704e7734376c0fc5a3a17fb59be2123c8d76111e6fb8"
+
+SRC_URI = "\
+ ${GNOME_MIRROR}/gobject-introspection/0.9/${BPN}-${PV}.tar.bz2 \
+ file://use-usr-bin-env-for-python.patch \
+"
+S = "${WORKDIR}/${BPN}-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ touch -f gtk-doc.make
+}
+
+EXTRA_OECONF = "\
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf \
+ --disable-tests \
+"
diff --git a/meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb b/meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb
new file mode 100644
index 0000000000..2a7f30c11c
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb
@@ -0,0 +1,33 @@
+# NOTE: WIP! This recipe does not cross-compile atm., only -native
+DEPENDS = "glib-2.0 libffi python-native gobject-introspection-native"
+DEPENDS_virtclass-native = "libffi-native python-native bison-native flex-native"
+BBCLASSEXTEND = "native"
+
+SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
+ file://use-usr-bin-env-for-python.patch \
+"
+
+LICENSE = "GPLv2+ & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING.tools;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.lib;md5=3bf50002aefd002f49e7bb854063f7e7"
+
+SRCREV = "8d64bc23d2b837421ecf9c7b0e4b8d5d95ca0d21"
+PV = "1.29.0+gitr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+BBCLASSEXTEND = "native"
+
+do_configure_prepend () {
+ echo "EXTRA_DIST = " > ${S}/gtk-doc.make
+}
+
+EXTRA_OECONF = "\
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf \
+ --disable-tests \
+"