aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch')
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch138
1 files changed, 138 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch b/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
new file mode 100644
index 0000000000..5232e2a1d8
--- /dev/null
+++ b/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
@@ -0,0 +1,138 @@
+Description: Debian forbids calls to external websites.
+
+Author: Gianfranco Costamagna <locutus@debian.org>
+Origin: Debian
+Forwarded: not-needed
+Reviewed-By: Gianfranco Costamagna <locutusofborg@debian.org>
+Last-Update: 2015-11-25
+
+Index: cpprest/Release/tests/functional/http/client/CMakeLists.txt
+===================================================================
+--- cpprest.orig/Release/tests/functional/http/client/CMakeLists.txt
++++ cpprest/Release/tests/functional/http/client/CMakeLists.txt
+@@ -12,7 +12,6 @@
+ multiple_requests.cpp
+ oauth1_tests.cpp
+ oauth2_tests.cpp
+- outside_tests.cpp
+ pipeline_stage_tests.cpp
+ progress_handler_tests.cpp
+ proxy_tests.cpp
+Index: cpprest/Release/tests/functional/http/client/authentication_tests.cpp
+===================================================================
+--- cpprest.orig/Release/tests/functional/http/client/authentication_tests.cpp
++++ cpprest/Release/tests/functional/http/client/authentication_tests.cpp
+@@ -675,9 +675,9 @@
+ VERIFY_ARE_EQUAL(return_code, response.status_code());
+ }
+
+- TEST(auth_no_data) { auth_test_impl(false); }
++ //TEST(auth_no_data) { auth_test_impl(false); }
+
+- TEST(unsuccessful_auth_with_basic_cred) { auth_test_impl(true); }
++ //TEST(unsuccessful_auth_with_basic_cred) { auth_test_impl(true); }
+
+ TEST_FIXTURE(uri_address, set_user_options_asio_http)
+ {
+@@ -695,6 +695,7 @@
+ VERIFY_ARE_EQUAL(200, response.status_code());
+ }
+
++ /*
+ TEST_FIXTURE(uri_address, set_user_options_asio_https)
+ {
+ handle_timeout([] {
+@@ -714,6 +715,7 @@
+ VERIFY_IS_FALSE(v.empty());
+ });
+ }
++ */
+
+ #endif
+
+Index: cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp
+===================================================================
+--- cpprest.orig/Release/tests/functional/websockets/client/authentication_tests.cpp
++++ cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp
+@@ -93,6 +93,7 @@
+ return false;
+ }
+
++ /*
+ TEST(ssl_test)
+ {
+ websocket_client client;
+@@ -127,6 +128,7 @@
+ throw;
+ }
+ }
++ */
+
+ // These tests are specific to our websocketpp based implementation.
+ #if !defined(__cplusplus_winrt)
+@@ -159,12 +161,14 @@
+ }
+ }
+
++ /*
+ // Test specifically for server SignalR team hit interesting cases with.
+ TEST(sni_with_older_server_test)
+ {
+ websocket_client client;
+ sni_test_impl(client);
+ }
++ */
+
+ // WinRT doesn't expose option for disabling.
+ // No stable server is available to reliably test this.
+@@ -194,6 +198,7 @@
+ }
+ }
+
++ /*
+ // Winrt doesn't allow explicitly setting server host for SNI.
+ TEST(sni_explicit_hostname)
+ {
+@@ -204,6 +209,7 @@
+ websocket_client client(config);
+ sni_test_impl(client);
+ }
++ */
+
+ void handshake_error_test_impl(const ::utility::string_t& host)
+ {
+@@ -225,11 +231,11 @@
+ }
+ }
+
+- TEST(self_signed_cert) { handshake_error_test_impl(U("wss://self-signed.badssl.com/")); }
++ //TEST(self_signed_cert) { handshake_error_test_impl(U("wss://self-signed.badssl.com/")); }
+
+- TEST(hostname_mismatch) { handshake_error_test_impl(U("wss://wrong.host.badssl.com/")); }
++ //TEST(hostname_mismatch) { handshake_error_test_impl(U("wss://wrong.host.badssl.com/")); }
+
+- TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
++ //TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
+
+ #endif
+
+Index: cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
+===================================================================
+--- cpprest.orig/Release/tests/functional/http/client/connections_and_errors.cpp
++++ cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
+@@ -406,6 +406,7 @@
+ }
+ #endif
+
++ /*
+ // Try to connect to a server on a closed port and cancel the operation.
+ TEST_FIXTURE(uri_address, cancel_bad_port)
+ {
+@@ -437,6 +438,7 @@
+
+ VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled);
+ }
++ */
+
+ } // SUITE(connections_and_errors)
+