aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset/fbset-modes.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/fbset/fbset-modes.bb')
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset-modes.bb b/meta-oe/recipes-support/fbset/fbset-modes.bb
index 5f6f9909b9..fcaf31795b 100644
--- a/meta-oe/recipes-support/fbset/fbset-modes.bb
+++ b/meta-oe/recipes-support/fbset/fbset-modes.bb
@@ -4,20 +4,19 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PV = "0.1.0"
-PR = "r6"
SRC_URI = "file://fb.modes"
-S = "${WORKDIR}"
+
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_install() {
install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
+ install -m 0644 ${UNPACKDIR}/fb.modes ${D}${sysconfdir}
}
-inherit allarch
-
# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
PACKAGE_ARCH = "${MACHINE_ARCH}"
-CONFFILES_${PN} = "${sysconfdir}/fb.modes"
+CONFFILES:${PN} = "${sysconfdir}/fb.modes"