aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/glog')
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-Change-SleepForMilliseconds-parameter-from-unsigned-.patch33
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch71
-rw-r--r--meta-oe/recipes-support/glog/glog/0002-Find-Libunwind-during-configure.patch120
-rw-r--r--meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch65
-rw-r--r--meta-oe/recipes-support/glog/glog/libexecinfo.patch40
-rw-r--r--meta-oe/recipes-support/glog/glog_0.3.5.bb34
-rw-r--r--meta-oe/recipes-support/glog/glog_0.6.0.bb43
7 files changed, 116 insertions, 290 deletions
diff --git a/meta-oe/recipes-support/glog/glog/0001-Change-SleepForMilliseconds-parameter-from-unsigned-.patch b/meta-oe/recipes-support/glog/glog/0001-Change-SleepForMilliseconds-parameter-from-unsigned-.patch
new file mode 100644
index 0000000000..3732c62cd0
--- /dev/null
+++ b/meta-oe/recipes-support/glog/glog/0001-Change-SleepForMilliseconds-parameter-from-unsigned-.patch
@@ -0,0 +1,33 @@
+From 176230435cb4b64ff7f2d97f77a04579ad9ca239 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 18 Feb 2023 13:14:14 -0800
+Subject: [PATCH] Change SleepForMilliseconds parameter from unsigned int -> long
+
+Fixes following error on 32bit platforms
+
+src/googletest.h:631:35: error: non-constant-expression cannot be narrowed from type 'unsigned int' to 'long' in initializer list [-Wc++11-narrowing]
+ const struct timespec req = {0, t * 1000 * 1000};
+ ^~~~~~~~~~~~~~~
+
+Upstream-Status: Submitted [https://github.com/google/glog/pull/894]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/googletest.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/googletest.h b/src/googletest.h
+index 5761361..836b06c 100644
+--- a/src/googletest.h
++++ b/src/googletest.h
+@@ -625,7 +625,7 @@ class Thread {
+ #endif
+ };
+
+-static inline void SleepForMilliseconds(unsigned t) {
++static inline void SleepForMilliseconds(long t) {
+ #ifndef GLOG_OS_WINDOWS
+ # if defined(_POSIX_C_SOURCE) && _POSIX_C_SOURCE >= 199309L
+ const struct timespec req = {0, t * 1000 * 1000};
+--
+2.39.2
+
diff --git a/meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch b/meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch
deleted file mode 100644
index f41a6c9724..0000000000
--- a/meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 4ea11e0d7c0575316a6ccc07a931164ca29c3d2f Mon Sep 17 00:00:00 2001
-From: Corentin Le Molgat <corentinl@google.com>
-Date: Mon, 29 Jan 2018 14:59:08 +0100
-Subject: [PATCH] Rework CMake glog VERSION management.
-
-- Use of Project version properties instead of custom variables
-- fix missmatch between VERSION (build version) and SOVERSION (API version)
-src: https://cmake.org/cmake/help/latest/prop_tgt/VERSION.html#prop_tgt:VERSION
-
-Upstream-Status: Backport [https://github.com/google/glog/commit/6b6e38a7d53fe01f42ce34384cf4ba4c50e8cb65]
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- CMakeLists.txt | 23 ++++++++---------------
- 1 file changed, 8 insertions(+), 15 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7415eab..fb4e408 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -8,23 +8,16 @@ if (POLICY CMP0063)
- cmake_policy (SET CMP0063 NEW)
- endif (POLICY CMP0063)
-
--project (google-glog)
-+project(glog VERSION 0.3.5 LANGUAGES C CXX)
-
- enable_testing ()
-
--set (GLOG_MAJOR_VERSION 0)
--set (GLOG_MINOR_VERSION 3)
--set (GLOG_PATCH_VERSION 5)
--
--set (GLOG_VERSION
-- ${GLOG_MAJOR_VERSION}.${GLOG_MINOR_VERSION}.${GLOG_PATCH_VERSION})
--
- set (CPACK_PACKAGE_NAME glog)
- set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "")
--set (CPACK_PACKAGE_VERSION_MAJOR ${GLOG_MAJOR_VERSION})
--set (CPACK_PACKAGE_VERSION_MINOR ${GLOG_MINOR_VERSION})
--set (CPACK_PACKAGE_VERSION_PATCH ${GLOG_PATCH_VERSION})
--set (CPACK_PACKAGE_VERSION ${GLOG_VERSION})
-+set (CPACK_PACKAGE_VERSION_MAJOR ${PROJECT_VERSION_MAJOR})
-+set (CPACK_PACKAGE_VERSION_MINOR ${PROJECT_VERSION_MINOR})
-+set (CPACK_PACKAGE_VERSION_PATCH ${PROJECT_VERSION_PATCH})
-+set (CPACK_PACKAGE_VERSION ${PROJECT_VERSION})
-
- option (WITH_GFLAGS "Use gflags" ON)
- option (WITH_THREADS "Enable multithreading support" ON)
-@@ -406,8 +399,8 @@ if (gflags_FOUND)
- endif (NOT BUILD_SHARED_LIBS)
- endif (gflags_FOUND)
-
--set_target_properties (glog PROPERTIES VERSION ${GLOG_MAJOR_VERSION})
--set_target_properties (glog PROPERTIES SOVERSION ${GLOG_VERSION})
-+set_target_properties (glog PROPERTIES VERSION ${PROJECT_VERSION})
-+set_target_properties (glog PROPERTIES SOVERSION ${PROJECT_VERSION_MAJOR})
-
- if (WIN32)
- target_compile_definitions (glog PUBLIC GLOG_NO_ABBREVIATED_SEVERITIES)
-@@ -570,7 +563,7 @@ configure_package_config_file (glog-config.cmake.in
- NO_CHECK_REQUIRED_COMPONENTS_MACRO)
-
- write_basic_package_version_file (glog-config-version.cmake VERSION
-- ${GLOG_VERSION} COMPATIBILITY SameMajorVersion)
-+ ${PROJECT_VERSION} COMPATIBILITY SameMajorVersion)
-
- export (TARGETS glog NAMESPACE glog:: FILE glog-targets.cmake)
- export (PACKAGE glog)
---
-2.17.1
-
diff --git a/meta-oe/recipes-support/glog/glog/0002-Find-Libunwind-during-configure.patch b/meta-oe/recipes-support/glog/glog/0002-Find-Libunwind-during-configure.patch
deleted file mode 100644
index 15cf67fd2e..0000000000
--- a/meta-oe/recipes-support/glog/glog/0002-Find-Libunwind-during-configure.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-diff -uNr a/cmake/FindLibunwind.cmake b/cmake/FindLibunwind.cmake
---- a/cmake/FindLibunwind.cmake 1970-01-01 01:00:00.000000000 +0100
-+++ b/cmake/FindLibunwind.cmake 2018-11-20 15:53:48.799078114 +0100
-@@ -0,0 +1,54 @@
-+# - Try to find libunwind
-+# Once done this will define
-+#
-+# Libunwind_FOUND - system has libunwind
-+# unwind - cmake target for libunwind
-+
-+find_library (UNWIND_LIBRARY NAMES unwind DOC "unwind library")
-+include (CheckIncludeFile)
-+check_include_file (libunwind.h HAVE_LIBUNWIND_H)
-+check_include_file (unwind.h HAVE_UNWIND_H)
-+
-+if (CMAKE_SYSTEM_PROCESSOR MATCHES "^arm")
-+ set(LIBUNWIND_ARCH "arm")
-+elseif (CMAKE_SYSTEM_PROCESSOR MATCHES "^aarch64")
-+ set(LIBUNWIND_ARCH "aarch64")
-+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" OR
-+ CMAKE_SYSTEM_PROCESSOR STREQUAL "amd64" OR
-+ CMAKE_SYSTEM_PROCESSOR STREQUAL "corei7-64")
-+ set(LIBUNWIND_ARCH "x86_64")
-+elseif (CMAKE_SYSTEM_PROCESSOR MATCHES "^i.86$")
-+ set(LIBUNWIND_ARCH "x86")
-+elseif (CMAKE_SYSTEM_PROCESSOR MATCHES "^ppc64")
-+ set(LIBUNWIND_ARCH "ppc64")
-+elseif (CMAKE_SYSTEM_PROCESSOR MATCHES "^ppc")
-+ set(LIBUNWIND_ARCH "ppc32")
-+elseif (CMAKE_SYSTEM_PROCESSOR MATCHES "^mips")
-+ set(LIBUNWIND_ARCH "mips")
-+elseif (CMAKE_SYSTEM_PROCESSOR MATCHES "^hppa")
-+ set(LIBUNWIND_ARCH "hppa")
-+elseif (CMAKE_SYSTEM_PROCESSOR MATCHES "^ia64")
-+ set(LIBUNWIND_ARCH "ia64")
-+endif()
-+
-+find_library (UNWIND_LIBRARY_PLATFORM NAMES "unwind-${LIBUNWIND_ARCH}" DOC "unwind library platform")
-+if (UNWIND_LIBRARY_PLATFORM)
-+ set(HAVE_LIB_UNWIND "1")
-+endif()
-+
-+include(FindPackageHandleStandardArgs)
-+# handle the QUIETLY and REQUIRED arguments and set Libunwind_FOUND to TRUE
-+# if all listed variables are TRUE
-+find_package_handle_standard_args(Libunwind DEFAULT_MSG
-+ UNWIND_LIBRARY HAVE_LIBUNWIND_H HAVE_UNWIND_H HAVE_LIB_UNWIND)
-+
-+mark_as_advanced (UNWIND_LIBRARY UNWIND_LIBRARY_PLATFORM)
-+
-+if (Libunwind_FOUND)
-+ add_library(unwind INTERFACE IMPORTED)
-+ set_target_properties(unwind PROPERTIES
-+ INTERFACE_LINK_LIBRARIES "${UNWIND_LIBRARY};${UNWIND_LIBRARY_PLATFORM}"
-+ )
-+else()
-+ message("Can't find libunwind library")
-+endif()
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2018-11-20 15:49:07.576278417 +0100
-+++ b/CMakeLists.txt 2018-11-20 15:49:32.106819928 +0100
-@@ -58,7 +58,6 @@
- check_include_file (execinfo.h HAVE_EXECINFO_H)
- check_include_file (glob.h HAVE_GLOB_H)
- check_include_file (inttypes.h HAVE_INTTYPES_H)
--check_include_file (libunwind.h HAVE_LIBUNWIND_H)
- check_include_file (memory.h HAVE_MEMORY_H)
- check_include_file (pwd.h HAVE_PWD_H)
- check_include_file (stdint.h HAVE_STDINT_H)
-@@ -74,7 +73,6 @@
- check_include_file (syslog.h HAVE_SYSLOG_H)
- check_include_file (ucontext.h HAVE_UCONTEXT_H)
- check_include_file (unistd.h HAVE_UNISTD_H)
--check_include_file (unwind.h HAVE_UNWIND_H)
-
- check_include_file_cxx ("ext/hash_map" HAVE_EXT_HASH_MAP)
- check_include_file_cxx ("ext/hash_set" HAVE_EXT_HASH_SET)
-@@ -109,10 +107,7 @@
- # snprintf as an inline function
- check_symbol_exists (snprintf stdio.h HAVE_SNPRINTF)
-
--check_library_exists (unwind get_static_proc_name "" HAVE_LIB_UNWIND)
--
--find_library (UNWIND_LIBRARY NAMES unwind DOC "unwind library")
--mark_as_advanced (UNWIND_LIBRARY)
-+find_package(Libunwind)
-
- check_c_source_compiles ("
- #include <stdlib.h>
-@@ -376,9 +371,9 @@
-
- set_target_properties (glog PROPERTIES POSITION_INDEPENDENT_CODE ON)
-
--if (UNWIND_LIBRARY)
-- target_link_libraries (glog PUBLIC ${UNWIND_LIBRARY})
--endif (UNWIND_LIBRARY)
-+if (Libunwind_FOUND)
-+ target_link_libraries (glog PUBLIC unwind)
-+endif (Libunwind_FOUND)
-
- if (HAVE_PTHREAD)
- target_link_libraries (glog PUBLIC ${CMAKE_THREAD_LIBS_INIT})
-@@ -571,6 +566,7 @@
- install (FILES
- ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
- ${CMAKE_CURRENT_BINARY_DIR}/glog-config-version.cmake
-+ ${CMAKE_CURRENT_SOURCE_DIR}/cmake/FindLibunwind.cmake
- DESTINATION lib/cmake/glog)
-
- install (EXPORT glog-targets NAMESPACE glog:: DESTINATION lib/cmake/glog)
-diff -uNr a/glog-config.cmake.in b/glog-config.cmake.in
---- a/glog-config.cmake.in 2018-11-20 15:49:07.576278417 +0100
-+++ b/glog-config.cmake.in 2018-11-20 15:52:32.330418489 +0100
-@@ -4,4 +4,6 @@
-
- @gflags_DEPENDENCY@
-
-+find_dependency (Libunwind)
-+
- include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake")
diff --git a/meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch b/meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch
deleted file mode 100644
index 641f70cb24..0000000000
--- a/meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2018-12-05 12:55:59.630792054 +0100
-+++ b/CMakeLists.txt 2018-12-05 13:00:22.922269200 +0100
-@@ -403,10 +403,15 @@
-
- set_target_properties (glog PROPERTIES PUBLIC_HEADER "${GLOG_PUBLIC_H}")
-
-+set (_glog_CMake_BINDIR ${CMAKE_INSTALL_BINDIR})
-+set (_glog_CMake_INCLUDE_DIR ${CMAKE_INSTALL_INCLUDEDIR})
-+set (_glog_CMake_LIBDIR ${CMAKE_INSTALL_LIBDIR})
-+set (_glog_CMake_INSTALLDIR ${_glog_CMake_LIBDIR}/cmake/glog)
-+
- target_include_directories (glog BEFORE PUBLIC
- "$<BUILD_INTERFACE:${CMAKE_CURRENT_BINARY_DIR}>"
- "$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/src>"
-- "$<INSTALL_INTERFACE:include>"
-+ "$<INSTALL_INTERFACE:${_glog_CMake_INCLUDE_DIR}>"
- PRIVATE ${CMAKE_CURRENT_BINARY_DIR}
- PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}/src)
-
-@@ -543,10 +548,10 @@
-
- install (TARGETS glog
- EXPORT glog-targets
-- RUNTIME DESTINATION bin
-- PUBLIC_HEADER DESTINATION include/glog
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib)
-+ RUNTIME DESTINATION ${_glog_CMake_BINDIR}
-+ PUBLIC_HEADER DESTINATION ${_glog_CMake_INCLUDE_DIR}/glog
-+ LIBRARY DESTINATION ${_glog_CMake_LIBDIR}
-+ ARCHIVE DESTINATION ${_glog_CMake_LIBDIR})
-
- if (gflags_FOUND)
- set (gflags_DEPENDENCY "find_dependency (gflags ${gflags_VERSION})")
-@@ -554,7 +559,7 @@
-
- configure_package_config_file (glog-config.cmake.in
- ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
-- INSTALL_DESTINATION lib/cmake/glog
-+ INSTALL_DESTINATION ${_glog_CMake_INSTALLDIR}
- NO_CHECK_REQUIRED_COMPONENTS_MACRO)
-
- write_basic_package_version_file (glog-config-version.cmake VERSION
-@@ -567,6 +572,7 @@
- ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
- ${CMAKE_CURRENT_BINARY_DIR}/glog-config-version.cmake
- ${CMAKE_CURRENT_SOURCE_DIR}/cmake/FindLibunwind.cmake
-- DESTINATION lib/cmake/glog)
-+ DESTINATION ${_glog_CMake_INSTALLDIR})
-
--install (EXPORT glog-targets NAMESPACE glog:: DESTINATION lib/cmake/glog)
-+install (EXPORT glog-targets NAMESPACE glog:: DESTINATION
-+ ${_glog_CMake_INSTALLDIR})
-diff -uNr a/glog-config.cmake.in b/glog-config.cmake.in
---- a/glog-config.cmake.in 2018-12-05 12:55:59.630792054 +0100
-+++ b/glog-config.cmake.in 2018-12-05 13:05:19.547196843 +0100
-@@ -4,6 +4,7 @@
-
- @gflags_DEPENDENCY@
-
-+list (APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}")
- find_dependency (Libunwind)
-
- include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake")
diff --git a/meta-oe/recipes-support/glog/glog/libexecinfo.patch b/meta-oe/recipes-support/glog/glog/libexecinfo.patch
new file mode 100644
index 0000000000..a791a40dbc
--- /dev/null
+++ b/meta-oe/recipes-support/glog/glog/libexecinfo.patch
@@ -0,0 +1,40 @@
+From 19d00c15710840910a7397252c14d612746631fe Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 8 Mar 2021 14:58:40 -0800
+Subject: [PATCH] Link libexecinfo if its found, this is needed for musl based
+ systems
+
+Fixes
+ld: libglog.so.0.4.0: undefined reference to `backtrace'
+| collect2: error: ld returned 1 exit status
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+---
+ CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 846b444..1553358 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -162,6 +162,7 @@ cmake_pop_check_state ()
+ check_cxx_symbol_exists (snprintf cstdio HAVE_SNPRINTF)
+
+ check_library_exists (dbghelp UnDecorateSymbolName "" HAVE_DBGHELP)
++check_library_exists (execinfo backtrace "" HAVE_EXECINFO)
+
+ check_cxx_source_compiles ("
+ #include <cstdlib>
+@@ -629,6 +630,10 @@ if (Unwind_FOUND)
+ set (Unwind_DEPENDENCY "find_dependency (Unwind ${Unwind_VERSION})")
+ endif (Unwind_FOUND)
+
++if (HAVE_EXECINFO)
++ target_link_libraries (glog PUBLIC execinfo)
++endif (HAVE_EXECINFO)
++
+ if (HAVE_DBGHELP)
+ target_link_libraries (glog PRIVATE dbghelp)
+ set (glog_libraries_options_for_static_linking "${glog_libraries_options_for_static_linking} -ldbghelp")
diff --git a/meta-oe/recipes-support/glog/glog_0.3.5.bb b/meta-oe/recipes-support/glog/glog_0.3.5.bb
deleted file mode 100644
index 56bf515544..0000000000
--- a/meta-oe/recipes-support/glog/glog_0.3.5.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "The glog library implements application-level logging. This \
-library provides logging APIs based on C++-style streams and various helper \
-macros."
-HOMEPAGE = "https://github.com/google/glog"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
-
-SRC_URI = " \
- git://github.com/google/glog.git;nobranch=1 \
- file://0001-Rework-CMake-glog-VERSION-management.patch \
- file://0002-Find-Libunwind-during-configure.patch \
- file://0003-installation-path-fix.patch \
-"
-
-SRCREV = "a6a166db069520dbbd653c97c2e5b12e08a8bb26"
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-PACKAGECONFIG ?= "shared unwind"
-PACKAGECONFIG_remove_riscv64 = "unwind"
-PACKAGECONFIG_remove_riscv32 = "unwind"
-
-PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind"
-PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
-
-do_configure_append() {
- # remove WORKDIR info to improve reproducibility
- if [ -f "${B}/config.h" ] ; then
- sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h
- fi
-}
diff --git a/meta-oe/recipes-support/glog/glog_0.6.0.bb b/meta-oe/recipes-support/glog/glog_0.6.0.bb
new file mode 100644
index 0000000000..ec39604f44
--- /dev/null
+++ b/meta-oe/recipes-support/glog/glog_0.6.0.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "The glog library implements application-level logging. This \
+library provides logging APIs based on C++-style streams and various helper \
+macros."
+HOMEPAGE = "https://github.com/google/glog"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
+
+SRC_URI = " \
+ git://github.com/google/glog.git;branch=master;protocol=https \
+ file://libexecinfo.patch \
+ file://0001-Change-SleepForMilliseconds-parameter-from-unsigned-.patch \
+"
+
+SRCREV = "b33e3bad4c46c8a6345525fd822af355e5ef9446"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ?= "shared unwind 64bit-atomics"
+PACKAGECONFIG:remove:riscv64 = "unwind"
+PACKAGECONFIG:remove:riscv32 = "unwind 64bit-atomics"
+PACKAGECONFIG:remove:mipsarch = "64bit-atomics"
+PACKAGECONFIG:remove:armv5 = "64bit-atomics"
+PACKAGECONFIG:remove:armv6 = "64bit-atomics"
+
+PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo"
+PACKAGECONFIG:append:libc-musl:riscv32 = " execinfo"
+
+PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind"
+PACKAGECONFIG[execinfo] = ",,libexecinfo"
+PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
+PACKAGECONFIG[64bit-atomics] = ",-DCMAKE_CXX_STANDARD_LIBRARIES='-latomic',,"
+
+do_configure:append() {
+ # remove WORKDIR info to improve reproducibility
+ if [ -f "${B}/config.h" ] ; then
+ sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h
+ fi
+}
+
+FILES:${PN}-dev += "${datadir}/${BPN}/cmake"