aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/imagemagick/imagemagick_6.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/imagemagick/imagemagick_6.9.1.bb')
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.9.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.9.1.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.9.1.bb
new file mode 100644
index 0000000000..e54135b326
--- /dev/null
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.9.1.bb
@@ -0,0 +1,42 @@
+SUMMARY = "ImageMagick is an image convertion tools"
+SECTION = "console/utils"
+LICENSE = "ImageMagick"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0887b670be7ef0c3cb37092b64d57514"
+# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
+DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib virtual/fftw freetype"
+
+PATCHSET = "3"
+SRC_URI = "http://www.imagemagick.org/download/releases/ImageMagick-${PV}-${PATCHSET}.tar.xz \
+"
+SRC_URI[md5sum] = "1171a6837defe10be288ab44869cc3a0"
+SRC_URI[sha256sum] = "5fd180603e60c624c05c644a8340f4f4e92c19dc3c41d374d38f76c69cd48ba3"
+
+S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}"
+
+inherit autotools pkgconfig
+
+# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
+# if someone needs xml support then fix it first
+EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-x --without-perl --disable-openmp --without-xml --disable-opencl"
+
+CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
+PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
+PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
+PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
+PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
+PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
+
+FILES_${PN} += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.so \
+ ${libdir}/ImageMagick-${PV}/modules-Q16/*/*.la \
+ ${libdir}/ImageMagick-${PV}/modules-Q16/filters \
+ ${libdir}/ImageMagick-${PV}/modules-Q16/coders \
+ ${libdir}/ImageMagick-${PV}/config-Q16 \
+ ${datadir}/ImageMagick-6 "
+
+FILES_${PN}-dev += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.a"
+
+FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*"
+
+BBCLASSEXTEND = "native"