aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb')
-rw-r--r--meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb b/meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb
new file mode 100644
index 0000000000..1981f1ee9c
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Skype protocol plug-in for libpurple"
+SECTION = "webos/services"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://skypeweb/gpl3.txt;md5=d90260d32cef39f3c8d6c0f05d3adb8e"
+
+DEPENDS = "pidgin json-glib glib-2.0 zlib"
+
+inherit pkgconfig
+
+SRC_URI = "git://github.com/EionRobb/skype4pidgin;branch=master;protocol=https"
+SRCREV = "b226d1c457d73900ae89b8a7469247fbe33677a6"
+
+S = "${WORKDIR}/git"
+PV = "1.7+git"
+
+do_compile() {
+ oe_runmake -C skypeweb;
+}
+
+do_install() {
+ oe_runmake -C skypeweb DESTDIR="${D}" install;
+}
+
+FILES:${PN} += " \
+ ${libdir} \
+"