aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pngcheck
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/pngcheck')
-rw-r--r--meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
new file mode 100644
index 0000000000..59f22df3f1
--- /dev/null
+++ b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "pngcheck verifies the integrity of PNG, JNG and MNG files"
+HOMEPAGE = "http://www.libpng.org/pub/png/apps/pngcheck.html"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://gpl/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+DEPENDS = "zlib libpng"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/png-mng/${BPN}/${PV}/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "980bd6d9a3830fdce746d7fe3c9166ee"
+SRC_URI[sha256sum] = "77f0a039ac64df55fbd06af6f872fdbad4f639d009bbb5cd5cbe4db25690f35f"
+
+do_compile() {
+ oe_runmake -f Makefile.unx INCS=-I${STAGING_DIR_HOST}${incdir} LIBS=${STAGING_DIR_HOST}${libdir}/libz.a
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install pngcheck ${D}${bindir}
+ install png-fix-IDAT-windowsize ${D}${bindir}
+ install pngsplit ${D}${bindir}
+}
+