aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/ode/ode_0.13.bb27
-rw-r--r--meta-oe/recipes-support/ode/ode_0.9.bb28
2 files changed, 27 insertions, 28 deletions
diff --git a/meta-oe/recipes-support/ode/ode_0.13.bb b/meta-oe/recipes-support/ode/ode_0.13.bb
new file mode 100644
index 0000000000..8e9eb153c2
--- /dev/null
+++ b/meta-oe/recipes-support/ode/ode_0.13.bb
@@ -0,0 +1,27 @@
+SUMMARY = "ODE is an Open Source Physics Engine"
+SECTION = "libs"
+HOMEPAGE = "http://www.ode.org"
+LICENSE = "LGPLv2.1 & BSD"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=1de906ee96808d9776dd72a5f9a79a22 \
+ file://LICENSE.TXT;md5=771782cb6245c7fbbe74bc0ec059beff \
+"
+# LICENSE-BSD.TXT is missing in 0.13 tarball, but COPYING still says it's dual licensed
+# and svn repo still contains LICENSE-BSD.TXT so maybe it will return in next tarball
+# file://LICENSE-BSD.TXT;md5=c74e6304a772117e059458fb9763a928
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-${PV}.tar.bz2"
+SRC_URI[md5sum] = "04b32c9645c147e18caff7a597a19f84"
+SRC_URI[sha256sum] = "34ce3e236e313bf109a0cb5546d2fca462aed99f29a42e62bc1463b803c31ef9"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--disable-demos --enable-soname"
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+
+PACKAGECONFIG ?= ""
+# if it isn't explicitly selected and "$build_os" == "$target_os", then configure will run
+# series of AC_TRY_RUN which won't work for cross-compilation and configure fails
+PACKAGECONFIG[double-precision] = "--enable-double-precision,--disable-double-precision"
diff --git a/meta-oe/recipes-support/ode/ode_0.9.bb b/meta-oe/recipes-support/ode/ode_0.9.bb
deleted file mode 100644
index 8b9955e397..0000000000
--- a/meta-oe/recipes-support/ode/ode_0.9.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "ODE is an Open Source Physics Engine"
-SECTION = "libs"
-HOMEPAGE = "http://www.ode.org"
-LICENSE = "LGPLv2.1 & BSD"
-LIC_FILES_CHKSUM = "file://LICENSE-BSD.TXT;md5=c74e6304a772117e059458fb9763a928 \
- file://LICENSE.TXT;md5=771782cb6245c7fbbe74bc0ec059beff"
-
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-src-${PV}.zip \
- file://install.patch"
-
-SRC_URI[md5sum] = "4c03759b76a0649a6d5108c8e172e1e4"
-SRC_URI[sha256sum] = "460d0851b743b1f144ef2a8259004d6774504c95d08e9357a96a296111496feb"
-
-inherit autotools binconfig
-
-EXTRA_OECONF = "--disable-demos --enable-soname"
-
-do_configure_append() {
- echo "#define dInfinity DBL_MAX" >>include/ode/config.h
-}
-
-FILES_${PN} = "${libdir}/lib*${SOLIBS}"
-
-PACKAGECONFIG ?= ""
-# if it isn't explicitly selected and "$build_os" == "$target_os", then configure will run
-# series of AC_TRY_RUN which won't work for cross-compilation and configure fails
-PACKAGECONFIG[double-precision] = "--enable-double-precision,--disable-double-precision"