aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libcapture/libcapture-tiny-perl_0.30.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libcapture/libcapture-tiny-perl_0.30.bb')
-rw-r--r--meta-perl/recipes-perl/libcapture/libcapture-tiny-perl_0.30.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcapture/libcapture-tiny-perl_0.30.bb b/meta-perl/recipes-perl/libcapture/libcapture-tiny-perl_0.30.bb
new file mode 100644
index 0000000000..3a3f843176
--- /dev/null
+++ b/meta-perl/recipes-perl/libcapture/libcapture-tiny-perl_0.30.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Capture::Tiny - Capture STDOUT and STDERR from Perl, XS or external programs."
+DESCRIPTION = "Capture::Tiny provies a simple, portable way to capture \
+almost anything sent to STDOUT or STDERR, regardless of whether it comes \
+from Perl, from XS code or from an external program. Optionally, output can \
+be teed so that it is captured while being passed through to the original \
+filehandles. Yes, it even works on Windows (usually). Stop guessing which of \
+a dozen capturing modules to use in any particular situation and just use \
+this one."
+SECTION = "libs"
+
+HOMEPAGE = "http://search.cpan.org/~dagolden/Capture-Tiny/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37a4918a30ace24395020e5b8c03b83f"
+
+SRCNAME = "Capture-Tiny"
+SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DAGOLDEN/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "7b0fbdbf4199724df1e53fe0b3e2ef4c"
+SRC_URI[sha256sum] = "a3b4e55278757e77d50df0b1a79f42e6e8354b7d41db806da39bf161bee63aea"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-scalar-util \
+ perl-module-io-file \
+ perl-module-extutils-makemaker \
+ perl-module-file-spec \
+ perl-module-exporter \
+ perl-module-carp \
+ perl-module-test-more \
+ perl-module-file-temp \
+ perl-module-lib \
+ perl-module-overloading \
+"
+
+BBCLASSEXTEND = "native"