aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
index f7cd9bb78a..152034b4c8 100644
--- a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
@@ -12,3 +12,12 @@ S = "${WORKDIR}/vcversioner-${PV}"
inherit setuptools
+
+do_compile_append() {
+ export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
+ ${PYTHON} setup.py -q bdist_egg --dist-dir ./
+}
+
+do_install_append() {
+ install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
+}