aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-eth-rlp_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-eth-rlp_2.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-rlp_2.1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eth-rlp_2.1.0.bb b/meta-python/recipes-devtools/python/python3-eth-rlp_2.1.0.bb
new file mode 100644
index 0000000000..4bdc0c8873
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-rlp_2.1.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "RLP definitions for common Ethereum objects in Python"
+HOMEPAGE = "https://github.com/ethereum/eth-rlp"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3d7bdfe69b1ffbde073ca6e96f5c53f7"
+
+SRC_URI[sha256sum] = "d5b408a8cd20ed496e8e66d0559560d29bc21cee482f893936a1f05d0dddc4a0"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = " \
+ python3-eth-utils \
+ python3-hexbytes \
+ python3-rlp \
+ python3-typing-extensions \
+"