aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyrad_2.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrad_2.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
new file mode 100644
index 0000000000..801233a026
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
@@ -0,0 +1,19 @@
+SUMMARY = "RADIUS tools"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
+
+PYPI_PACKAGE = "pyrad"
+SRC_URI[sha256sum] = "057de4b7e89d8da57ba782c1bde45c63ebee720ae2c0b0a69beaff15c47e30d9"
+
+SRC_URI += "file://use-poetry-core.patch"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += " \
+ python3-crypt \
+ python3-io \
+ python3-logging \
+ python3-netaddr \
+ python3-six \
+"