aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.20.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.20.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.20.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.20.bb
new file mode 100644
index 0000000000..b96cdd3ed8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.20.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
+application developers the full power and flexibility of SQL"
+HOMEPAGE = "http://www.sqlalchemy.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595"
+
+SRC_URI[sha256sum] = "38ee3a266afef2978e82824650457f70c5d74ec0cadec1b10fe5ed6f038eb5d0"
+
+PYPI_PACKAGE = "SQLAlchemy"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-profile \
+"