aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pbr.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-pbr_3.1.1.bb18
-rw-r--r--meta-python/recipes-devtools/python/python3-pbr_3.1.1.bb2
3 files changed, 18 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pbr.inc b/meta-python/recipes-devtools/python/python-pbr.inc
new file mode 100644
index 0000000000..d8847f6502
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pbr.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "Python Build Reasonableness: PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
+HOMEPAGE = "https://pypi.python.org/pypi/pbr"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "4e82c2e07af544c56a5b71c801525b00"
+SRC_URI[sha256sum] = "05f61c71aaefc02d8e37c0a3eeb9815ff526ea28b3b76324769e6158d7f95be1"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pip"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-pbr_3.1.1.bb b/meta-python/recipes-devtools/python/python-pbr_3.1.1.bb
index bdff867f30..8f7f924dab 100644
--- a/meta-python/recipes-devtools/python/python-pbr_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python-pbr_3.1.1.bb
@@ -1,16 +1,2 @@
-DESCRIPTION = "Python Build Reasonableness: PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
-HOMEPAGE = "https://pypi.python.org/pypi/pbr"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
-
-SRC_URI[md5sum] = "4e82c2e07af544c56a5b71c801525b00"
-SRC_URI[sha256sum] = "05f61c71aaefc02d8e37c0a3eeb9815ff526ea28b3b76324769e6158d7f95be1"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN}_class-target += " \
- python-pip \
- "
-
-BBCLASSEXTEND = "native"
+inherit setuptools
+require python-pbr.inc
diff --git a/meta-python/recipes-devtools/python/python3-pbr_3.1.1.bb b/meta-python/recipes-devtools/python/python3-pbr_3.1.1.bb
new file mode 100644
index 0000000000..97e7361b16
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pbr_3.1.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pbr.inc