aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_2.9.1.bb10
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest_2.9.1.bb2
3 files changed, 19 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
new file mode 100644
index 0000000000..4877358f2e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Simple powerful teting with python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d8a5609608d9a5a180705b0fa298ae01"
+
+SRC_URI[md5sum] = "05165740ea50928e4e971378630163ec"
+SRC_URI[sha256sum] = "0d48d27a127644fbe7c8158157e08b35f8255045d4476df694b91eb3a8147e65"
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-py \
+ ${PYTHON_PN}-setuptools \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb b/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb
index e21c4f45a9..d322f09b24 100644
--- a/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb
+++ b/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb
@@ -1,10 +1,2 @@
-SUMMARY = "Simple powerful teting with Python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d8a5609608d9a5a180705b0fa298ae01"
-
-SRC_URI[md5sum] = "05165740ea50928e4e971378630163ec"
-SRC_URI[sha256sum] = "0d48d27a127644fbe7c8158157e08b35f8255045d4476df694b91eb3a8147e65"
-
-RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json"
-
inherit pypi setuptools
+require python-pytest.inc
diff --git a/meta-python/recipes-devtools/python/python3-pytest_2.9.1.bb b/meta-python/recipes-devtools/python/python3-pytest_2.9.1.bb
new file mode 100644
index 0000000000..466cfa8253
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest_2.9.1.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pytest.inc