aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-attr.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-attr_0.2.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-attr_0.2.0.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-attr.inc b/meta-python/recipes-devtools/python/python-attr.inc
new file mode 100644
index 0000000000..8ebf9b97be
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-attr.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "Simple decorator to set attributes of target function or class in a DRY way"
+HOMEPAGE = "https://github.com/denis-ryzhkov/attr"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=598841c0e09b76883d9ff37a3b6100bf"
+
+SRC_URI[md5sum] = "de69ad11c8872a6dfdbdace7eb81efb4"
+SRC_URI[sha256sum] = "826135ffdd4d0b4bc8a580ce491c33fd90b55e169217539c34b7bfdbe2086ee3"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-attr_0.2.0.bb b/meta-python/recipes-devtools/python/python-attr_0.2.0.bb
new file mode 100644
index 0000000000..979d6cb687
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-attr_0.2.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-attr.inc
diff --git a/meta-python/recipes-devtools/python/python3-attr_0.2.0.bb b/meta-python/recipes-devtools/python/python3-attr_0.2.0.bb
new file mode 100644
index 0000000000..e80648c8c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-attr_0.2.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-attr.inc