aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_3.4.2.bb (renamed from meta-python/recipes-devtools/python/python-pytest_3.4.1.bb)0
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index 60ff83008a..4feb9a03cf 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "http://pytest.org"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4"
-SRC_URI[md5sum] = "6768537cbb150022387c565051904a1c"
-SRC_URI[sha256sum] = "9ddcb879c8cc859d2540204b5399011f842e5e8823674bf429f70ada281b3cc6"
+SRC_URI[md5sum] = "1b83a25d45fad893f430fc5031653c56"
+SRC_URI[sha256sum] = "117bad36c1a787e1a8a659df35de53ba05f9f3398fb9e4ac17e80ad5903eb8c5"
SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
file://pytest_version_fix.patch "
diff --git a/meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch b/meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch
index 908f862b52..b373d93e8f 100644
--- a/meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch
+++ b/meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch
@@ -36,7 +36,7 @@ Index: pytest-3.2.2/setup.py
+ return version_match.group(1)
+ raise RuntimeError("Unable to find version string.")
- def has_environment_marker_support():
+ def get_environment_marker_support_level():
"""
@@ -59,9 +72,7 @@ def main():
name='pytest',
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.4.1.bb b/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
index 201ab050cd..201ab050cd 100644
--- a/meta-python/recipes-devtools/python/python-pytest_3.4.1.bb
+++ b/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb