aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ruby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ruby')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby.inc12
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb44
2 files changed, 28 insertions, 28 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc
index 894e3e6a93..becf64c93d 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby.inc
+++ b/meta-ruby/recipes-devtools/ruby/ruby.inc
@@ -8,10 +8,10 @@ HOMEPAGE = "http://www.ruby-lang.org/"
SECTION = "devel/ruby"
LICENSE = "Ruby | BSD | GPLv2"
LIC_FILES_CHKSUM = "\
- file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \
- file://BSDL;md5=3949e007205deef714bd225e1ee4a8ea \
- file://GPL;md5=393a5ca445f6965873eca0259a17f833 \
- file://LEGAL;md5=e88686821918c0b6d2b1b8328116cec5 \
+ file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \
+ file://BSDL;md5=3949e007205deef714bd225e1ee4a8ea \
+ file://GPL;md5=393a5ca445f6965873eca0259a17f833 \
+ file://LEGAL;md5=e88686821918c0b6d2b1b8328116cec5 \
"
DEPENDS = "ruby-native zlib openssl tcl"
@@ -38,6 +38,6 @@ inherit autotools
# built.
do_configure_prepend() {
- sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
- rm -rf ${S}/ruby/
+ sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
+ rm -rf ${S}/ruby/
}
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb
index b9f7915d92..6611ce11ea 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb
+++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb
@@ -4,40 +4,40 @@ PR = "${INC_PR}.0"
DEPENDS += "libyaml"
SRC_URI += "\
- file://0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch \
- file://ruby-1.9.3-always-use-i386.patch \
- file://ruby-1.9.3-disable-versioned-paths.patch \
- file://ruby-1.9.3-fix-s390x-build.patch \
- file://ruby-1.9.3-rubygems-1.8.11-uninstaller.patch \
- file://ruby-1.9.3-webrick-test-fix.patch \
- file://ruby-1.9.3-bignum-test-fix.patch \
- file://ruby-1.9.3-custom-rubygems-location.patch \
- file://rubygems-1.8.11-binary-extensions.patch \
- file://ruby-1.9.3-mkmf-verbose.patch \
- file://ruby-1.9.3-install-cross.patch \
+ file://0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch \
+ file://ruby-1.9.3-always-use-i386.patch \
+ file://ruby-1.9.3-disable-versioned-paths.patch \
+ file://ruby-1.9.3-fix-s390x-build.patch \
+ file://ruby-1.9.3-rubygems-1.8.11-uninstaller.patch \
+ file://ruby-1.9.3-webrick-test-fix.patch \
+ file://ruby-1.9.3-bignum-test-fix.patch \
+ file://ruby-1.9.3-custom-rubygems-location.patch \
+ file://rubygems-1.8.11-binary-extensions.patch \
+ file://ruby-1.9.3-mkmf-verbose.patch \
+ file://ruby-1.9.3-install-cross.patch \
"
SRC_URI[md5sum] = "bc0c715c69da4d1d8bd57069c19f6c0e"
SRC_URI[sha256sum] = "46e2fa80be7efed51bd9cdc529d1fe22ebc7567ee0f91db4ab855438cf4bd8bb"
EXTRA_OECONF = "\
- --enable-wide-getaddrinfo \
- --with-rubygemsdir=${datadir}/rubygems \
- --disable-versioned-paths \
- --disable-rpath \
- --enable-shared \
+ --enable-wide-getaddrinfo \
+ --with-rubygemsdir=${datadir}/rubygems \
+ --disable-versioned-paths \
+ --disable-rpath \
+ --enable-shared \
"
EXTRA_OEMAKE = " \
- LIBRUBYARG='-lruby-static' \
+ LIBRUBYARG='-lruby-static' \
"
do_install() {
- if [ ${PN} = "ruby" ]; then
- oe_runmake 'DESTDIR=${D}' install install-cross
- else
- oe_runmake 'DESTDIR=${D}' install
- fi
+ if [ ${PN} = "ruby" ]; then
+ oe_runmake 'DESTDIR=${D}' install install-cross
+ else
+ oe_runmake 'DESTDIR=${D}' install
+ fi
}
FILES_${PN} += "${datadir}/rubygems \