aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/conf')
-rw-r--r--meta-systemd/conf/layer.conf18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-systemd/conf/layer.conf b/meta-systemd/conf/layer.conf
index 3310abc8af..d06cfa138e 100644
--- a/meta-systemd/conf/layer.conf
+++ b/meta-systemd/conf/layer.conf
@@ -12,7 +12,23 @@
BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/*/recipes-*/*/*.bbappend"
+BBFILES += "\
+ ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/oe-core/recipes-*/*/*.bbappend \
+ ${LAYERDIR}/meta-oe/recipes-*/*/*.bbappend \
+ ${@base_contains('BBFILE_COLLECTIONS', 'systemd-layer',\
+ '', '${LAYERDIR}/invalid.bb', d)} \
+ ${@base_contains('BBFILE_COLLECTIONS', 'gnome-layer',\
+ '${LAYERDIR}/meta-gnome/recipes-*/*/*.bbappend', '', d)} \
+ ${@base_contains('BBFILE_COLLECTIONS', 'efl-layer',\
+ '${LAYERDIR}/meta-efl/recipes-*/*/*.bbappend', '', d)} \
+ ${@base_contains('BBFILE_COLLECTIONS', 'multimedia-layer',\
+ '${LAYERDIR}/meta-multimedia/recipes-*/*/*.bbappend', '', d)} \
+ ${@base_contains('BBFILE_COLLECTIONS', 'networking',\
+ '${LAYERDIR}/meta-networking/recipes-*/*/*.bbappend', '', d)} \
+ ${@base_contains('BBFILE_COLLECTIONS', 'xfce-layer',\
+ '${LAYERDIR}/meta-xfce/recipes-*/*/*.bbappend', '', d)} \
+"
BBFILE_COLLECTIONS += "systemd-layer"
BBFILE_PATTERN_systemd-layer := "^${LAYERDIR}/"