aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/conf')
-rw-r--r--meta-systemd/conf/layer.conf28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-systemd/conf/layer.conf b/meta-systemd/conf/layer.conf
new file mode 100644
index 0000000000..d07d2aded0
--- /dev/null
+++ b/meta-systemd/conf/layer.conf
@@ -0,0 +1,28 @@
+# It really depends on order of the layers appearing in BBLAYERS
+# variable in toplevel bblayers.conf file, where bitbake will search
+# for .inc files and others where bitbake uses BBPATH since it will
+# search the directories from first to last as specified in BBPATH
+# Therefore if you want a given layer to be considered high priority
+# for the .inc and .conf etc. then consider it adding at the beginning
+# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
+# the recipe contention so the order of directories in BBFILES does
+# not matter.
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "systemd-layer"
+BBFILE_PATTERN_systemd := "^${LAYERDIR}/"
+
+# Define the priority for recipes (.bb files) from this layer,
+# choosing carefully how this layer interacts with all of the
+# other layers.
+
+BBFILE_PRIORITY_systemd-layer = "7"
+
+SIGGEN_EXCLUDERECIPES_ABISAFE += " \
+ systemd-serialgetty \
+"