aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend b/meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend
index e58306fcc9..ed9cf9dd79 100644
--- a/meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend
+++ b/meta-systemd/meta-oe/recipes-extended/atftp/atftp_git.bbappend
@@ -6,12 +6,12 @@ inherit systemd
SRC_URI += "file://atftpd.service"
-SYSTEMD_PACKAGES = "atftpd"
-SYSTEMD_SERVICE_atftpd = "atftpd.service"
-FILES_atftpd += "${systemd_unitdir}/system/atftpd.service"
-RPROVIDES_atftpd += "atftpd-systemd"
-RREPLACES_atftpd += "atftpd-systemd"
-RCONFLICTS_atftpd += "atftpd-systemd"
+SYSTEMD_PACKAGES = "${PN}d"
+SYSTEMD_SERVICE_${PN}d = "atftpd.service"
+FILES_${PN}d += "${systemd_unitdir}/system/atftpd.service"
+RPROVIDES_${PN}d += "${PN}d-systemd"
+RREPLACES_${PN}d += "${PN}d-systemd"
+RCONFLICTS_${PN}d += "${PN}d-systemd"
do_install_append() {
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/atftpd.service ${D}${systemd_unitdir}/system