aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb')
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb
index a251523bc8..1c9bff7fbc 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb
+++ b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb
@@ -27,6 +27,8 @@ inherit update-rc.d useradd
CFLAGS_append = " -fPIE -pie"
CXXFLAGS_append = " -fPIE -pie"
+EXTRA_OECONF = ""
+
do_configure () {
if [ "${SITEINFO_BITS}" = "64" ]; then
PTRSIZE=8
@@ -55,7 +57,8 @@ do_configure () {
--pid-path=/run/nginx/nginx.pid \
--prefix=${prefix} \
--with-http_ssl_module \
- --with-http_gzip_static_module
+ --with-http_gzip_static_module \
+ ${EXTRA_OECONF}
}
do_install () {