aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch')
-rw-r--r--meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch b/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch
new file mode 100644
index 0000000000..9409dd2b15
--- /dev/null
+++ b/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch
@@ -0,0 +1,35 @@
+Testing for IPv6 support got broken by configure.ac changes in 1.6.4
+As a temp workaround, revert back to the 1.6.3 version.
+
+Upstream-Status: Pending
+
+--- spawn-fcgi-1.6.4/configure.ac
++++ spawn-fcgi-1.6.3/configure.ac
+@@ -66,8 +47,8 @@
+ # Check for IPv6 support
+
+ AC_ARG_ENABLE(ipv6,
+- AC_HELP_STRING([--disable-ipv6],[disable IPv6 support]),
+- [case "${enableval}" in
++ AC_HELP_STRING([--disable-ipv6],[disable IPv6 support]),
++ [case "${enableval}" in
+ yes) ipv6=true ;;
+ no) ipv6=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-ipv6) ;;
+@@ -75,13 +56,10 @@
+
+ if test x$ipv6 = xtrue; then
+ AC_CACHE_CHECK([for IPv6 support], ac_cv_ipv6_support,
+- [AC_TRY_LINK([[
+-#include <sys/types.h>
++ [AC_TRY_LINK([ #include <sys/types.h>
+ #include <sys/socket.h>
+-#include <netinet/in.h>
+- ]], [[
+-struct sockaddr_in6 s; struct in6_addr t=in6addr_any; int i=AF_INET6; s; t.s6_addr[0] = 0;
+- ]], [ac_cv_ipv6_support=yes], [ac_cv_ipv6_support=no])])
++#include <netinet/in.h>], [struct sockaddr_in6 s; struct in6_addr t=in6addr_any; int i=AF_INET6; s; t.s6_addr[0] = 0; ],
++ [ac_cv_ipv6_support=yes], [ac_cv_ipv6_support=no])])
+
+ if test "$ac_cv_ipv6_support" = yes; then
+ AC_DEFINE(HAVE_IPV6,1,[Whether to enable IPv6 support])