aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch')
-rw-r--r--meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch50
1 files changed, 26 insertions, 24 deletions
diff --git a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
index dcc2a37196..e2165c2fa5 100644
--- a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
+++ b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
@@ -10,16 +10,19 @@ plugin
Makes it compile/build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Patch Reworked for xfce4-mount-plugin 0.6.4->1.1.2
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
---
configure.ac | 1 +
- panel-plugin/devices.c | 22 ++++++++++++++++++----
- 2 files changed, 19 insertions(+), 4 deletions(-)
+ panel-plugin/devices.c | 22 +++++++++++++++++++---
+ 2 files changed, 20 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 34d6f7f..52ecc4a 100644
+index b131117..c633fef 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -67,6 +67,7 @@ AC_CHECK_HEADERS([sys/socket.h])
+@@ -69,6 +69,7 @@ AC_CHECK_HEADERS([sys/socket.h])
AC_CHECK_HEADERS([sys/time.h])
AC_CHECK_HEADERS([unistd.h])
AC_CHECK_HEADERS([sys/sockio.h])
@@ -28,10 +31,10 @@ index 34d6f7f..52ecc4a 100644
AC_PROG_GCC_TRADITIONAL
AC_TYPE_SIZE_T
diff --git a/panel-plugin/devices.c b/panel-plugin/devices.c
-index afa954e..345b603 100644
+index 797b079..d29df56 100644
--- a/panel-plugin/devices.c
+++ b/panel-plugin/devices.c
-@@ -24,8 +24,9 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+@@ -24,8 +24,10 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#ifdef HAVE_CONFIG_H
#include <config.h>
#endif
@@ -39,41 +42,40 @@ index afa954e..345b603 100644
+#if HAVE_FSTAB_H
#include <fstab.h>
+#endif
++
#include <glib.h>
#include <stdio.h>
#include <string.h>
-@@ -370,14 +371,15 @@ out:
- GPtrArray *
- disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
+@@ -468,11 +470,12 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
{
-- GPtrArray * pdisks; /* to be returned */
-+ GtkWidget *dialog;
+ GPtrArray * pdisks; /* to be returned */
t_disk * pdisk;
- struct fstab *pfstab;
-+ GPtrArray * pdisks; /* to be returned */
gboolean has_valid_mount_device;
-- GtkWidget *dialog;
pdisks = g_ptr_array_new();
-+#if HAVE_FSTAB_H
++#if HAVE_FSTAB_H
+ struct fstab *pfstab;
/* open fstab */
if (setfsent()!=1)
{
-@@ -422,6 +424,18 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
+@@ -526,7 +529,20 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
+ } /* end for */
endfsent(); /* close file */
-
+-
+#else
++ /* popup notification dialog */
+ if (! (*showed_fstab_dialog) ) {
-+ dialog = gtk_message_dialog_new (NULL, GTK_DIALOG_DESTROY_WITH_PARENT,
-+ GTK_MESSAGE_INFO, GTK_BUTTONS_OK,
-+ "Your /etc/fstab could not be read because fstab is not supported. This will severely degrade the plugin's abilities.");
-+ /* gtk_dialog_run (GTK_DIALOG (dialog)); */
-+ g_signal_connect (dialog, "response",
-+ G_CALLBACK (gtk_widget_destroy), dialog);
-+ gtk_widget_show (dialog);
++ xfce_message_dialog (NULL,
++ _("Xfce 4 Mount Plugin"),
++ "dialog-info",
++ _("Your /etc/fstab could not be read because fstab is not supported. This will severely degrade the plugin's abilities."),
++ NULL,
++ "gtk-ok",
++ GTK_RESPONSE_OK,
++ NULL);
+ *showed_fstab_dialog = TRUE;
+ }
+#endif
@@ -81,5 +83,5 @@ index afa954e..345b603 100644
}
--
-2.12.0
+2.9.3