aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/exo/exo_0.10.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/exo/exo_0.10.4.bb')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.10.4.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.4.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.4.bb
new file mode 100644
index 0000000000..eeb2e75388
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo_0.10.4.bb
@@ -0,0 +1,36 @@
+DESCRIPTION="Application library for the Xfce desktop environment"
+SECTION = "x11"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
+DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
+
+inherit xfce pythonnative perlnative gtk-doc
+
+# SRC_URI must follow inherited one
+SRC_URI += " \
+ file://exo-no-tests-0.8.patch \
+ file://configure.patch \
+"
+
+SRC_URI_append_class-native = " \
+ file://reduce-build-to-exo-csource-only.patch \
+"
+
+SRC_URI[md5sum] = "fe54dad8b897af36628da46b33844f95"
+SRC_URI[sha256sum] = "cced5fdbc0b61a5d976210ff71ecdd81b89fcd15e5860a44f50da7b83fb2deaa"
+
+PACKAGES =+ "exo-csource"
+
+# Note: python bindings did not work in oe-dev and are about to be moved to
+# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
+FILES_${PN} += "${datadir}/xfce4/ \
+ ${libdir}/xfce4/exo-1 \
+"
+
+FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
+"
+
+FILES_exo-csource += "${bindir}/exo-csource"
+
+BBCLASSEXTEND = "native"