aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/cups/cups-1.4.6/configure.patch (renamed from recipes-support/cups/cups-1.4.4/configure.patch)0
-rw-r--r--recipes-support/cups/cups-1.4.6/skip_tools.patch (renamed from recipes-support/cups/cups-1.4.4/skip_tools.patch)0
-rw-r--r--recipes-support/cups/cups-1.4.6/use_echo_only_in_init.patch (renamed from recipes-support/cups/cups-1.4.4/use_echo_only_in_init.patch)0
-rw-r--r--recipes-support/cups/cups.inc8
-rw-r--r--recipes-support/cups/cups_1.4.6.bb (renamed from recipes-support/cups/cups_1.4.4.bb)11
5 files changed, 9 insertions, 10 deletions
diff --git a/recipes-support/cups/cups-1.4.4/configure.patch b/recipes-support/cups/cups-1.4.6/configure.patch
index 877e8d3232..877e8d3232 100644
--- a/recipes-support/cups/cups-1.4.4/configure.patch
+++ b/recipes-support/cups/cups-1.4.6/configure.patch
diff --git a/recipes-support/cups/cups-1.4.4/skip_tools.patch b/recipes-support/cups/cups-1.4.6/skip_tools.patch
index 272110146b..272110146b 100644
--- a/recipes-support/cups/cups-1.4.4/skip_tools.patch
+++ b/recipes-support/cups/cups-1.4.6/skip_tools.patch
diff --git a/recipes-support/cups/cups-1.4.4/use_echo_only_in_init.patch b/recipes-support/cups/cups-1.4.6/use_echo_only_in_init.patch
index 21ff0e535b..21ff0e535b 100644
--- a/recipes-support/cups/cups-1.4.4/use_echo_only_in_init.patch
+++ b/recipes-support/cups/cups-1.4.6/use_echo_only_in_init.patch
diff --git a/recipes-support/cups/cups.inc b/recipes-support/cups/cups.inc
index 0f813ca492..8f97f12338 100644
--- a/recipes-support/cups/cups.inc
+++ b/recipes-support/cups/cups.inc
@@ -25,7 +25,7 @@ EXTRA_OECONF = " \
do_configure() {
- export DSOFLAGS="${LDFLAGS}"
+ export DSOFLAGS="${LDFLAGS}"
gnu-configize
libtoolize --force
oe_runconf
@@ -45,11 +45,11 @@ do_compile () {
"-I."
}
-fakeroot do_install () {
+do_install () {
oe_runmake "DSTROOT=${D}" install
- # This directory gets installed with perms 511, which makes packaging fail
- chmod 0711 "${D}/${localstatedir}/run/cups/certs"
+ # This directory gets installed with perms 511, which makes packaging fail
+ chmod 0711 "${D}/${localstatedir}/run/cups/certs"
}
python do_package_append() {
diff --git a/recipes-support/cups/cups_1.4.4.bb b/recipes-support/cups/cups_1.4.6.bb
index df5bf585d5..850b80c5cc 100644
--- a/recipes-support/cups/cups_1.4.4.bb
+++ b/recipes-support/cups/cups_1.4.6.bb
@@ -1,5 +1,7 @@
require cups14.inc
+DEPENDS += "virtual/libusb0"
+
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=956e7600195e6139f12de8c2a5bbefa9"
SRC_URI += " \
@@ -8,12 +10,9 @@ SRC_URI += " \
file://configure.patch \
"
-SRC_URI[md5sum] = "8776403ad60fea9e85eab9c04d88560d"
-SRC_URI[sha256sum] = "d25ffa35add3abeeec0eba60be2cffc89425b649c64ef3a73dfc724683a59aa3"
+SRC_URI[md5sum] = "de8fb5a29c36554925c0c6a6e2c0dae1"
+SRC_URI[sha256sum] = "f08711702a77b52c7150f96fe1f45482f6151cb95ef601268c528607fe6ad514"
-PR = "r2"
+EXTRA_OECONF += " --disable-gssapi --enable-debug --disable-relro --enable-libusb"
-DEFAULT_PREFERENCE = "-1"
-DEPENDS += "virtual/libusb0"
-EXTRA_OECONF += " --disable-gssapi --disable-largefile --enable-debug --disable-relro --enable-libusb"
CONFFILES_${PN} += "${sysconfdir}/cups/cupsd.conf"