aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* zsh: update to 5.4.1dankm/zshDan McGregor2017-08-228-61/+434
| | | | | | Also fix up autoconf to use pkg-config, and properly detect pcre. Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
* tmux: uprev to 2.5Dan McGregor2017-08-221-1/+4
| | | | Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
* htop: update to 2.0.2Dan McGregor2017-08-223-22/+56
|
* json-spirit: Add -latomic to LDFLAGSMing Liu2017-08-131-0/+2
| | | | | | | | | | | This fixes following errors when compiling with clang: | ../json_spirit/libjson_spirit.so.4.0.8: error: undefined reference to '__atomic_load_4' | ../json_spirit/libjson_spirit.so.4.0.8: error: undefined reference to '__atomic_compare_exchange_4' | ../json_spirit/libjson_spirit.so.4.0.8: error: undefined reference to '__atomic_fetch_sub_4' | ../json_spirit/libjson_spirit.so.4.0.8: error: undefined reference to '__atomic_fetch_add_4' Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* rapidjson: avoid dependency to non-existing packageStefan Agner2017-08-131-0/+1
| | | | | | | | | | | | | | RapidJSON is a header only library. The automatic package split leads to no 'rapidjson' package but a 'rapidjson-dev' package with a dependency to the 'rapidjson' package, leading to errors like: * Solver encountered 1 problem(s): * Problem 1/1: * - nothing provides rapidjson = 1.1.0+git0+e5635fb27f-r0 needed by rapidjson-dev-1.1.0+git0+e5635fb27f-r0.core2-64 Clear rapidjson-dev dependencies. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-pytest: update to version 3.2.0Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-prompt-toolkit: update to version 1.0.15Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-django: update to version 1.11.4Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-requests: update to version 2.18.3Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-cryptography: update to version 2.0.3Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-cryptography-vectors: update to version 2.0.3Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-pyasn1: update to version 0.3.2Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-pymongo: update to version 3.5.0Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-iso8601: update to version 0.1.11Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-sdnotify: update to version 0.3.2Derek Straka2017-08-133-6/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-decorator: update to version 4.1.2Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-certifi: update to version 2017.7.27.1Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-typing: update to version 3.6.2Derek Straka2017-08-132-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-idna: update to version 2.6Derek Straka2017-08-133-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* webmin: update to version 1.850Derek Straka2017-08-131-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* opencv: update to version 3.3.Ismo Puustinen2017-08-139-590/+93
| | | | | | | | | | | Update OpenCV recipe from version 3.2 to 3.3. Rebase patches and drop those which are no longer relevant or already contained in upstream OpenCV. Fix changed build options, such as UPDATE_PROTO_FILES to PROTOBUF_UPDATE_FILES. Update also subcomponents (opencv-contrib and opencv-3rdparty) to match with 3.3. Signed-off-by: Ismo Puustinen <ismo.puustinen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* tigervnc: fix a clang compiling issueHongxu Jia2017-08-132-0/+28
| | | | | | | Backport a fix from upstream Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libblockdev: fix a clang compiling issueHongxu Jia2017-08-132-0/+112
| | | | | | | | | | | | | | | | | [snip] ../../../git/src/plugins/fs.c:2617:26: error: missing field 'start' initializer [-Werror,-Wmissing-field-initializers] PedGeometry geom = {0}; ^ ../../../git/src/plugins/fs.c:2618:30: error: missing field 'start' initializer [-Werror,-Wmissing-field-initializers] PedGeometry new_geom = {0}; [snip] Fix typo s/enum libvk_packet_format format/enum libvk_secret secret_type/ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* fbida: Fix build with libjpeg-turboKhem Raj2017-08-134-1/+1885
| | | | | | | | Dont hardcode cpp to point to gcc collection, helps compiling with clang Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* collectd: Fix build with clangKhem Raj2017-08-131-4/+8
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python-grpcio: Do not hardcode compiler -std optionsKhem Raj2017-08-132-0/+38
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python3-twisted: Fix build with clangKhem Raj2017-08-132-0/+79
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mongodb: Upgrade to 3.4.6Khem Raj2017-08-133-5/+107
| | | | | | | | Add missing Zlib to license list Add patches to fix build issue with gcc7 and missing internal build dependency Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* llvm: RemoveKhem Raj2017-08-136-283/+0
| | | | | | | Moved to OE-core, with a version upgrade Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* php7: upgrade to 7.1.7Khem Raj2017-08-134-14/+78
| | | | | | | | License checksum changed due to opyright year changed to 2017 Fix build with clang/hardening Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* poppler: update 0.53.0 -> 0.57.0Andreas Müller2017-08-131-3/+3
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* kodi: fix build with latest gccAndreas Müller2017-08-132-0/+97
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-screenshooter: update 1.8.2 -> 1.9.1Andreas Müller2017-08-132-33/+2
| | | | | | | | 0001-Makefile.am-create-ouput-directory-for-desktop-file.patch was applied upstream Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-xkb-plugin: update 0.7.1 -> 0.8.0Andreas Müller2017-08-131-3/+3
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-clipman-plugin: update 1.4.1 -> 1.4.2Andreas Müller2017-08-131-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-whiskermenu-plugin: update 2.1.2 -> 2.1.3Andreas Müller2017-08-131-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-terminal: update 0.8.4 -> 0.8.6Andreas Müller2017-08-131-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* thunar: update 1.6.11 -> 1.6.12Andreas Müller2017-08-131-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* exo: update 0.11.2 -> 0.11.5Andreas Müller2017-08-132-27/+17
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* pidgin: Update from 2.11.0 to 2.12.0Herrie2017-08-131-2/+2
| | | | Signed-off-by: Herman van Hazendonk <github.com@herrie.org>
* libotr: Upgrade from 4.0.0 to 4.1.1 and update patchesHerrie2017-08-133-6/+6
| | | | Signed-off-by: Herman van Hazendonk <github.com@herrie.org>
* bluez4: remove bluez4-only recipesMartin Jansa2017-08-1327-870/+0
| | | | | | | | | | | | | | | | | | | | | * remove recipes which support only bluez4 and are blacklisted when bluez5 is selected in DISTRO_FEATURES, if someone is still using bluez4, then it can be restored in separate meta-bluez4 and maintained by people using it. * there are few recipes which support both bluez5 or bluez4 based on selected DISTRO_FEATURES, these can stay in meta-oe repository, but now people without bluez5 in DISTRO_FEATURES will need to add meta-bluez4 layer to satisfy bluez4 dependency meta-gnome/recipes-connectivity/obex/obexd_0.48.bb:DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.18.2.bb: ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)} \ meta-oe/recipes-connectivity/obex/obex-data-server_0.4.6.bb:DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb:DEPENDS_append_class-target = " ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb:RDEPENDS_bluez4 = " \ meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb:# Install bluez4 tools or bluez5 tools depending on what is specified in the distro. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* uim: Fixed a problem that an immodule.cache is not updated appropriately ↵Yusuke Mitsuki2017-08-131-5/+2
| | | | | | | | | | | when uim-gtk2.0 or uim-gtk3 was installed. pkg_postinst_uim-gtk2.0 is not worked. Plus, uim-gtk3 is not supported. oe-core has gtk-immodule-cache class for update the immodule.cache. Modified to use the this class instead of pkg_post_uim-gtk2.0 and added support to uim-gtk3. Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* uim: Fixed pkg_postinst_*/pkg_prerm_* for uim-anthy and uim-skk.Yusuke Mitsuki2017-08-131-15/+18
| | | | | | | | | pkg_postinst*/pkg_prerm_* functions are not worked correctly. Because uim-module-manager executes on the host machine. It needs executed via qemu. Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* uim: Removed pkg_postinst_uim-common/pkg_prerm_uim-common.Yusuke Mitsuki2017-08-131-15/+0
| | | | | | | | These functions are not worked correctly. However default im is installed. thus we determined it not need. Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* uim: Added glibc-utils and glibc-gconv-euc-jp to RDEPENDS_uim-anthyYusuke Mitsuki2017-08-131-1/+1
| | | | | | | | | | To uim-anthy is working correctly needs register by uim-module-manager. However 'uim-module-manager --register anthy' is failed. Because uim-module-manager uses iconv(EUCJP to UTF8) internally. iconv needs glibc-utils and EUCJP conversion needs glibc-gconv-euc-jp. Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* uim: add dependency on anthyYusuke Mitsuki2017-08-131-1/+1
| | | | | | | | | | | | anthy.h could not found at confiugre of uim. class-target override was used incorrectly with +=, but instead of expected append to DEPENDS set above it overrided whole DEPENDS for target builds so anthy was missing. Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* uim: Modified the order of package definition.Yusuke Mitsuki2017-08-131-1/+1
| | | | | | | | The uim-anthy package is created that empty. To avoid this problem by defining a packages with a rough PATH list after the uim-anthy package. Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libextutils-parsexs-perl: update to version 3.35Derek Straka2017-08-131-3/+3
| | | | | | | Update license checksum and verify terms are unchanged Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libmoo-perl: update to version 2.003002Derek Straka2017-08-131-3/+3
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>