aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
...
* libio-socket-ssl-perl: 2.059 -> 2.060Kai Kang2018-11-021-2/+2
| | | | | Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* gvfs: 1.36.2 -> 1.39.1Kai Kang2018-11-021-21/+23
| | | | | | | | | | Upgrade gvfs from 1.36.2 to 1.39.1. * autotools has been removed, use meson instead * add packageconfigs dnssd and logind * disable options bluray, goa, google and nfs Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libwnck3: 3.24.1 -> 3.30.0Kai Kang2018-11-021-2/+2
| | | | | Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* thunar: 1.8.1 -> 1.8.2Kai Kang2018-11-021-2/+2
| | | | | Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xfce4-notifyd: 0.4.2 -> 0.4.3Kai Kang2018-11-021-2/+2
| | | | | Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xfce4-clipman-plugin: 1.4.2 -> 1.4.3Kai Kang2018-11-021-2/+2
| | | | | Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xfconf: 4.13.5 -> 4.13.6Kai Kang2018-11-021-2/+3
| | | | | | | | Upgrade xfconf from 4.13.5 to 4.13.6. * update FILES Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* netkit-telnet: fix qa warnings of alternative targetKai Kang2018-11-021-0/+1
| | | | | | | | | | | | | | | | | | | When build lib32-netkit-telnet that multilib is enabled, it shows qa warnings of alternative target: | WARNING: lib32-netkit-telnet-0.17-r0 do_package: netkit-telnet: | alternative target (/usr/bin/telnet or /usr/bin/telnet.netkit-telnet) | does not exist, skipping... | WARNING: lib32-netkit-telnet-0.17-r0 do_package: netkit-telnet: NOT | adding alternative provide /usr/bin/telnet: | /usr/bin/telnet.netkit-telnet does not exist | WARNING: lib32-netkit-telnet-0.17-r0 do_package: netkit-telnet: alt_link | == alt_target: /usr/bin/telnet == /usr/bin/telnet Set ALTERNATIVE_TARGET to fix the issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libyui-ncurses: fix ncurses find modulePascal Bach2018-11-022-0/+36
| | | | | | | | This makes the module look in the standard locations instead of only some hard coded ones. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libyui: make resulting cmake config relocatablePascal Bach2018-11-022-0/+131
| | | | | Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* civetweb: disable testsPascal Bach2018-11-021-0/+1
| | | | | | | | Tests try to download third party code and bypass the bitbake fetcher to do that. This will not work in environments with no internet access. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* civetweb: remove redundant EXTRA_OECMAKE_class-nativePascal Bach2018-11-021-6/+0
| | | | | | | They are the same as the default version. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-twisted: Add more python-twisted-* packages to the "meta" packageMark Asselstine2018-11-022-0/+7
| | | | | | | | | | | | | | | | | Whereas the python-twisted-core package is used to install the minimum components of python-twisted, the python-twisted package is essentially a 'meta' package which installs all of the python-twisted-* packages (used by folks that don't want to determine which components they are interested in). Add additional packages to the python-twisted 'meta' package. NOTE: that there are still modules of python-twisted which have not been ported to python3 (see src/twisted/python/_setup.py "notPortedModules") so the installed packages for py2 vs. py3 will not be the same (ie. python-twisted-news is only part of the py2 package). Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-pyiface: Upgrade to 0.0.11Alexandru Vasiu2018-11-023-2/+2
| | | | | Signed-off-by: Alexandru Vasiu <alexandru.vasiu@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uriparser: Allow native buildSam Nobs2018-11-011-0/+2
| | | | | | | | | It is useful to be able to build a native version of uriparser e.g. when you're building your entire distribution on native for validation and testing purposes. Signed-off-by: Sam Nobs <samuel.nobs@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* netcat-openbsd: update SRC_URIChangqing Li2018-11-011-2/+2
| | | | | | | update SRC_URI since previous is not valid now Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* netkit-telnet: update SRC_URIChangqing Li2018-11-011-1/+1
| | | | | | | update SRC_URI since previous is not valid now Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vlan: update SRC_URIChangqing Li2018-11-011-1/+1
| | | | | | | | tar on previous link checksum changed, so changed SRC_URI to get previous tar Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* lvm2: update SRC_URIMingli Yu2018-11-011-1/+1
| | | | | | | | | Update SRC_URI for lvm2 as the previous one is invalid. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Tested-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* geoip: update md5sum and sha256sumChangqing Li2018-11-011-8/+8
| | | | | | | | Geolite database update periodically, md5sum and sha256sum have changed, update them Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uftrace: Support x86Yi-Soo An2018-11-011-2/+11
| | | | | | | | | | | If TARGET_ARCH is not set to i386 for x86, build will be failed with logs such as "arch/i586: No such file or directory". In this case, TARGET_ARCH is set to i586. To succeed the build, add additional function named set_target_arch. Signed-off-by: Yi-Soo An <yisooan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libssh: Do not use thumb-1 ISA on armv5Khem Raj2018-10-271-0/+2
| | | | | | | | | Fixes TOPDIR/build/tmpfs/work/armv5te-yoe-linux-gnueabi/libssh/0.8.4-r0/git/src/channels.c:2632:1: sorry, unimplemented: -fstack-check=specific for Thumb-1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Paul Eggleton <paul.eggleton@linux.intel.com>
* kernel-selftest: temporary disable bpf for arm - fix build for qemuarmAndrea Adami2018-10-271-0/+1
| | | | | | | | | | | | | | | Even running on 32bit the bpf objects are 64bit: this triggers the QA about bitsize mismatch 32 vs. 64. Besides, objdump does not recognize the arch 0xf7. Trying the workaround to use the llvm-objdump and setting TOOLCHAIN = "clang" the build for arm fails on libcxx |include/c++/8.2.0/atomic:250: undefined reference to `__atomic_load_4' Temporary disable bpf as done for x86/32bit as it seems still unstable. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* network-manager-applet: upgrade 1.8.14 -> 1.8.18Andreas Müller2018-10-261-2/+3
| | | | | | | Add a packageconfig for mobile-broadband-provider-info - disabled by default Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* packagegroup-xfce-extended: add catfish / xfce4-panel-profilesAndreas Müller2018-10-261-0/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xfce4-panel-profiles: initial add 1.0.8Andreas Müller2018-10-261-0/+28
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* poppler: upgrade 0.69.0 -> 0.70.1Andreas Müller2018-10-261-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* catfish: initial add 1.4.6Andreas Müller2018-10-261-0/+17
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* exo: upgrade 0.12.2 -> 0.12.3Andreas Müller2018-10-261-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: eliminate systemd ExecStart editMax Kellermann2018-10-261-6/+0
| | | | | | | | This was never necessary because MPD's build script already inserts the correct path. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: remove deprecated "enable_bzip2=yes" lineMax Kellermann2018-10-261-1/+0
| | | | | | | | This should have been removed in commit 5a06148e58ca5a7558dd4b438a61d22caa8dfffe Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: update to 0.20.22Max Kellermann2018-10-261-1/+4
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ] Add recipes for django rest frameworkJoris Offouga2018-10-263-0/+20
| | | | | Signed-off-by: Joris Offouga <offougajoris@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* openldap: Reproducibility: Remove user, hostname, pwd from version stringdouglas.royds2018-10-261-5/+22
| | | | | | | | | | This updated patch also sets the date and time strings to the SOURCE_DATE_EPOCH. The WHOWHERE string will now be set to simply "openldap" in the case that a SOURCE_DATE_EPOCH is set. Upstream-Status: Submitted [https://www.openldap.org/its/index.cgi/Incoming?id=8928] Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rapidjson: Update to newer 1.1.0 + gitJoshua Watt2018-10-251-4/+2
| | | | | | | | | | | | | | Bring in a newer version of rapidjson which includes a fixes when running on ARM, specifically 748a652f04 ("Fix SIGBUS due to unaligned access") Also remove the existing patch file as the issue was resolved in the mainline by 4c9a28a28e ("CMake: do not pass -march=native or -mcpu=native when crosscompiling") Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Veselin Georgiev <veselin.georgiev@garmin.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* redis: fix build for qemuarm disabling atomicsAndrea Adami2018-10-251-0/+1
| | | | | | | | | | | | Apply the same patch used for mips. Fix |ld: networking.o: in function `createClient': | /usr/src/debug/redis/4.0.8-r0/redis-4.0.8/src/networking.c:93: undefined reference to `__atomic_fetch_add_8' Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mbedtls: upgrade to 2.13.0Johannes Pointner2018-10-251-2/+2
| | | | | Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libgit2: Upgrade to 0.27.5Khem Raj2018-10-251-3/+3
| | | | | | add missing dep on libgcrypt Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpc: update to 0.31Max Kellermann2018-10-241-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ncmpc: add PACKAGECONFIG[regex]Max Kellermann2018-10-231-2/+2
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ncmpc: update to 0.33Max Kellermann2018-10-231-5/+5
| | | | | | | Several build options have been changed from "boolean" to "feature", and thus we have to change "true/false" to "enabled/disabled". Signed-off-by: Khem Raj <raj.khem@gmail.com>
* adduser: Update SRC_URIMingli Yu2018-10-231-1/+1
| | | | | | | | Update SRC_URI for adduser as the previous one is invalid. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* snort: Update SRC_URIMingli Yu2018-10-231-1/+1
| | | | | | | | Update SRC_URI for snort as the previous one is invalid. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libssh: upgrade to 0.8.4Paul Eggleton2018-10-221-2/+2
| | | | | | | | | | | | | Notable changes since 0.7.3: * Fixed CVE-2018-10933 authentication bypass * Removed support for deprecated SSHv1 protocol * Added support for OpenSSL 1.1 * Added support for chacha20-poly1305 cipher * Added ECDSA support with gcrypt backend * Improved threading support (note: libssh_threads is now gone) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: Fix build issue with timezone 2018f updateArmin Kuster2018-10-223-0/+7618
| | | | | | | Sync our copy of the timezone library with IANA release tzcode2018f. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libqmi: Make udev and mbim configurable through PACKAGECONFIGAdrian Bunk2018-10-211-1/+5
| | | | | Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libqmi: Add upstream fix for a 1.20.2 regressionAdrian Bunk2018-10-212-0/+42
| | | | | Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* modemmanager: Upgrade to 1.8.2Adrian Bunk2018-10-212-69/+2
| | | | | | | | | Obsolete patch dropped, upstream solved this differently: Use realpath() instead of canonicalize_filename(), fixing build with musl libc. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* add a storage I/O benchmark test suiteAnders Roxell2018-10-191-0/+30
| | | | | Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* openipmi: not install .pyc and .pyo filesKai Kang2018-10-192-0/+27
| | | | | | | | | | | | | openipmi load swig/python/.libs/_OpenIPMI.so to create .pyc and .pyo files. It fails when multilib is enable: | ImportError: .../lib32-openipmi/2.0.25-r0/OpenIPMI-2.0.25/swig/python/.libs/_OpenIPMI.so: | wrong ELF class: ELFCLASS32 Don't compile and install .pyc and .pyo files to fix the failure. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>