aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* net-snmp: Fix PACKAGECONFIG for perlrbt/pkgconfigRobert Yang2019-09-271-4/+5
| | | | | | | | | | | | | | | * Remove perl-lib since it had been removed by oe-core: commit 68552c353255188de3d5b42135360a30e7eac535 Author: Alexander Kanavin <alex.kanavin@gmail.com> Date: Sun Dec 2 12:46:37 2018 +0100 perl: remove the previous version of the recipe Now the files are in perl pacakge. * Fix perl paths when perl is enabled. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* corosync: Fix PACKAGECONFIG flag for rdmaRobert Yang2019-09-271-1/+1
| | | | | | | | | | | | Fixed: PACKAGECONFIG_append_pn-corosync = ' rdma' $ bitbake corosync | configure: error: Package requirements (rdmacm) were not met: | | No package 'rdmacm' found Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* python-paste: upgrade 3.2.0 -> 3.2.1Zang Ruochen2019-09-251-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-alembic: upgrade 1.2.0 -> 1.2.1Zang Ruochen2019-09-253-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tesseract-lang: update to 4.0.0Oleksandr Kravchuk2019-09-251-3/+3
| | | | | Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* sanlock: update to 3.6.0Oleksandr Kravchuk2019-09-252-84/+2
| | | | | Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libyui-ncurses: udpate to 2.52.0Oleksandr Kravchuk2019-09-253-200/+1
| | | | | Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libyui: update to 3.6.0Oleksandr Kravchuk2019-09-252-35/+1
| | | | | Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uim: Fix cross-buildsKhem Raj2019-09-253-27/+36
| | | | | | riscv is not yet supported to exclude it Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Remove non building arches from COMPATIBLE_HOSTKhem Raj2019-09-251-9/+1
| | | | | | c++17 is default now so we don't need to edit out c++11 options Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmicrohttpd: backport the fix for building with older gnutlsMartin Jansa2019-09-252-1/+35
| | | | | | | | | | | | * with gnutls from meta-gplv2 libmicrohttpd fails to build now: libmicrohttpd-0.9.66/src/microhttpd/daemon.c:2539:7: error: unknown type name 'gnutls_init_flags_t'; did you mean 'gnutls_pin_flag_t'? 2539 | gnutls_init_flags_t flags; backport the fix from master branch * see https://bugs.gnunet.org/view.php?id=5806 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* crash: update from 7.2.6 to 7.2.7Randy MacLeod2019-09-251-1/+1
| | | | | | | Change log: http://people.redhat.com/anderson/crash.changelog.html Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* haveged: upgrade v1.9.4 -> v1.9.6Trevor Gamblin2019-09-253-56/+2
| | | | | | | | | Both of the patches used in v1.9.4 have been incorporated in v1.9.6, so they are no longer required - see upstream commits ceab89ad and f2193587. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* spice: Drop broken nativeRobert Yang2019-09-251-2/+1
| | | | | | | | | | | | $ bitbake spice-native checking whether the C compiler works... no configure: error: in `/path/to/spice-native/0.14.2+gitAUTOINC+7cbd70b931_4fc4c2db36-r0/build': configure: error: C compiler cannot create executables It's a broken native recipe which means no ones need it any more, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* iperf3: Drop broken nativeRobert Yang2019-09-251-2/+0
| | | | | | | | | | $ bitbake iperf3-native configure: error: --with-openssl was given, but test for OpenSSL failed It's a broken native recipe which means no ones need it any more, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libnet-dns-sec-perl: Drop broken nativeRobert Yang2019-09-251-2/+0
| | | | | | | | | | $ bitbake libnet-dns-sec-perl-native ERROR: Nothing RPROVIDES 'libcrypto-native' (but virtual:native:/path/to/meta-perl/recipes-perl/libnet/libnet-dns-sec-perl_1.10.bb RDEPENDS on or otherwise requires it) It's a broken native recipe which means no ones need it any more, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libnet-ssleay-perl: Drop broken nativeRobert Yang2019-09-251-2/+0
| | | | | | | | | | $ bitbake libnet-ssleay-perl-native ERROR: Nothing RPROVIDES 'libssl-native' (but virtual:native:/path/to/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb RDEPENDS on or otherwise requires it) It's a broken native recipe which means no ones need it any more, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* keyutils: Fix installed-vs-shipped for nativesdkRobert Yang2019-09-251-0/+12
| | | | | | | | | | | | | | | | | Fixed: $ bitbake nativesdk-keyutils ERROR: nativesdk-keyutils-1.6-r0 do_package: QA Issue: nativesdk-keyutils: Files/directories were installed but not shipped in any package: /usr /etc /usr/share /usr/share/man /usr/share/keyutils [snip] /etc/request-key.conf /etc/request-key.d Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* fuse: Fix installed-vs-shipped for nativesdkRobert Yang2019-09-251-1/+7
| | | | | | | | | | | | | | | | | | | | | | | There are two problems: * The /dev is installed to '${D}/dev', not '${D}${base_prefix}' * The /etc is installed ${D}, but should be ${D}${sysconfdir} It works for target is because target's base_prefix is NULL, but it isn't work for native or nativesdk. Fixed: $ bitbake nativesdk-fuse ERROR: nativesdk-fuse-2.9.9-r0 do_package: QA Issue: nativesdk-fuse: Files/directories were installed but not shipped in any package: /dev /etc /etc/init.d /etc/udev /etc/init.d/fuse /etc/udev/rules.d /etc/udev/rules.d/99-fuse.rules Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-incremental: Drop broken nativesdkRobert Yang2019-09-251-1/+1
| | | | | | | | | | | | | | | | The nativesdk-python3-incremental doesn't work since lacks of dependencies, and hard to satisfy that, I tried to extend the following ones' nativesdk, but it still didn't work: python-automat python-constantly python-hyperlink python-twisted python-zopeinterface So just drop the broken nativesdk. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-asn1crypto: extend to nativesdkRobert Yang2019-09-251-1/+1
| | | | | | | | | Fixed: $ bitbake nativesdk-python3-cryptography ERROR: Nothing PROVIDES 'nativesdk-python3-asn1crypto' Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* add new recipes for python-lrparsing, python3-lrparsingCallaghan, Dan2019-09-253-0/+20
| | | | | | | The lrparsing library is an LR(1) parsing library for Python. Grammars can be defined using Python expressions. Signed-off-by: Khem Raj <raj.khem@gmail.com>
* firewalld: add UPSTREAM_CHECK_URICallaghan, Dan2019-09-251-0/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-protobuf: upgrade 3.9.1 -> 3.9.2Zang Ruochen2019-09-253-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-cmd2: upgrade 0.9.16 -> 0.9.17Zang Ruochen2019-09-253-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xterm: upgrade 348 -> 349Zang Ruochen2019-09-251-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* protobuf: upgrade 3.9.1 -> 3.9.2Zang Ruochen2019-09-241-1/+1
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* fio: upgrade 3.15 -> 3.16Zang Ruochen2019-09-242-45/+1
| | | | | | | | -files/0001-engines-splice-remove-buggy-mem_align-set.patch Removed since this is included in 3.16. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-test-generator: add recipeAnuj Mittal2019-09-231-0/+15
| | | | | | | | Generator is a helper for generating test methods for nose while still using unittest. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Fix build on musl/aarch64Khem Raj2019-09-233-31/+32
| | | | | | | one impl of strerror_r is glibc specific, therefore check for __GLIBC__ also before using it Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nmap: Update to 7.80Peiran Hong2019-09-232-36/+31
| | | | | | | | | | | | | | | | Updates nmap to v7.80, this solves the following CVEs: - CVE-2017-18594 - CVE-2018-15173 and addressed numerous bugs as well. The patch '0001-include-time.h-for-time-structure-definition.patch' is modified to be applicable to the new version while serving for the same purpose. The license changed in the commit https://github.com/nmap/nmap/commit/d639a53 and is only a date bump without modification of any content in the license. Signed-off-by: Peiran Hong <peiran.hong@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libstatgrab: add recipe for libstatgrab-0.92Jens Rehsack2019-09-231-0/+27
| | | | | | | | | | | With the recent update at begin of summer, which includes the fix for nxp bsp issues, it's time to bring libstatgrab to more people than the few who use it in datacenter monitoring. Language bindings will follow once base library is settled. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-dtschema: new packageBartosz Golaszewski2019-09-231-0/+15
| | | | | | | | | | | This adds a recipe for dtschema package developed by Rob Herring for easy validation of YAML device-tree files in the linux kernel. The version is current git as the only release so far - v0.1 - is old and doesn't work with kernel's dt_binding_check make target. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* sshfs-fuse: upgrade 2.10 -> 3.5.2Bartosz Golaszewski2019-09-231-8/+5
| | | | | | | | Build system has been changed to meson. The webpage has been moved from sourceforge to github. The package also now depends on fuse3 not fuse2. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-ruamel-yaml: new packageBartosz Golaszewski2019-09-231-0/+16
| | | | | | | | | Add a pypi recipe for ruamel-yaml parser. Based on the recipe found in meta-homeassistant by Oleksandr Andrushchenko. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* phpmyadmin: upgrade 4.9.0.1 -> 4.9.1Yi Zhao2019-09-231-3/+3
| | | | | | | License-Update: tecnickcom/tcpdf/LICENSE.TXT: copyright years updated. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-urllib3: upgrade 1.25.3 -> 1.25.5Zang Ruochen2019-09-233-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* numactl: fix a error about lib32-numactlHongzhi.Song2019-09-232-0/+101
| | | | | | | | | | | | | | lib32-numactl has a error: root@intel-x86-64:~# numademo -t -e 1M Configured Nodes does not match available memory nodes That's because (long long int) is assigned to (long int). This will cause (long int) overflow on 32bit system. Unify variable types and fix it. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-pytest: upgrade 5.1.2 -> 5.1.3Zang Ruochen2019-09-233-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-pysocks: upgrade 1.7.0 -> 1.7.1Zang Ruochen2019-09-233-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-msgpack: upgrade 0.6.1 -> 0.6.2Zang Ruochen2019-09-233-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-alembic: upgrade 1.1.0 -> 1.2.0Zang Ruochen2019-09-233-2/+2
| | | | | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rrdtool: suppress appending of installation to perllocal.podNaveen Saini2019-09-231-1/+1
| | | | | | | | | | | | | | | | | | | | | | perl modules when gets installed can produce a perllocal.pod file for documenting a list of locally installed perl modules. This can conflict if multiple packages generate the file. Hits the conflict with apparmor & rrdtool packages. Error: Transaction check error: file /usr/lib/perl5/5.30.0/x86_64-linux/perllocal.pod conflicts between attempted installs of rrdtool-1.7.2-r0.corei7_64 and apparmor-2.13.3-r0.corei7_64 perllocal.pod files are for documentation purpose, so disabling does not harm. Generating perllocal.pod for perl module is disabled by passing NO_PERLLOCAL=1 with ExtUtils::MakeMaker utility. https://perldoc.perl.org/5.30.0/ExtUtils/MakeMaker.html#Using-Attributes-and-Parameters [YOCTO #13491] Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* jasper: update to 2.0.16Oleksandr Kravchuk2019-09-232-18/+24
| | | | | | | Licence change due to modified copyright years (see @11ef9d44ac9795f4). Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mosquitto: update to 1.6.6Leon Anavi2019-09-221-2/+2
| | | | | | | | Fix security vulnerabilities. For further details, see: https://mosquitto.org/blog/2019/09/version-1-6-6-released/ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ostree: Add recipeAlex Kiernan2019-09-224-0/+307
| | | | | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: bump to version 4.2.0+git18ce5c9Vincent Prince2019-09-2213-131/+196
| | | | | | | | | | | | MongoDB v4.2.0 adds python3 support that is needed by scons upgrade [44f303b scons: inherit python3native]. - mongodb git commit 18ce5c9 was needed to fix https://jira.mongodb.org/browse/SERVER-42787 - Add PREFIX and prefix to scons environment to fix unknown variable check (SConstruct#L1073) - fix musl compilation (strerror_r) - Remove compatibility for clang/x86 due to missing "Hardware interference size" - Previous patches are refreshed Signed-off-by: Vincent Prince <vincent.prince.external@saftbatteries.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rsyslog: update from 8.1907.0 to 8.1908.0Randy MacLeod2019-09-221-2/+3
| | | | | | | | | | | | | | | | | | | | | Enable imfile-tests even if they take a while. ptest results for qemux86-64 with kvm and a timeout of 1000 seconds to allow stress tests to complete: Recipe | Passed | Failed | Skipped | Time(s) rsyslog-8.1907.0 | 365 | 4 | 2 | 2452 rsyslog-8.1908.0 | 379 | 4 | 2 | 2538 The failed tests for both 8.1907 and 8.1908 are: FAIL: Test ./omfile-read-only-errmsg.sh (took 2 seconds) FAIL: Test ./omfile-read-only.sh (took 2 seconds) FAIL: Test ./privdropuser.sh (took 580 seconds) FAIL: Test ./privdropuserid.sh (took 580 seconds) They are not fixed in this update. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uim: Update to 1.8.8Khem Raj2019-09-204-103/+22
| | | | | | | | | | | | | | License-Update: Change URI from code.google.com to github.com [1] Drop the patches they seem to be not needed Add dependency on libedit Disable parallel make due to races aarch64 support is upstream so drop the patch [1] https://github.com/uim/uim/commit/a1cf71ec3719389874c42dd4c719a15509983485#diff-7116ef0705885343c9e1b2171a06be0e Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xf86-video-nouveau: update to 1.0.16Oleksandr Kravchuk2019-09-201-3/+2
| | | | | Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>