aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* Revert "libencode-perl: add 2.76 recipe"timo/new-meta-perl-recipesTim Orling2015-08-151-54/+0
| | | | | | This reverts commit 8506ef66b991ef69c8b436eb8d96082acba61745. This module is included in stock perl, so this recipe is not needed.
* librole-tiny-perl: add 2.000001 recipeTim Orling2015-08-141-1/+1
| | | | | | | Changes since v1: fix URL (Thank you, Andreas Baak) Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libmoo-perl: add 2.000002 recipeTim Orling2015-08-141-0/+44
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* librole-tiny-perl: add 2.000001 recipeTim Orling2015-08-141-0/+29
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libstrictures-perl: add 2.000001 recipeTim Orling2015-08-141-0/+45
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libio-stringy-perl: add 2.111 recipeTim Orling2015-08-131-0/+31
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libimport-into-perl: add 1.002004 recipeTim Orling2015-08-131-0/+32
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libextutils-parsexs-perl: add 3.24 recipeTim Orling2015-08-131-0/+47
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libencode-locale-perl: add 1.05 recipeTim Orling2015-08-131-0/+21
| | | | | | | | | | | | * Based on: Paul Eggleton <paul.eggleton@linux.intel.com> http://github.com/bluelightning/public_bb_recipes * which is forked from: Emil Petersen <erp@movis.dk> http://github.com/EmilRP/public_bb_recipes/ Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libencode-perl: add 2.76 recipeTim Orling2015-08-131-0/+54
| | | | | | | | | | | | * Based on v2.52 recipe: Paul Eggleton <paul.eggleton@linux.intel.com> http://github.com/bluelightning/public_bb_recipes * which is forked from: Emil Petersen <erp@movis.dk> http://github.com/EmilRP/public_bb_recipes Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libdevel-globaldestruction-perl: add 0.13 recipeTim Orling2015-08-131-0/+23
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libsub-exporter-progressive-perl: add 0.001011 recipeTim Orling2015-08-131-0/+30
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* libclass-method-modifiers-perl: add 2.11 recipeTim Orling2015-08-111-0/+28
| | | | Signed-off-by: Tim Orling <TicoTimo@gmail.com>
* hostapd: consider sysroot when search header filesRoy Li2015-07-302-0/+41
| | | | | Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* sblim-cmpi-devel: add new recipeleimaohui2015-07-302-0/+35
| | | | | | | sblim-cmpi-devel is dependence of cmpi-bindings. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* sblim-sfcc: add new recipeBian Naimeng2015-07-301-0/+15
| | | | | | | sblim-sfcc is a Small Footprint CIM Client library. Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* openwsman: add new recipeleimaohui2015-07-303-0/+94
| | | | | | | Openwsman is an open source implementation of WS-Management; enabling the in-band management of Linux/uni*/Windows platforms. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mozjs: fix lib soname issueArmin Kuster2015-07-302-0/+21
| | | | | | | | | | | | | | | | | | | polkit failed to build do to missing mozjs libs. The libs created are: libmozjs-..a libmozjs-..so this was caused by a perl script error Can't use 'defined(@array)' (Maybe you should just omit the defined()?) at config/milestone.pl line 58. this script is use to determine the major and minor lib versions. I believe this issue is do to the recent perl update. this fixes the lib creation error and polkit build error. I am not a perl person so this may not be the idea fix. Signed-off-by: Armin Kuster <akuster808@gmail.com> Acked-By: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* multipath-tools: bug fixLi xin2015-07-302-0/+37
| | | | | | | Modify multipathd.service,otherwise it can't be started successfully. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* multipath-tools: upgrade git revKang Kai2015-07-302-6/+13
| | | | | | | | There is no new release for package multipath-tools. And just upgrade its git rev to the latest commit 0.5.0-144-g770e6d0 on Feb 16, 2015. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* ifuse: remove blacklist due to libimobiledeviceS. Lockwood-Childs2015-07-301-1/+0
| | | | | | | | ifuse's libimobiledevice dependency has been fixed, so ifuse blacklist can be removed as well Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libimobiledevice: remove runtime configure checkS. Lockwood-Childs2015-07-302-5/+39
| | | | | | | | | | | | | | | | configure.ac had a runtime check for large file support that got run on 64-bit architectures, and all runtime checks must go away to be cross-compile safe. Luckily that runtime check was extraneous, so just remove it; standard AC_SYS_LARGEFILE macro should be sufficient for figuring out proper settings to get large file support. Also un-blacklist libimobiledevice, since this problem was the reason for the blacklist. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libxaw: upgrade 1.0.10 -> 1.0.13Li xin2015-07-301-2/+2
| | | | | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* lmsensors: upgrade 3.3.5 -> 3.4.0Li xin2015-07-301-2/+2
| | | | | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* lua: upgrade 5.2.2 -> 5.3.1Li xin2015-07-301-5/+5
| | | | | | | | Update the checksum, beginline and endline of LICENSE file, but the LICENSE has not been changed. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* openldap: upgrade 2.4.40 -> 2.4.41Li xin2015-07-3011-73/+3
| | | | | | | | | | | | 1) Dropped backported patches(commit-id): -0001-ITS-8027-require-non-empty-AttributeList.patch(c32e747) -0001-ITS-8046-fix-vrFilter_free.patch(2f1a2dd) 2) Update the checksum of COPYRIGHT,since the date in it has been changed, but the LICENSE has not been changed. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* opensc: upgrade 0.14.0 -> 0.15.0Li xin2015-07-301-2/+2
| | | | | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* numactl: upgrade 2.0.9 -> 2.0.10Li xin2015-07-302-22/+27
| | | | | | | | | | | | | | 1) Update Fix-the-test-output-format.patch,since the contents has been changed. 2) Update the checksum, beginline and endline of LICENSE file, but the LICENSE has not been changed. 3) Remove "libdir=${D}/${libdir}" to avoid build Warning: QA Issue: numactl: Files/directories were installed but not shipped in any package Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* packagegroup-xfce-extended: add xfce4-hotcorner-pluginAndreas Müller2015-07-301-0/+1
| | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* xfce4-hotcorner-plugin: initial add 0.0.2Andreas Müller2015-07-301-0/+11
| | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* libwnck: update to 2.31 / avoid conflicts with libwnck3Andreas Müller2015-07-302-15/+22
| | | | | | | | | | | Both libwnck and libwnck3 install the commandline tools 'wnck-urgency-monitor' and 'wnckprop' to bindir. The packages depending on libwnck were checked: In none of them there is a trace for these tools. To avoid conflicts the tools are installed by libwnck3 only. If something requires 'wnck-urgency-monitor' or 'wnckprop' it needs to install libwnck3. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* libwnck3: update to 3.14Andreas Müller2015-07-301-4/+3
| | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* xfce4-notifyd: update to 0.2.4Andreas Müller2015-07-302-5/+157
| | | | | | | This update makes xfce4-notifyd compatible to oe-core's current libnotify and libnotify >= 0.7.0 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* gphoto2: Adds recipe for gphoto2 2.5.8Andreas Baak2015-07-303-0/+80
| | | | | | | | | | | | | | | | | gphoto2 is a command line frontend for libgphoto2. The patch 0001-configure.ac-remove-AM_PO_SUBDIRS is very similar to the corresponding patch in the libgphoto2 recipe and is required to make the tool compile. Without the patch 0002-Look-for-popt-with-GP_CHECK_LIBARY-function, the popt library would be taken from the host system. In the EXTRA_OECONF, the --with-jpeg-prefix is required to avoid the host system's jpeg library to be found. --without-cdk is required since the cdk headers are not found anywhere. According to gphoto2's configure.ac file, removing cdk removes "interactive access to the camera's configuration". Pure pure command-line access is retained, though. Signed-off-by: Andreas Baak <andreas.baak@gmail.com>
* libgphoto2: update to 2.5.8Andreas Baak2015-07-307-1292/+15115
| | | | | | | | | | | - Added build dependencies zlib and libxml2 - Adapted 0001-configure-ac-remove-AM_PO_SUBDIRS.patch - Removed patch allow.to.disable.gd.patch: Removing libgd is now possible using the configure flag "--without-gdlib" - Regenerated .fdi and .rules files Signed-off-by: Andreas Baak <andreas.baak@gmail.com>
* efibootmgr: add recipeKang Kai2015-07-304-0/+97
| | | | | | | | | Add efibootmgr recipe from layer meta-linaro and upgrade from 0.5.4 to 0.6.0. efibootmgr is a linux user-space application to modify the EFI Boot Manager which is useful for us to manage boot on EFI boards. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libedit: upgrade 20130712-3.1 -> 20150325-3.1Li xin2015-07-301-2/+2
| | | | | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libcap-ng: upgrade 0.7.4 -> 0.7.7Li xin2015-07-302-21/+42
| | | | | | | Update python.patch,since the contents has been changed. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libconfig: upgrade 1.4.9 -> 1.5Li xin2015-07-301-2/+2
| | | | | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* iw: upgrade 3.15 -> 4.1Li xin2015-07-301-2/+2
| | | | | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dracut: upgrade from 038 to 043Kang Kai2015-07-301-3/+3
| | | | | Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* corosync: upgrade 2.3.4 -> 2.3.5Li xin2015-07-301-9/+4
| | | | | | | Drop "--enable-nss" configure option because it is not be supported any more. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* bdftopcf: upgrade 1.0.4 -> 1.0.5Li xin2015-07-301-2/+2
| | | | | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* fio: Add PACKAGECONFIG for numa, re-enable ARM buildDominic Sacré2015-07-301-2/+10
| | | | | | | | | Make fio's NUMA support optional via PACKAGECONFIG. Enable this feature by default, except on ARM where libnuma/numactl is not available. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* lvm2: fix shared object file dlopen failedZhixiong Chi2015-07-302-0/+35
| | | | | | | | Add the variable snapshot_library into config file(lvm.conf), so it can link the correct shared object files with correct path. Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* lvm2: upgrade from 2.02.97 to 2.02.125Kang Kai2015-07-306-104/+5
| | | | | | | | | | Upgrade lvm2 to 2.02.125: * drop 3 backported patches * remove PR and INC_PR Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* liblockfile: add patch of version 1.09-6 from debianKang Kai2015-07-302-0/+25
| | | | | | | | Add patch of liblockfile 1.09-6 from debian. And fix error which install so file to manual directory. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* crash: upgrade from 7.0.9 to 7.1.2Kang Kai2015-07-305-2/+2
| | | | | Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* fuse: fix for CVE-2015-3202 Privilege EscalationTudor Florea2015-07-302-0/+64
| | | | | | | | | | | | | | fusermount in FUSE before 2.9.3-15 does not properly clear the environment before invoking (1) mount or (2) umount as root, which allows local users to write to arbitrary files via a crafted LIBMOUNT_MTAB environment variable that is used by mount's debugging feature. References: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3202 http://www.openwall.com/lists/oss-security/2015/05/21/9 Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libxml-libxml-perl: update from 2.0116 to 2.0121Wenzong Fan2015-07-301-6/+2
| | | | | | | | | | | update to 2.0121 and clean unused logic: - do_configure_prepend() { - rm -rf ${S}/.pc/* - } Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>