aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* gtkwave: add version 3.3.98HEADmasterTuan Hoang2019-02-221-0/+19
| | | | | Signed-off-by: Hoang Anh Tuan <tuanha@viosoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tk_8.6.9: Add tkConfig.sh in crossscriptTuan Hoang2019-02-221-0/+25
| | | | | Signed-off-by: Hoang Anh Tuan <tuanha@viosoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* udisks: add REQUIRED_DISTRO_FEATURES for polkitNicolas Dechesne2019-02-221-1/+4
| | | | | | | | | | | | After below commits to add polkit as a required distro feature: 97a1a55 polkit: add polkit as a required distro feature c049e02 polkit: inherit distro_features_check Need to add REQUIRED_DISTRO_FEATURES for polkit to avoid error when trying to build 'world' Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* packagegroup-meta-oe: fixup package that now require polkitNicolas Dechesne2019-02-221-1/+2
| | | | | | | | | | | | After below commits to add polkit as a required distro feature: 97a1a55 polkit: add polkit as a required distro feature c049e02 polkit: inherit distro_features_check We need to propagate that to all recipes that use/need them, such as this packagegroup, otherwise 'world' will fail. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* polkit: add REQUIRED_DISTRO_FEATURES for polkitNicolas Dechesne2019-02-221-0/+3
| | | | | | | | | | | | | | | | After below commits to add polkit as a required distro feature: 97a1a55 polkit: add polkit as a required distro feature c049e02 polkit: inherit distro_features_check All recipes that includes polkit-group-rule.inc will fail to parse when polkit is not in DISTRO_FEATURE, especially 'world'. e.g. ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'udisks', 'polkit'] Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* meta-oe: fixup LAYERDEPENDS to include meta-pythonNicolas Dechesne2019-02-221-0/+1
| | | | | | | | | | | | | | | | | | | | meta-oe depends on meta-python, for mongodb recipe, since 5cf9a144ad16 (mongodb: Upgrade to 4.0.1 release) Trying to run the yocto-check-layer script fails with: ERROR: Nothing PROVIDES 'python-cheetah-native' (but /work/yocto/meta-openembedded/meta-oe/recipes-dbs/mongodb/mongodb_git.bb DEPENDS on or otherwise requires it). Close matches: python3-git-native python-nose-native python-native ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'mongodb', 'python-cheetah-native'] Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nodejs: fix additional compatibility with older gccAndrej Valek2019-02-221-8/+28
| | | | | | | | - replace all occurrences of std::make_unique with wrapper - sync indent level Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* cim-schema-final: remove do_unpackChangqing Li2019-02-221-6/+1
| | | | | | | Use subdir=${BP} rather than write do_unpack manually. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* cim-schema-docs: remove do_unpackChangqing Li2019-02-221-6/+1
| | | | | | | Use subdir=${BP}, rather than write do_unpack manually. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uftrace: Support armeb.leimaohui2019-02-221-0/+2
| | | | | Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* lvm2: fix lvm2-monitor.service startup failedChangqing Li2019-02-222-1/+34
| | | | | | | | | | | | Issue: vm2-monitor.service: Failed to create lvm2-monitor.service/start: Unit lvm2-lvmetad.socket not found lvmetad have been removed by upstream, but this part is missed, backport fix from upstream Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* openldap: upgrade 2.4.46 -> 2.4.47Changqing Li2019-02-222-17/+32
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uthash: upgrade 2.0.2 -> 2.1.0Changqing Li2019-02-221-3/+3
| | | | | | | License-Update: Copyright Year Update Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* unixodbc: upgrade 2.3.6 -> 2.3.7Changqing Li2019-02-221-3/+3
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xf86-video-mga: upgrade 1.6.5 -> 2.0.0Changqing Li2019-02-221-2/+2
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* smartmontools: upgrade 6.6 -> 7.0Changqing Li2019-02-222-31/+2
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: upgrade 1.11.1 -> 1.11.2Changqing Li2019-02-222-10/+10
| | | | | | | License-Update: Copyright Year Update Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* syslog-ng: upgrade 3.16.1 -> 3.19.1Changqing Li2019-02-221-2/+2
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* udisk2: 2.7.8 -> 2.8.1Changqing Li2019-02-221-2/+2
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* upower: add REQUIRED_DISTRO_FEATURES for polkitMingli Yu2019-02-221-1/+3
| | | | | | | | | | | | | | | | After below commits to add polkit as a required distro feature: 97a1a55 polkit: add polkit as a required distro feature c049e02 polkit: inherit distro_features_check Need to add REQUIRED_DISTRO_FEATURES for polkit to fix below error for these packages which depend on polkit: $ bitbake upower ERROR: Nothing PROVIDES 'polkit' (but /build/layers/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.7.bb DEPENDS on or otherwise requires it) Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* udisks2: add REQUIRED_DISTRO_FEATURES for polkitMingli Yu2019-02-221-1/+3
| | | | | | | | | | | | | | | | After below commits to add polkit as a required distro feature: 97a1a55 polkit: add polkit as a required distro feature c049e02 polkit: inherit distro_features_check Need to add REQUIRED_DISTRO_FEATURES for polkit to fix below error for these packages which depend on polkit: $ bitbake udisk2 ERROR: Nothing PROVIDES 'polkit' (but /build/layers/meta-openembedded/meta-oe/recipes-support/udisks/udisks2_2.7.8.bb DEPENDS on or otherwise requires it) Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* multipath-tools: upgrade 0.7.9 -> 0.8.0Changqing Li2019-02-224-55/+38
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* phoronix-test-suite: Upgrade 8.2.0 -> 8.6.0Changqing Li2019-02-201-2/+2
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xarchiver: upgrade to upstream 0.5.4.14Andreas Müller2019-02-201-7/+14
| | | | | | | | * build with gtk+3 * add 7z support Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* geany-plugins: upgrade 1.31 -> 1.34 and reworkAndreas Müller2019-02-202-68/+74
| | | | | | | | | | | | | | | | | | | | | * geany-plugins-treebrowser/license checksum: Was changed to: "TreeBrowser plugin is distributed under the same license as in geany." Geany is GPLv2 which is part of geany-plugin's license. * Remove explicit RDEPENDS: * They caused cyclic dependencies making impossible anything but all plugins * Checked: Dependencies are set correct automatically * Add geany-plugins-common to avoid cylcic dependencies * All plugins that are enabled, build and pack properly. Before adding geany-plugins to an image caused errors in do_rootfs due to empty packages. * Some plugins don't build with gtk3 - disable them Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* geany: upgrade 1.31 -> 1.34.1 and build with gtk+3Andreas Müller2019-02-201-3/+3
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libpeas: initial add 1.22.0Andreas Müller2019-02-201-0/+24
| | | | | | | | Am working on a rebirth of midori (no it's not dead) at meta-browser. To avoid an additional layer dependency for meta-browser, put libpeas to meta-oe. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ndctl: disable ndctl-monitor service by defaultChangqing Li2019-02-181-0/+1
| | | | | | | | | ndctl-monitor service will start failed if there is no nvdimm device like on qemux86, so disable it by default, user can enable it if their machine support this device. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xdebug: upgrade 2.6.1 -> 2.7.0RC2Changqing Li2019-02-181-3/+3
| | | | | | | | | | License-Update: Change http://xdebug.org to https://xdebug.org everywhere php upgrade to 3.7.2, 2.6.1 not support php 3.x, need upgrade to 2.7 which support php 3.x. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nodejs 8.15.0 -> 10.15.1Andrej Valek2019-02-176-17/+230
| | | | | | | | | Update nodejs to active 10.x LTS release 10.15.1. - link atomic library - make it compatible with gcc < 4.9 Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* snort: Strip out DEBUG_PREFIX_MAP options and --sysrootKhem Raj2019-02-171-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* znc: Strip out DEBUG_PREFIX_MAP options and --sysroot from znc.pcKhem Raj2019-02-171-1/+1
| | | | | | | | This fixes issues e.g. ERROR: znc-1.7.1-r0 do_populate_sysroot: QA Issue: znc.pc failed sanity test (tmpdir) in path /mnt/a/yoe/build/tmp/work/aarch64-yoe-linux/znc/1.7.1-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig] ERROR: znc-1.7.1-r0 do_populate_sysroot: QA staging was broken by the package built above Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python-requests: update to version 2.20.1Ricardo Salveti2019-02-175-187/+3
| | | | | | | | | | | Drop patches as they were backports which are now available as part of this release. License checksum changed but the license is the same (license address changed from http to https). Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* hdf5: add version 1.8.19Hongxu Jia2019-02-176-0/+1358
| | | | | | | | License HDF5 is BSD-style. https://support.hdfgroup.org/products/licenses.html Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libgpiod: bump version to v1.2.1Bartosz Golaszewski2019-02-171-2/+2
| | | | | | | This is a bugfix release fixing two problems in C++ bindings. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-keras-preprocessing: add version 1.0.5Hongxu Jia2019-02-171-0/+15
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-keras-applications: add version 1.0.6Hongxu Jia2019-02-171-0/+19
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-gast: add version 0.2.2Hongxu Jia2019-02-171-0/+14
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-astor: add version 0.7.1Hongxu Jia2019-02-171-0/+14
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-absl: add version 0.7.0Hongxu Jia2019-02-171-0/+14
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-wheel: add version 0.32.3Hongxu Jia2019-02-171-0/+16
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-markdown: add version 3.0.1Hongxu Jia2019-02-171-0/+12
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-termcolor: add version 1.1.0Hongxu Jia2019-02-171-0/+12
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-h5py: add version 2.9.0Hongxu Jia2019-02-172-0/+76
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-pkgconfig: add version 1.4.0Hongxu Jia2019-02-171-0/+18
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* python3-protobuf: add cpp implementation supportHongxu Jia2019-02-173-0/+108
| | | | | | | | | | | | | | | | | | | | | - Compiling with option `--cpp_implementation', add cpp implementation support which requires to build with protobuf. - Workaround native compile failure while host gcc <= 4.8 Setting environment KOKORO_BUILD_NUMBER, the build will explicitly compile with option `-std=c++11', it could workaround native compile failure while host gcc <= 4.8 ... /usr/include/c++/4.8/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options ... - Add Python 3.7 compatibility Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ace-cloud-editor: move ace-cloud-editor recipe to meta-oe/recipes-supportSai Hari Chandana Kalluri2019-02-171-0/+0
| | | | | | | | This commit c245374fafbc4769e0c98ae18ac9ff71f9f14169 places ace-cloud-editor recipe in an incorrect location. This commit moves the recipe to the right location. Signed-off-by: Khem Raj <raj.khem@gmail.com>
* cryptsetup: Upgrade to 2.1.0Mingli Yu2019-02-151-3/+3
| | | | | | | | | Instead of hardcoding the version in SRC_URI, get the version for the folder of the source dynamically in SRC_URI. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* upm_git.bb: Add fix for installing the python filesManjukumar Matha2019-02-152-1/+40
| | | | | | | | | Use SWIG_SUPPORT_FILES to find the list of python files generated by CMake Swig module and install those files. This should be applicable to cmake version 3.12 or higher Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* lcdproc: Disable serialVFD driver on arm/aarch64Khem Raj2019-02-151-2/+3
| | | | | | | | | | | | | | This driver uses inb/outb instructions which seems to have trouble on arm/aarch64 compiler server/drivers/serialVFD_io.c :45: | ../../../git/server/drivers/port.h:344:32: error: invalid output constraint '=a' in asm | | __asm__ volatile ("inb %1,%0":"=a" (value) | ^ Signed-off-by: Khem Raj <raj.khem@gmail.com>