aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
Commit message (Collapse)AuthorAgeFilesLines
* mpd: eliminate systemd ExecStart editMax Kellermann2018-10-261-6/+0
| | | | | | | | This was never necessary because MPD's build script already inserts the correct path. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: remove deprecated "enable_bzip2=yes" lineMax Kellermann2018-10-261-1/+0
| | | | | | | | This should have been removed in commit 5a06148e58ca5a7558dd4b438a61d22caa8dfffe Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: update to 0.20.22Max Kellermann2018-10-261-1/+4
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpc: update to 0.31Max Kellermann2018-10-241-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ncmpc: add PACKAGECONFIG[regex]Max Kellermann2018-10-231-2/+2
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ncmpc: update to 0.33Max Kellermann2018-10-231-5/+5
| | | | | | | Several build options have been changed from "boolean" to "feature", and thus we have to change "true/false" to "enabled/disabled". Signed-off-by: Khem Raj <raj.khem@gmail.com>
* gstreamer: Remove machine specific appendMark Hatle2018-10-171-3/+0
| | | | | | | | | | | | | | | | If you try to build a system with multiple BSPs, one of which is qemux86 or qemux86-64, the gstreamer package will change. This will trigger anything using gstream to also be rebuilt. For a package based system, the PR values will also be incremented each time. The end result will be an ever growing set of PR values as well as being unable to tell which configured version of the multimedia components are really being deployed. The solution here was to remove the rrecommend for consistency. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmpdclient: make TCP support optionalMax Kellermann2018-10-091-0/+3
| | | | | | | | | Allows more tinfication. Without TCP, libmpdclient can only use local sockets, which is a good choice anyway if MPD runs on the same machine. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmpdclient: update to 2.16Max Kellermann2018-10-091-1/+1
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ncmpc: add various PACKAGECONFIGsMax Kellermann2018-10-051-1/+18
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ncmpc: update to the 0.32 release tagMax Kellermann2018-10-051-6/+3
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: enable aac PACKAGECONFIG only with commercial LICENSE_FLAGSArmin Kuster2018-10-011-1/+2
| | | | | | | | | ERROR: Nothing PROVIDES 'faad2' (but /home/akuster/oss/maint/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/mpd_0.20.21.bb DEPENDS on or otherwise requires it) enable aac only if LICENSE_FLAGS is commercial Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* layers: Update layer compatibility to thudKhem Raj2018-09-301-1/+1
| | | | | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@googlemail.com> Cc: Derek Straka <derek@asterius.io> Cc: Tim Orling <TicoTimo@gmail.com> Cc: Hongxu Jia <hongxu.jia@windriver.com> Cc: Armin Kuster <akuster808@gmail.com> Cc: Joe MacDonald <joe_macdonald@mentor.com> Cc: Andrea Adami <andrea.adami@gmail.com>
* fluidsynth: drop extra dash from `-Denable-pulseaudio=OFF`Max Kellermann2018-09-261-1/+1
| | | | | | | | | This caused a build failure: CMake Error: The source directory ".../tmp-glibc/work/aarch64-oe-linux/fluidsynth/1.1.11-r0/build/--Denable-pulseaudio=OFF" does not exist. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: eliminate `chmod`/`chown` calls by using `install`Max Kellermann2018-09-261-5/+5
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: make more plugins optionalMax Kellermann2018-09-261-2/+7
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: build from gitMax Kellermann2018-09-261-3/+3
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: fix the sqlite dependencyMax Kellermann2018-09-261-1/+1
| | | | | | | "sqlite" is sqlite 2.x, but MPD requires 3.x. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: sort PACKAGECONFIGs againMax Kellermann2018-09-261-3/+3
| | | | | | | The new ones I added were not sorted. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: drop LICENSE_FLAGS="commercial"Max Kellermann2018-09-241-3/+0
| | | | | | | | | The mpg123 LICENSE_FLAGS have been removed in oe-core commit b0bc82a5f238db82425b3b146e269bc6605cbdce, so we can remove it from MPD as well. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: make lots of plugins optionalMax Kellermann2018-09-241-22/+22
| | | | | | | | The new options are enabled by default to avoid breaking existing configurations. Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: sort PACKAGECONFIGsMax Kellermann2018-09-241-1/+1
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpd: update 0.20.21Max Kellermann2018-09-241-2/+2
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ncmpc: new recipeMax Kellermann2018-09-241-0/+23
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mpc: new recipeMax Kellermann2018-09-241-0/+16
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmpdclient: new recipeMax Kellermann2018-09-241-0/+19
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vorbis-tools: add PACKAGECONFIG[ogg123]Max Kellermann2018-09-241-2/+3
| | | | | Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* minidlna: restore & fix recipeBaptiste DURAND2018-09-115-0/+143
| | | | | | | Restore minidlna recipe and bump it to v1.2.1 Move it to meta-multimedia Signed-off-by: Baptiste Durand <baptiste.durand@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* gstd: Upgrade to latest and fix unrecognised options to configureKhem Raj2018-09-113-49/+39
| | | | | | QA Issue: gstd: configure was passed unrecognised options: --disable-gtk-doc [unknown-configure-option] Signed-off-by: Khem Raj <raj.khem@gmail.com>
* oscam: Depend on openssl10Khem Raj2018-09-081-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rtmpdump: Depend on openssl10 and update to latest on gitKhem Raj2018-09-082-7/+7
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vlc: use fribidi not libfribidiRoss Burton2018-08-311-1/+1
| | | | | | | The recipe is called fribidi, so use that instead of the PROVIDE. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* kodi: Remove, use from meta-kodiKhem Raj2018-08-2017-1607/+0
| | | | | | | Use more uptodate version from https://github.com/koenkooi/meta-kodi Signed-off-by: Khem Raj <raj.khem@gmail.com>
* faac: set LICENSE_FLAGSPaul Eggleton2018-08-151-0/+2
| | | | | | | | Commercial usage requires licensing according to the homepage, so set LICENSE_FLAGS = "commercial" to indicate that. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* faac: set HOMEPAGEPaul Eggleton2018-08-151-0/+1
| | | | | | | Set HOMEPAGE so there is a place to go for more information. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* oscam: Upgrade to latest rev 11431 on trunkKhem Raj2018-08-153-41/+29
| | | | | | | Add patch to fix build with glibc 2.28+ Remove backported patches which are no longer needed Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libopenmpt: add recipeCarlos Rafael Giani2018-07-292-0/+113
| | | | | | | | | libopenmpt is a cross-platform C++ and C library to decode tracked music files ("modules", like the .mod .xm .s3m .it formats) into raw PCM audio. It is based on the player code of OpenMPT module tracker. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rygel: remove obsolete ossp-uuid dependencyRoss Burton2018-07-271-1/+1
| | | | | | | | | Not only was uuid removed as a build dependency of Rygel in 0.27.1, but oe-core's ossp-uuid has always renamed the library to libossp-uuid so it was never used (as util-linux provides libuuid.so). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tinyalsa: Add -fPIC to compile flagsCarlos Rafael Giani2018-07-201-0/+6
| | | | | Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libdc1394: libglu needs both openGL and X11 but not tvirtual/libglKhem Raj2018-06-221-1/+2
| | | | | | Epxress this dependency accurately Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rygel: Update license to LGPLv2.1Leon Anavi2018-05-291-1/+1
| | | | | | | | | | | | | | | | | | | | | | Fix the warning below and set proper license according to the content of file COPYING in Rygel: WARNING: rygel-0.34.0-r0 do_populate_lic: rygel: \ No generic license file exists for: LGPL1.1 in any provider According to a git commit in Rygel made two years ago by Jens Georg: "all: Update license text to LGPLv2.1 proper We always claimed being LGPLv2.1 but the license text said differently." In the same time the tag for Rygel 0.34 has been created on 20 March 2017, aka after this git commit. For more details: https://gitlab.gnome.org/GNOME/rygel/commit/cdcb6bd55efd0c3b7a2fd4ae5c3d8556f69f8402 Furthermore, the changelog of Rygel 0.34.0 also indicates that the license is LGPLv2.1+ (after a fix in release 0.29.1): https://abi-laboratory.pro/tracker/changelog/rygel/0.34.0/log.html Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmusicbrainz: Set CMAKE_EXE_LINKER_FLAGS to build linker flagsKhem Raj2018-05-261-1/+3
| | | | | | | | | Some older compilers do not support security flags like -fstack-protector=strong and if we do not set this then it will use the target flags to pass here which will fail with gcc < 5.x, especially a problem building distros with security flags on host with 4.x gcc e.g. ubuntu 14.04 Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tinyalsa: Update SRC_URI to github git fetcherKhem Raj2018-05-231-15/+5
| | | | | | | | Update to latest on git/master Fixes build with clang switch component build system to cmake Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tinyalsa: switch away from github archiveTrevor Woerner2018-05-171-3/+3
| | | | | | | | | | Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* openh264: switch away from github archiveTrevor Woerner2018-05-171-3/+4
| | | | | | | | | | Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* openh264: fix build for 32-bit intel archTrevor Woerner2018-05-171-5/+4
| | | | | Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* fluidsynth: update 1.1.10 -> 1.1.11Andreas Müller2018-05-171-1/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libsrtp: bump 1.5.2 -> 1.6.0Trevor Woerner2018-05-171-8/+2
| | | | | Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libsrtp: switch away from github archiveTrevor Woerner2018-05-171-3/+3
| | | | | | | | | | Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* gst-instruments: update to latestTrevor Woerner2018-05-171-1/+1
| | | | | Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>