aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
Commit message (Collapse)AuthorAgeFilesLines
* libmatroska: Fix missing GNU_HASH errorsKhem Raj2017-08-042-1/+31
| | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit e961adf6cb5db90d4220412fa5a91eb9146909a0) Signed-off-by: Armin Kuster <akuster808@gmail.com>
* alsa-equal: Update SRC_URI to something validKhem Raj2017-06-261-2/+2
| | | | | | | | | | | | | | www.thedigitalmachine.net has disappeared * cherry picked from master: commit a02ec57e144b768c8d5e383622a83f87d86425b5 Author: Khem Raj <raj.khem@gmail.com> Date: Wed Mar 22 11:45:33 2017 -0700 alsa-equal: Update SRC_URI to something valid Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libupnp: Fix out-of-bound access in create_url_list() (CVE-2016-8863)Andrej Valek2017-02-242-0/+58
| | | | | | | | | | | | | If there is an invalid URL in URLS->buf after a valid one, uri_parse is called with out pointing after the allocated memory. As uri_parse writes to *out before returning an error the loop in create_url_list must be stopped early to prevent an out-of-bound access Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit b4659368a01a5b4209d9e1e571bb569ef4a06195) Signed-off-by: Armin Kuster <akuster808@gmail.com>
* vlc: Add packageconfig for vdpauKhem Raj2017-02-221-1/+6
| | | | | | | | | | | | | Fix packaging of libvlc_vdpau.so since this plugin does not have soname version Fixes QA Issue: non -dev/-dbg/nativesdk- package contains symlink .so: vlc path '/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/vlc/2.2.2-r0/packages-split/vlc/usr/lib/vlc/libvlc_vdpau.so' [dev-so] Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 7c670ff3374617f804d1f0fe5d8957a1021ea726) Signed-off-by: Armin Kuster <akuster808@gmail.com>
* meta-openembedded: Add me to morty maintainer's listArmin Kuster2016-11-151-6/+5
| | | | | Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libdc1394: Upgrade to 2.2.4Khem Raj2016-10-261-2/+2
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dvb-apps: fix recipe, and update to the latest versionHerve Jourdain2016-10-251-4/+22
| | | | | | | | | | | | Fixed error "GNU_HASH not present" Fixed dvb-scan-data package Fixed the VERSION_FILE (used to check the dvb api version) to the one used for the target (by default, it uses the one on the host) Updated to the "latest" version (2014/03/22) The latest version suppressed the original scan tables (not maintained anymore), so fetch and install the latest ones (using dvb api v3 format)(introduces a dependency on v4l-utils-native) Signed-off-by: Herve Jourdain <herve.jourdain@neuf.fr> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* alsa-equal: Add recipe for version 0.6Fabio Berton2016-10-214-0/+256
| | | | | | | | Alsaequal is a real-time adjustable equalizer plugin for ALSA. It can be adjusted using an ALSA compatible mixer, like alsamixergui or alsamixer. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* caps: Add recipe for version 0.9.24Fabio Berton2016-10-212-0/+60
| | | | | | | | | CAPS is a collection of audio plugins comprising basic virtual guitar amplification and a small range of classic effects, signal processors and generators of mostly elementary and occasionally exotic nature. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gst-plugins-base: fix rare but annoying build errorsAndreas Müller2016-10-052-0/+33
| | | | | | | | | | | | | | | | | | As mentioned long ago in [1] for me gst-plugins-base failed when rebuilding. Before this patch I had no other choice but to build from scratch. When error occured I saw in config.log: GLIB_CFLAGS='-pthread line /home/superandy/tmp/oe-core-glibc/sysroots/raspberrypi2/usr/include/glib-2.0 -I/home/superandy/tmp/oe-core-glibc/sysroots/raspberrypi2/usr/lib/glib-2.0/include' and build failed with: | arm-angstrom-linux-gnueabi-gcc: error: line: No such file or directory [1] http://lists.openembedded.org/pipermail/openembedded-devel/2016-March/106528.html Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpd: disable automatic start at boot - service is activated on demand by socketAndreas Müller2016-10-051-1/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* layer.conf: add LAYERVERSION and LAYERDEPENDSJoe Slater2016-10-031-0/+6
| | | | | | | | | The layer README states we depend on meta-ruby and meta-oe, but bitbake-layers show-cross-depends does not find these dependencies. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* rtmpdump: fix QA warning for GNU_HASHCarlos Rafael Giani2016-09-261-1/+1
| | | | | | | | The package wasn't actually using the OE CFLAGS and LDFLAGS. These must be passed as XCFLAGS and XLDFLAGS to make. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* cdparanoia: fix QA warning for GNU_HASHCarlos Rafael Giani2016-09-262-0/+43
| | | | | | | Patch Makefile.in files to use LDFLAGS when linking the shared objects Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gtk-doc: disable where necessaryAlexander Kanavin2016-09-051-0/+2
| | | | | | | | | Several recipes in meta-oe layers are so old that they don't work with modern gtk-doc (which was added and enabled by default in oe-core); disable that where it is necessary for the build to succeed. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-oe: remove trailing spacesMartin Jansa2016-08-222-2/+2
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-oe: fix indentationMartin Jansa2016-08-2211-21/+21
| | | | | | | | * remove tabs which sneaked in since last cleanup * meta-oe layers are using consistent indentation with 4 spaces, see http://www.openembedded.org/wiki/Styleguide Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* rygel: add intltool-native dependencyMartin Jansa2016-08-151-1/+1
| | | | | | | | * fixes: | ../rygel-0.28.2/configure: line 18228: syntax error near unexpected token `0.40.0' | ../rygel-0.28.2/configure: line 18228: `IT_PROG_INTLTOOL(0.40.0)' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gupnp-tools: add intltool-native dependencyMartin Jansa2016-08-151-1/+1
| | | | | | | | * fixes: | ../gupnp-tools-0.8.10/configure: line 14369: syntax error near unexpected token `0.40.6' | ../gupnp-tools-0.8.10/configure: line 14369: `IT_PROG_INTLTOOL(0.40.6)' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libebml: fix do_unpack failureMartin Jansa2016-07-291-1/+1
| | | | | | | | | | | DEBUG: Executing shell function dos2unix | /home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/libebml/1.3.0-r0/temp/run.dos2unix.30265:104: /home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/libebml/1.3.0-r0/temp/run.dos2unix.30265:cannot open make/*/Makefile: No such file | WARNING: exit code 2 from a shell command. | ERROR: Function failed: dos2unix (log file is located at Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* juce: Improved juce class and recipeseu@felipetonello.com2016-07-293-6/+19
| | | | | | | | This allows recipes that inherits juce class to have more modular dependencies and change it if necessary. Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* juce: Added support for JUCE frameworkeu@felipetonello.com2016-07-294-0/+78
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | See below for the official README from JUCE. For TL;DRs: JUCE is a well known and widely used C++ Framework for audio applications. It has good support for Linux and ARM. A typical JUCE application recipe will only contain this skeleton: inherit juce SRC_URI = "..." JUCE_JUCERS = "${B}/cool-project.jucer" do_compile() { CONFIG=Release oe_runmake } do_install() { install ... } ====== OBS: This recipe requires a patch[1] on oe-core which is been tested right now. [1] http://lists.openembedded.org/pipermail/openembedded-core/2016-July/123972.html ====== >From the README: JUCE (Jules' Utility Class Extensions) is an all-encompassing C++ framework for developing cross-platform software. It contains pretty much everything you're likely to need to create most applications, and is particularly well-suited for building highly-customised GUIs, and for handling graphics and sound. Most JUCE modules are shared under the GNU Public Licence (GPLv2, v3, and the AGPLv3). This means that the code can be freely copied and distributed, and costs nothing to use in other GPL applications. One module (the juce_core module) is permissively licensed under the ISC. For more information, visit the website: http://www.juce.com Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* Mpd: use libsystemdSzombathelyi György2016-07-291-0/+4
| | | | | | | | | Mpd tries to find and link to libsystemd-daemon by default, but there's only libsystemd in OpenEmbedded. Fixing this makes socket activation work. Signed-off-by: Gyorgy Szombathelyi <gyurco@freemail.hu> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpg123: remove the recipeAlexander Kanavin2016-07-291-65/+0
| | | | | | | The recipe has been added to oe-core, see https://bugzilla.yoctoproject.org/show_bug.cgi?id=6020 Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libebml: don't rely on make -e, obey LDFLAGSChristopher Larson2016-06-233-5/+138
| | | | | | | | | We need to obey LDFLAGS to get the correct hash style for external toolchains, and passing vars explicitly is better than relying on implicitly overriding everything blindly from the environment. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* faac: address gcc-6 narrowing errors via an explicit castDerek Straka2016-06-232-4/+50
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* tvheadend: add a patch to fix issues with gcc 6 and drop the ↵Derek Straka2016-06-232-2/+47
| | | | | | | -Wno-error=misleading-indentation Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* tvheadend: add CFLAG to ignore misleading indentationsDerek Straka2016-06-151-3/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* faac, iperf, crash, espeak, open-vcdiff: blacklist, fails to build with gcc-6Martin Jansa2016-06-131-0/+2
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* abiword, fbreader, tvheadend, glmark2, libqmi, modemmanager, thrift, wvdial, ↵Martin Jansa2016-06-131-0/+3
| | | | | | wvstreams, dt, collectd, gtkmathview, tcsh, glcompbench, geos, libspatialite, geis, grail, opencv, openwbem, fwts: blacklist, fails to build with gcc-6 or glibc-2.24 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mpd: update to 0.19.15Szombathelyi György2016-06-081-2/+2
| | | | | | This fixes a build issue Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipesAlexander Kanavin2016-06-081-2/+0
| | | | | | | They are no longer required to build python software. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dvd-apps: Fix several QA WARNINGSArmin Kuster2016-06-081-0/+10
| | | | | | | | | | | | | | | | | Example: WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbdate contained in package dvbdate requires libucsi.so, but no providers found in RDEPENDS_dvbdate? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbtraffic contained in package dvbtraffic requires libdvbapi.so, but no providers found in RDEPENDS_dvbtraffic? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbscan contained in package dvb-scan requires libdvbapi.so, but no providers found in RDEPENDS_dvb-scan? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/gotox contained in package dvb-apps requires libdvbapi.so, but no providers found in RDEPENDS_dvb-apps? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/femon contained in package dvb-femon requires libdvbapi.so, but no providers found in RDEPENDS_dvb-femon? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbnet contained in package dvbnet requires libdvbapi.so, but no providers found in RDEPENDS_dvbnet? [file-rdeps] and WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/dvbscan contained in package dvb-scan requires libdvbcfg.so, but no providers found in RDEPENDS_dvb-scan? [file-rdeps] WARNING: dvb-apps-1.1.1-r0 do_package_qa: QA Issue: /usr/bin/gotox contained in package dvb-apps requires libdvbapi.so, but no providers found in RDEPENDS_dvb-apps? [file-rdeps] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* fluidsynth: set correct portaudio packageconfig dependencyAndreas Müller2016-05-061-1/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* sox: dep on ffmpeg, not libavChristopher Larson2016-05-061-1/+1
| | | | | | | | The libav recipe no longer exists, in favor of ffmpeg. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-multimedia: use bb.utils.contains() instead of base_contains()Ross Burton2016-04-288-20/+20
| | | | | | | | base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gst-plugins.inc: inherit gobject-introspectionMartin Jansa2016-04-121-1/+2
| | | | | | | | | | * fixes: gst-plugins-gl-0.10.3: gst-plugins-gl: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] gst-plugins-bad-0.10.23: gst-plugins-bad: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] gst-plugins-good-0.10.31: gst-plugins-good: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] gst-plugins-ugly-0.10.19: gst-plugins-ugly: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gstreamer: fix argument parsing when using Bison 3Stefan Agner2016-04-013-34/+36
| | | | | | | | | | | | Remove the argument fix patch and add a patch which fixes the grammer.y Bison input file. YYLEX_PARAM seems to be no longer supported and has been replaced with %parse-param which has been introduced already in 2003. This fixes a segmentation fault when launching gst-launch-0.10. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libmediaart: fix gobject introspectionAlexander Kanavin2016-03-141-2/+2
| | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* gstreamer-0.10: disable gobject introspectionAlexander Kanavin2016-03-143-1/+4
| | | | | | | Making it work would require significant patching - if you need it, update your stack to gstreamer 1.x Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* python-gst: remove the 0.10 recipeAlexander Kanavin2016-03-142-57/+0
| | | | | | It depends on pygobject 2.x which has been update to 3.x in oe-core Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* media-service-demo: remove the recipeAlexander Kanavin2016-03-141-18/+0
| | | | | | | | It hasn't been updated in years, and depends on pygtk, which is obsolete and incompatible with pygobject 3.x (and so is no longer provided). Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* rygel: fix gobject introspectionAlexander Kanavin2016-03-141-2/+2
| | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* gupnp: fix gobject introspectionAlexander Kanavin2016-03-146-23/+25
| | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* libao: update to 1.2.0Derek Straka2016-03-141-2/+4
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: add libpng PACKAGECONFIG (on by default)Rafaël Carré2016-03-071-2/+2
| | | | | | WARNING: vlc-2.2.2-r0 do_package_qa: QA Issue: vlc rdepends on libpng, but it isn't a build dependency, missing libpng in DEPENDS or PACKAGECONFIG? [build-deps] Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: fix build with ffmpeg 3.0Rafaël Carré2016-03-073-0/+340
| | | | | Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: update to 2.2.2Rafaël Carré2016-03-072-22/+2
| | | | | | | Drop rdp.c patch obsoleted by upstream changes Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vlc: Fix typo introduced in 0f2b3139521570ad494a72399f8a9dae76e69b16Rafaël Carré2016-03-071-1/+1
| | | | | | | | | | | | vlc-2.2.1: vlc: invalid PACKAGECONFIG: {@bb.utils.contains('DISTRO_FEATURES', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: 'x11', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: 'x11 [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: sdl', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: '', [invalid-packageconfig] vlc-2.2.1: vlc: invalid PACKAGECONFIG: d)} [invalid-packageconfig] Signed-off-by: Rafaël Carré <funman@videolan.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode,links"Martin Jansa2016-03-042-2/+2
| | | | | | | | | * Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>