aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
Commit message (Collapse)AuthorAgeFilesLines
* ctapi-common: Add new recipeQian Lei2014-12-311-0/+23
| | | | | | | | | ctapi-common provides common files and packaging infrastructure for CT-API modules. Port from fedora 20. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* log4cpp: Add new recipePhilip Balister2014-12-311-0/+22
| | | | | | | Built for armv7a basad machine. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dstat: add new recipeLi xin2014-12-311-0/+23
| | | | | | | | | Dstat is a versatile replacement for vmstat, iostat, netstat and ifstat. Dstat overcomes some of their limitations and adds some extra features, more counters and flexibility. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* procmail: Fix license format QA errorOtavio Salvador2014-12-311-1/+1
| | | | | | | | | | | | Fix the following QA error: ,---- | WARNING: Recipe procmail, LICENSE (GPL-2.0 Artistic-1.0) has invalid | format, LICENSES must have operator "([&|() ])" between them. `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libftdi: Fix license format QA errorOtavio Salvador2014-12-311-1/+1
| | | | | | | | | | | | Fix following QA error: ,---- | WARNING: Recipe libftdi, LICENSE (LGPLv2.1 GPLv2) has invalid format, | LICENSES must have operator "([&|() ])" between them. `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libutempter: Fix license format QA errorOtavio Salvador2014-12-311-1/+1
| | | | | | | | | | | | | Fix the following QA error: ,---- | WARNING: Recipe libutempter, LICENSE (GPLv2 GPLv2+ LGPLv2 MIT) has | invalid format, LICENSES must have operator "([&|() ])" between | them. `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* engine-pkcs11: Add new recipeQian Lei2014-12-191-0/+29
| | | | | | | | | Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be loaded using code, config file or command line and will pass any function call by openssl to a PKCS cards and software for using smart cards in PKCS Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mcelog: add new recipeLi xin2014-12-191-0/+28
| | | | | | | mcelog daemon accounts memory and some other errors in various ways. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mailcap: add new recipeLi xin2014-12-191-0/+23
| | | | | | | | | The mailcap file is used by the metamail program. Metamail reads the mailcap file to determine how it should display non-text or multimedia material. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* openwbem: add new recipeLi xin2014-12-199-0/+476
| | | | | | | | | | OpenWBEM is a set of software components that help facilitate deployment of the Common Information Model (CIM) and Web-Based Enterprise Management (WBEM) technologies of the Distributed Management Task Force (DMTF). Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mongodb: blacklist because do_configure failsMartin Jansa2014-12-171-0/+7
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* PNBLACKLIST: use weak assignmentsMartin Jansa2014-12-176-6/+6
| | | | | | | * this makes it easier to unblacklist it from local.conf which is parsed before the recipes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libp11: Add new recipeQian Lei2014-12-171-0/+23
| | | | | | | | libp11 is a library implementing a small layer on top of PKCS make using PKCS Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libjs-sizzle: Add new recipeQian Lei2014-12-171-0/+20
| | | | | | | libjs-sizzle is a pure-javascript CSS selector engine Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libjs-jquery: Add new recipeQian Lei2014-12-171-0/+24
| | | | | | | libjs-jquery is a javascript library for dynamic web application Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libftdi: update to 1.1Raphael Silva2014-12-102-31/+29
| | | | | | | | | | | Previous version was 0.19 but it had a failing recipe due to the fact that libusb was not detect during do_configure. This problem does not happen in version 1.1. Signed-off-by: Mario Goulart <mario.goulart@gmail.com> Signed-off-by: Raphael Silva <rapphil@gmail.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* enca: fix broken automakeAwais Belal2014-12-102-1/+30
| | | | | | | | | The added patch fixes the usage of AM_ICONV macro and comes straight from the Buildroot source tree. Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libutempter: Add new recipeQian Lei2014-12-101-0/+36
| | | | | | | | Libutempter provides interface for terminal emulators such as screen and xterm to record user sessions to utmp and wtmp files. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xmlto: remove recipe as it's in OE coreQi.Chen@windriver.com2014-12-092-30/+0
| | | | | | | Remove xmlto recipe from meta-oe because it's in OE core now. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* daemontools: add recipeBian Naimeng2014-12-094-0/+164
| | | | | | | | | | daemontools is a collection of tools for managing UNIX services. Though daemontools is a very old tool, but it still supported by some distro such as ubuntu(trusty 14.04LTS). Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libcanberra: fix installed-vs-shipped warningRobert Yang2014-12-091-1/+1
| | | | | | | | | | | | | | | | | When build libcanberra for powerpc64 bsp, it shows warning: WARNING: QA Issue: libcanberra: Files/directories were installed but not shipped /lib /lib/systemd /lib/systemd/system /lib/systemd/system/canberra-system-shutdown.service /lib/systemd/system/canberra-system-shutdown-reboot.service /lib/systemd/system/canberra-system-bootup.service [installed-vs-shipped] Update FILES_${PN}-systemd to fix it. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* procmail: add new recipeLi xin2014-12-095-0/+920
| | | | | | | | | | Procmail can be used to create mail-servers, mailing lists, sort your incoming mail into separate folders/files,preprocess your mail, start any programs upon mail arrival or selectively forward certain incoming mail automatically to someone. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* lvm2: add lvm.con to CONFFILESLiu Jian2014-11-241-0/+2
| | | | | | | | | | | * Files will be over written when updating using rpm. * If there is no %config micro before the file in the spec file, this file will be over-written after updating this package using rpm. This will make our settings lost. Signed-off-by: Jian Liu <jian.liu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mariadb: add dependency libeventKang Kai2014-11-241-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | mariadb failed to build: | make[2]: *** No rule to make target '/.../bitbake_build/tmp/sysroots/qemux86-64/usr/lib64/libevent.so', needed by 'tests/async_queries'. Stop. | make[2]: Leaving directory '/.../bitbake_build/tmp/work/core2-64-wrs-linux/mariadb/5.5.40-r0/build' CMakeFiles/Makefile2:6742: recipe for target 'tests/CMakeFiles/async_queries.dir/all' failed | make[1]: *** [tests/CMakeFiles/async_queries.dir/all] Error 2 It is an rare case that when configure mariadb, libevent exists in sysroot. But when do compile for mariadb, libevent is gone somehow. That causes build fails. Run follow commands could reproduce this error: $ bitbake libevent $ bitbake mariadb -c cleansstate $ bitbake mariadb -c configure $ bitbake libevent -c clean $ bitbake mariadb Add if without libevent, test case tests/async_queries.c will not be built. The case is helpful to do unit test. So add libevent as a dependency to fix the error and make sure async_queries.c will be built. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mariadb: re-package configure filesKang Kai2014-11-242-3/+12
| | | | | | | | | | | | | | | | | | | | There are 3 configure files under /etc/my.cnf.d: client.cnf: options for client library mysql-clients.cnf: options for MariaDB tools such as mysqladmin, etc server.cnf: options for server They are packaged to mariadb-leftover at this moment. That is not correct. Split them into sub-packages: client.cnf --> libmysqlclient mysql-clients.cnf --> mariadb-client server.cnf --> mariadb-server Make these files as configure file by CONFFILES and update global configure file my.cnf to include /etc/my.cnf.d as well. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mariadb: Update from version 5.5.39 to 5.5.40Kang Kai2014-11-244-6/+53
| | | | | | | | | | | * rename mariadb_5.5.39.inc -> mariadb.inc * add dependency bision-native for mariadb-native * add revert-fix-for-MDEV-5120.patch to revert an commit for mariadb test suite which causes packages mysql-python and modphp fail to build * add PACKAGECONFIG 'libedit' Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mariadb: Check valgrind headers only if WITH_VALGRIND is setJackie Huang2014-11-242-0/+43
| | | | | | | | | Changes: - Add patch to check valgrind headers only if WITH_VALGRIND is set - Add PACKAGECONFIG for valgrind and disable it by default Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* dfu-util: Point to gitorious.org repository as gnumonks.org is downChris Morgan2014-11-241-3/+6
| | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Chris Morgan <chmorgan@gmail.com>
* smem: add new recipeLi xin2014-11-241-0/+26
| | | | | | | | | | smem is a tool that can give numerous reports on memory usage on Linux systems. Unlike existing tools, smem can report proportional set size (PSS), which is a more meaningful representation of the amount of memory used by libraries and applications in a virtual memory system. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* pam_passwdqc: new recipeLi xin2014-11-243-0/+201
| | | | | | | | | | | | pam_passwdqc is a simple password strength checking module for PAM-aware password changing programs, such as passwd(1). It is capable of checking password or passphrase strength,enforcing a policy, and offering randomly-generated passphrases,with all of these features being optional and easily (re-)configurable. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* tomoyo-tools: Add new recipesQian Lei2014-11-241-0/+29
| | | | | | | | | TOMOYO Linux is a Mandatory Access Control (MAC) implementation for Linux that can be used to increase the security of a system, while also being useful purely as a system analysis tool. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* imagemagick: update 6.8.9 to patchset 9Peter Bigot2014-11-191-3/+3
| | | | | Signed-off-by: Peter A. Bigot <pab@pabigot.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* imagemagick: update URI to allow fetching current and previous releasesPeter Bigot2014-11-191-1/+1
| | | | | | | | The only version available at the original URI is patch 9. All releases are available at the /releases sub-path. Signed-off-by: Peter A. Bigot <pab@pabigot.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* syslog-ng: Fix memory leak when udp connection is used [ LIN7-1379 ]Xufeng Zhang2014-11-195-48/+136
| | | | | | | | | When udp connection is used, there are several memory leaks happen after run a long time. Signed-off-by: Xufeng Zhang <xufeng.zhang@windriver.com> Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libyaml: add fix for CVE-2014-2525 Security AdvisoryKang Kai2014-11-072-1/+45
| | | | | | | | | | | | | Heap-based buffer overflow in the yaml_parser_scan_uri_escapes function in LibYAML before 0.1.6 allows context-dependent attackers to execute arbitrary code via a long sequence of percent-encoded characters in a URI in a YAML file. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-2525 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* postgresql: add fix for CVE-2014-0065 and CVE-2014-0066 Security AdvisoryKang Kai2014-11-072-0/+394
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Coverity identified a number of places in which it couldn't prove that a string being copied into a fixed-size buffer would fit. We believe that most, perhaps all of these are in fact safe, or are copying data that is coming from a trusted source so that any overrun is not really a security issue. Nonetheless it seems prudent to forestall any risk by using strlcpy() and similar functions. Fixes by Peter Eisentraut and Jozef Mlich based on Coverity reports. In addition, fix a potential null-pointer-dereference crash in contrib/chkpass. The crypt(3) function is defined to return NULL on failure, but chkpass.c didn't check for that before using the result. The main practical case in which this could be an issue is if libc is configured to refuse to execute unapproved hashing algorithms (e.g., "FIPS mode"). This ideally should've been a separate commit, but since it touches code adjacent to one of the buffer overrun changes, I included it in this commit to avoid last-minute merge issues. This issue was reported by Honza Horak. Security: CVE-2014-0065 for buffer overruns, CVE-2014-0066 for crypt() https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0065 https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0066 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* postgresql: add fix for CVE-2014-0067 Security AdvisoryKang Kai2014-11-072-0/+76
| | | | | | | | | | | | | | The make check command for the test suites in PostgreSQL 9.3.3 and earlier does not properly invoke initdb to specify the authentication requirements for a database cluster to be used for the tests, which allows local users to gain privileges by leveraging access to this cluster. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0067 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* postgresql: add fix for CVE-2014-0063 Security AdvisoryKang Kai2014-11-072-0/+466
| | | | | | | | | | | | | | | | Multiple stack-based buffer overflows in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to cause a denial of service (crash) or possibly execute arbitrary code via vectors related to an incorrect MAXDATELEN constant and datetime values involving (1) intervals, (2) timestamps, or (3) timezones, a different vulnerability than CVE-2014-0065. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0063 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* postgresql: add fix for CVE-2014-0062 Security AdvisoryKang Kai2014-11-072-0/+1083
| | | | | | | | | | | | | | | Race condition in the (1) CREATE INDEX and (2) unspecified ALTER TABLE commands in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allows remote authenticated users to create an unauthorized index or read portions of unauthorized tables by creating or deleting a table with the same name during the timing window. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0062 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* postgresql: add fix for CVE-2014-0061 Security AdvisoryKang Kai2014-11-072-0/+268
| | | | | | | | | | | | | | The validator functions for the procedural languages (PLs) in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to gain privileges via a function that is (1) defined in another language or (2) not allowed to be directly called by the user due to permissions. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0061 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* postgresql: add fix for CVE-2014-0060 Security AdvisoryKang Kai2014-11-072-0/+274
| | | | | | | | | | | | | | PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 does not properly enforce the ADMIN OPTION restriction, which allows remote authenticated members of a role to add or remove arbitrary users to that role by calling the SET ROLE command before the associated GRANT command. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0060 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* postgresql: add fix for CVE-2014-0064 Security AdvisoryKang Kai2014-11-072-2/+608
| | | | | | | | | | | | | | | Multiple integer overflows in the path_in and other unspecified functions in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to have unspecified impact and attack vectors, which trigger a buffer overflow. NOTE: this identifier has been SPLIT due to different affected versions; use CVE-2014-2669 for the hstore vector. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0064 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mariadb: use ${PN} for SYSTEMD_AUTO_ENABLEChen Qi2014-11-071-1/+1
| | | | | | | | Use ${PN} instead of hardcoding 'mariadb' so that everything works fine in case of multilib. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* fftw: s/PN/BPN/Yue Tao2014-11-071-2/+2
| | | | | | | | | | | | | | Replace the PN with BPN to fix the multilib build. The error is: /ala-lpggp21/bpiolin/intel-x86-64-gplv2-4/bitbake_build/tmp/pkgdata/*/runtime-reverse/lib32-libfftw: No such file or directory Because the PN causes the package is named as lib32-liblib32-fftw. Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mariadb: change socket location in my.cnfChen Qi2014-11-071-2/+2
| | | | | | | | | | | | | | Change socket location to /var/lib/mysql/mysql.sock. Otherwise, we could spot errors in systemd systems like below. mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)' Check that mysqld is running and that the socket: '/tmp/mysql.sock' exists! This is because mysqld.service is using PrivateTmp=true. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* syslog-ng: add gawk to RDEPENDSChong.Lu@windriver.com2014-10-301-0/+1
| | | | | | | | | | This solves the following warning: syslog-ng-3.5.4.1: syslog-ng requires /usr/bin/awk, but no providers in its RDEPENDS [file-rdeps] Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* sharutils: Add new packageHongjun.Yang2014-10-302-0/+47
| | | | | Signed-off-by: Hongjun.Yang <hongjun.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libtinyxml2: new packageA. Varnin2014-10-271-0/+38
| | | | | | | TinyXML-2 is a rewrite of TinyXML-1. It provides some advantages over the original. They are covered on the homepage. (http://www.grinninglizard.com/tinyxml2/) Signed-off-by: A. Varnin <fenixk19@mail.ru> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vim: Upgrade to v7.4.481Paul Barker2014-10-271-1/+1
| | | | | Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* log4c: new packageA. Varnin2014-10-271-0/+16
| | | | | | | Log4c is logging library for C (http://log4c.sourceforge.net/) Signed-off-by: A. Varnin <fenixk19@mail.ru> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>