aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-04-18 18:16:31 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-21 13:31:47 +0200
commit38d45f7446d845b9c19367d7b17c4625537a1101 (patch)
tree8168904f80498a5526d512fa5c2fee607ccd3c01
parent9dfa0411e01bd23df4994627fa0280c407a1aac9 (diff)
downloadmeta-openembedded-38d45f7446d845b9c19367d7b17c4625537a1101.tar.gz
vim: don't check acl header if acl support disabled
Vim/vim-tiny always check 'sys/acl.h' existence even acl support has been disabled from configure line. This works in mostly time but except for acl works in an odd mode - while acl was mirrored from sstate_cache, it will install 'sys/acl.h' to sysroot dir and and then clean the header file with sysroot_cleansstate(). If build vim/vim-tiny and acl in parallel, below errors will occur: * os_unix.c:2668:23: fatal error: sys/acl.h: No such file or directory This change only workaround the failure and get build running, we still need to fix it from acl side. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/vim/files/disable_acl_header_check.patch27
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.258.bb4
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
new file mode 100644
index 0000000000..8f824e78b0
--- /dev/null
+++ b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
@@ -0,0 +1,27 @@
+Upstream-Status: pending
+
+Don't check 'sys/acl.h' if acl support disabled for vim/vim-tiny.
+
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+================================================
+diff --git a/src/configure.in b/src/configure.in
+index fb965e5..d734064 100644
+--- a/src/configure.in
++++ b/src/configure.in
+@@ -2511,7 +2511,7 @@ AC_CHECK_HEADERS(stdarg.h stdint.h stdlib.h string.h \
+ sys/systeminfo.h locale.h sys/stream.h termios.h \
+ libc.h sys/statfs.h poll.h sys/poll.h pwd.h \
+ utime.h sys/param.h libintl.h libgen.h \
+- util/debug.h util/msg18n.h frame.h sys/acl.h \
++ util/debug.h util/msg18n.h frame.h \
+ sys/access.h sys/sysinfo.h wchar.h wctype.h)
+
+ dnl sys/ptem.h depends on sys/stream.h on Solaris
+@@ -3112,6 +3112,7 @@ AC_ARG_ENABLE(acl,
+ , [enable_acl="yes"])
+ if test "$enable_acl" = "yes"; then
+ AC_MSG_RESULT(no)
++AC_CHECK_HEADERS(sys/acl.h)
+ AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"],
+ AC_CHECK_LIB(acl, acl_get_file, [LIBS="$LIBS -lacl"
+ AC_CHECK_LIB(attr, fgetxattr, LIBS="$LIBS -lattr",,)],,),)
diff --git a/meta-oe/recipes-support/vim/vim_7.4.258.bb b/meta-oe/recipes-support/vim/vim_7.4.258.bb
index 023e8fc6c5..9c6e231ad1 100644
--- a/meta-oe/recipes-support/vim/vim_7.4.258.bb
+++ b/meta-oe/recipes-support/vim/vim_7.4.258.bb
@@ -6,7 +6,9 @@ RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8"
-SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim"
+SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \
+ file://disable_acl_header_check.patch;patchdir=.. \
+"
SRCREV = "v7-4-258"
S = "${WORKDIR}/${PN}/src"