aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-04-23 03:26:27 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-03 20:45:02 +0200
commit846ab65cfed72c1cdba465e51ed40d3a9fb6b690 (patch)
treef96112b349be09090c380e43b560ad6d0aa79a47
parent2112e618f28df5d5eeae9679c045ab8f5914e50e (diff)
downloadmeta-openembedded-846ab65cfed72c1cdba465e51ed40d3a9fb6b690.tar.gz
gd: split the binaries to package gd-tools
As most linux distribution do, gd only includes the library, and split all the command line tools into gd-tools, and add the perl dependcy since one of the tools is a perl script. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/gd/gd_2.1.0.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.1.0.bb b/meta-oe/recipes-support/gd/gd_2.1.0.bb
index a260cd67be..d92e6395f8 100644
--- a/meta-oe/recipes-support/gd/gd_2.1.0.bb
+++ b/meta-oe/recipes-support/gd/gd_2.1.0.bb
@@ -30,3 +30,12 @@ EXTRA_OECONF += " --disable-rpath \
--without-x"
EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+FILES_${PN}-tools = "${bindir}/*"
+
+PROVIDES += "${PN}-tools"
+RPROVIDES_${PN}-tools = "${PN}-tools"
+RDEPENDS_${PN}-tools = "perl perl-module-strict"