aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-03-30 17:44:17 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-21 13:31:47 +0200
commit8b29bc67af47e3f6ca272731e5ccf1ff1c59b14c (patch)
tree0a97a56f5396ef679dccdfbbe09426c62ef37a34
parent72b21ffad37e520da3e10fe91bf3246774da0e46 (diff)
downloadmeta-openembedded-8b29bc67af47e3f6ca272731e5ccf1ff1c59b14c.tar.gz
gnuplot: upgrade to 4.6.5
* automake patch from 4.4.4 is no longer needed * PACKAGECONFIG for lua (lua term is only useful for LaTeX) * linking problems with dlopen, etc. in lua loadlibs.c fixed ** this same problem was seen in jansa world builds for 4.4.4 ** I am not able to replicate that error on 4.4.4 NOTE: qt is supported by this version, but I was not able to figure out the configuration... Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch44
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch16
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/subdirs.patch (renamed from meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/subdirs.patch)0
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot.inc1
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot_4.6.5.bb (renamed from meta-oe/recipes-extended/gnuplot/gnuplot_4.4.4.bb)8
5 files changed, 20 insertions, 49 deletions
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch b/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch
deleted file mode 100644
index 51f703ce28..0000000000
--- a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/automake-1.12.x.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Upstream-Status: Backport
-
-It's fixed in 4.6 and 4.7(HEAD)
-
-http://sourceforge.net/tracker/?func=detail&aid=3523591&group_id=2055&atid=102055
-
-diff -uNr gnuplot-4.4.4.orig/Makefile.am gnuplot-4.4.4/Makefile.am
---- gnuplot-4.4.4.orig/Makefile.am 2012-07-20 10:54:49.075828905 +0200
-+++ gnuplot-4.4.4/Makefile.am 2012-07-20 10:55:22.380831313 +0200
-@@ -1,5 +1,5 @@
- ## Process this file with automake to produce Makefile.in -*-Makefile-*-
--AUTOMAKE_OPTIONS = foreign 1.2h
-+AUTOMAKE_OPTIONS = foreign
-
- SUBDIRS = config m4 term src $(LISPDIR) man share
-
-diff -uNr gnuplot-4.4.4.orig/configure.in gnuplot-4.4.4/configure.in
---- gnuplot-4.4.4.orig/configure.in 2011-09-02 06:09:40.000000000 +0200
-+++ gnuplot-4.4.4/configure.in 2012-07-20 10:55:53.289833224 +0200
-@@ -16,10 +16,11 @@
- dnl configure.in body
-
- dnl Compiler characteristics
--dnl Check for ANSI C prototypes, the const and inline keywords,
--dnl and ANSI style stringification
-+dnl Check for the const and inline keywords and ANSI style stringification
-+dnl automake 1.12 dropped support for AM_C_PROTOTYPES and ansi2knr
-+dnl But our code still tests for #ifdef PROTOTYPES, so define it here
-+AC_DEFINE(PROTOTYPES,1,[Automake 1.12 dropped support for building without prototypes])
- AC_PROG_CC
--AM_C_PROTOTYPES
- AC_PROG_CPP
- AC_C_CONST
- AC_C_INLINE
-diff -uNr gnuplot-4.4.4.orig/src/Makefile.am gnuplot-4.4.4/src/Makefile.am
---- gnuplot-4.4.4.orig/src/Makefile.am 2010-10-06 06:53:16.000000000 +0200
-+++ gnuplot-4.4.4/src/Makefile.am 2012-07-20 10:56:02.376834548 +0200
-@@ -1,5 +1,5 @@
- ## Process this file with automake to produce Makefile.in -*-Makefile-*-
--AUTOMAKE_OPTIONS = ansi2knr foreign 1.2h
-+AUTOMAKE_OPTIONS = foreign
-
- # in the spirit of automake ...
- pkglibexecdir = $(libexecdir)/@PACKAGE@/@VERSION_MAJOR@
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch
new file mode 100644
index 0000000000..23f2cd26a5
--- /dev/null
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/lua-loadlibs-configure-in-fix.patch
@@ -0,0 +1,16 @@
+Index: gnuplot-4.6.5/configure.in
+===================================================================
+--- gnuplot-4.6.5.orig/configure.in
++++ gnuplot-4.6.5/configure.in
+@@ -690,6 +690,11 @@ if test "${with_lua}" = yes ; then
+ fi
+
+ if test "$with_lua" != no; then
++ dnl check for dlopen/dl to fix loadlibs link failure
++ AC_CHECK_FUNC([dlopen], [],
++ AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
++ AC_SUBST(DLOPEN_LIBS)
++ LUA_LIBS="$LUA_LIBS $DLOPEN_LIBS"
+ TERMLIBS="$TERMLIBS $LUA_LIBS"
+ CPPFLAGS="$CPPFLAGS $LUA_CFLAGS"
+ else
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/subdirs.patch b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/subdirs.patch
index 8c7d1f0d35..8c7d1f0d35 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot-4.4.4/subdirs.patch
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot-4.6.5/subdirs.patch
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot.inc b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
index 96d6ee2cc0..ab3ec3fbba 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot.inc
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
@@ -12,6 +12,7 @@ acpaths = ""
PACKAGECONFIG ??= "cairo"
PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango"
+PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
--without-lisp-files \
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot_4.4.4.bb b/meta-oe/recipes-extended/gnuplot/gnuplot_4.6.5.bb
index 4ea312fea0..8a5bca964d 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot_4.4.4.bb
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot_4.6.5.bb
@@ -1,16 +1,14 @@
require gnuplot.inc
-PR = "r1"
-
SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz;name=archive \
http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \
file://subdirs.patch \
+ file://lua-loadlibs-configure-in-fix.patch \
file://gnuplot.desktop \
file://gnuplot.png \
- file://automake-1.12.x.patch \
"
-SRC_URI[archive.md5sum] = "97a43328e81e57ebed7f135ca0c07e82"
-SRC_URI[archive.sha256sum] = "d228599d08d5f87bcb79af8af8bb432c77d942802b1643f920c7baaeaf1ddbfd"
+SRC_URI[archive.md5sum] = "9a476b21f74bd99c876f1509d731a0f9"
+SRC_URI[archive.sha256sum] = "e550f030c7d04570e89c3d4e3f6e82296816508419c86ab46c4dd73156519a2d"
SRC_URI[qtplot.md5sum] = "0a481885a496092c77eb4017540b5cf6"
SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132"