aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-30 17:32:23 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-31 17:30:13 +0200
commitb2a70421756ef2cc7d59c82fb4cd02141e99a52c (patch)
tree961e3495079ddc941a593b870ce6082d159c2435
parent658bd7ef32390e5d364fb41ba93363b5ee8eeb3b (diff)
downloadmeta-openembedded-b2a70421756ef2cc7d59c82fb4cd02141e99a52c.tar.gz
xserver-xorg: upgrade from 1.10.1.902 to 1.10.2 and replace part of randr-support.patch with upstream patch
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch61
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-assume-pixman-supports-overlapped-blt.patch)0
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-fbdev-ignore-return-mode.patch)0
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/randr-support.patch)41
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/replace-pkgconfig-sdkdir-poking.patch (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/replace-pkgconfig-sdkdir-poking.patch)0
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.2.bb (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.901.bb)9
6 files changed, 72 insertions, 39 deletions
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch
new file mode 100644
index 0000000000..2c4078a001
--- /dev/null
+++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch
@@ -0,0 +1,61 @@
+From 50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd Mon Sep 17 00:00:00 2001
+From: Aaron Plattner <aplattner@nvidia.com>
+Date: Tue, 24 May 2011 23:02:42 +0000
+Subject: randr: check rotated virtual size limits correctly
+
+Commit d1107918d4626268803b54033a07405122278e7f introduced checks to
+the RandR path that cause RRSetScreenConfig requests to fail if the
+size is too large. Unfortunately, when RandR 1.1 rotation is enabled
+it compares the rotated screen dimensions to the unrotated limits,
+which causes 90- and 270-degree rotation to fail unless your screen
+happens to be square:
+
+ X Error of failed request: BadValue (integer parameter out of range for operation)
+ Major opcode of failed request: 153 (RANDR)
+ Minor opcode of failed request: 2 (RRSetScreenConfig)
+ Value in failed request: 0x780
+ Serial number of failed request: 14
+ Current serial number in output stream: 14
+
+Fix this by moving the check above the code that swaps the dimensions
+based on the rotation.
+
+Signed-off-by: Aaron Plattner <aplattner@nvidia.com>
+Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
+Tested-by: Robert Hooker <robert.hooker@canonical.com>
+Tested-by: Kent Baxley <kent.baxley@canonical.com>
+Signed-off-by: Keith Packard <keithp@keithp.com>
+(cherry picked from commit b6c7b9b2f39e970cedb6bc1e073f901e28cb0fa3)
+---
+diff --git a/randr/rrscreen.c b/randr/rrscreen.c
+index 1bc1a9e..da6d48d 100644
+--- a/randr/rrscreen.c
++++ b/randr/rrscreen.c
+@@ -910,12 +910,6 @@ ProcRRSetScreenConfig (ClientPtr client)
+ */
+ width = mode->mode.width;
+ height = mode->mode.height;
+- if (rotation & (RR_Rotate_90|RR_Rotate_270))
+- {
+- width = mode->mode.height;
+- height = mode->mode.width;
+- }
+-
+ if (width < pScrPriv->minWidth || pScrPriv->maxWidth < width) {
+ client->errorValue = width;
+ free(pData);
+@@ -927,6 +921,12 @@ ProcRRSetScreenConfig (ClientPtr client)
+ return BadValue;
+ }
+
++ if (rotation & (RR_Rotate_90|RR_Rotate_270))
++ {
++ width = mode->mode.height;
++ height = mode->mode.width;
++ }
++
+ if (width != pScreen->width || height != pScreen->height)
+ {
+ int c;
+--
+cgit v0.8.3-6-g21f6
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-assume-pixman-supports-overlapped-blt.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch
index a947582f15..a947582f15 100644
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-assume-pixman-supports-overlapped-blt.patch
+++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-fbdev-ignore-return-mode.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch
index d3661cbea2..d3661cbea2 100644
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-fbdev-ignore-return-mode.patch
+++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/randr-support.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch
index d870f3972e..632a64ce52 100644
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/randr-support.patch
+++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch
@@ -39,22 +39,22 @@ diff -ur xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c git/xorg-server-
+ case RR_Rotate_0:
+ swap_axes = 1;
+ invert[0] = 0;
-+ invert[1] = 0;
++ invert[1] = 0;
+ break;
+ case RR_Rotate_90:
+ swap_axes = 0;
+ invert[0] = 0;
-+ invert[1] = 1;
++ invert[1] = 1;
+ break;
+ case RR_Rotate_180:
+ swap_axes = 1;
-+ invert[0] = 0;
-+ invert[1] = 0;
++ invert[0] = 1;
++ invert[1] = 1;
+ break;
+ case RR_Rotate_270:
+ swap_axes = 0;
-+ invert[0] = 0;
-+ invert[1] = 1;
++ invert[0] = 1;
++ invert[1] = 0;
+ break;
+ }
+
@@ -100,32 +100,3 @@ diff -ur xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c git/xorg-server-1.1
return ret;
}
-diff -ur xorg-server-1.10.1.901//randr/rrscreen.c git/xorg-server-1.10.1.901//randr/rrscreen.c
---- xorg-server-1.10.1.901//randr/rrscreen.c 2011-02-25 04:27:32.000000000 +0100
-+++ git/xorg-server-1.10.1.901//randr/rrscreen.c 2011-05-18 23:19:39.007760004 +0200
-@@ -910,11 +910,6 @@
- */
- width = mode->mode.width;
- height = mode->mode.height;
-- if (rotation & (RR_Rotate_90|RR_Rotate_270))
-- {
-- width = mode->mode.height;
-- height = mode->mode.width;
-- }
-
- if (width < pScrPriv->minWidth || pScrPriv->maxWidth < width) {
- client->errorValue = width;
-@@ -926,7 +921,12 @@
- free(pData);
- return BadValue;
- }
--
-+ if (rotation & (RR_Rotate_90|RR_Rotate_270))
-+ {
-+ width = mode->mode.height;
-+ height = mode->mode.width;
-+ }
-+
- if (width != pScreen->width || height != pScreen->height)
- {
- int c;
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/replace-pkgconfig-sdkdir-poking.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/replace-pkgconfig-sdkdir-poking.patch
index 3967c4c738..3967c4c738 100644
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/replace-pkgconfig-sdkdir-poking.patch
+++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/replace-pkgconfig-sdkdir-poking.patch
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.901.bb b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.2.bb
index 0515a34da8..06a97f931e 100644
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.901.bb
+++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.2.bb
@@ -7,16 +7,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=74df27b6254cc88d2799b5f4f5949c00"
DESCRIPTION = "the X.Org X server"
DEPENDS += "mesa-dri pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native"
PE = "2"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.0"
SRC_URI += " \
+ file://50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch \
file://randr-support.patch \
file://hack-fbdev-ignore-return-mode.patch \
file://hack-assume-pixman-supports-overlapped-blt.patch \
file://replace-pkgconfig-sdkdir-poking.patch \
"
-SRC_URI[md5sum] = "64585a28abb18726d950cf1005bbcce4"
-SRC_URI[sha256sum] = "b7d775891e7e7fc3001763cf5727995b81bf07b72e12d9d41db282fe625298e6"
+SRC_URI[md5sum] = "c9ba50bd44ea70da51f13100336a5484"
+SRC_URI[sha256sum] = "65264f6640568b9db8d738aec1ddd036c3ae21b7ba05b98d006759d11a72792c"
do_install_prepend() {
mkdir -p ${D}/${libdir}/X11/fonts
@@ -26,7 +27,7 @@ do_install_prepend() {
PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
-EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
+EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
EXTRA_OECONF += " --enable-dri2 --disable-unit-tests --disable-docs --disable-devel-docs"
export LDFLAGS += " -ldl "